Results 1 to 15 of 15
  1. garyscoco's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    Thread AuthorThread Author   #1  

    Angry Trackpad Not Clicking

    Hi guys! ive had this phone for three months now. the past week i have been encountering issues with this trackpad. it scrolls but it wont click!!! if i keep pressing it, it clicks once or twice. other than that it doesnt! did battery pulls etc still nothing! my warranty has expired! what should i do?!
  2. TheRealFixxxer's Avatar
    CrackBerry Abuser

    Posts
    133 Posts
    PIN
    Feel free to ask.
    #2  

    Default

    How did your warranty expire after 3 months? I was under the impression that it was a 12 month warranty.

    I suppose I should ask where you bought it. Was it new or used?
  3. PALeafs67's Avatar
    CrackBerry Addict

    Posts
    587 Posts
    PIN
    28519AFC
    #3  

    Default

    Did you Upgrade the OS at all or still original.. i had a similar problem where the track pad would scroll up but not down kinda got stuck.
    As soon as i upgraded the OS it fixed that issue.
    Paul Atherton
  4. Bilaal's Avatar
    CrackBerry Genius

    Posts
    2,143 Posts
    Global Posts
    2,149 Global Posts
    #4  

    Default

    Wow, I didn't know updating the OS would help a trackpad issue. That is, if the trackpad ACTUALLY doesn't allow the person to "press" it in, physically. If you can do so, but the phone doesn't respond to the pressing of the button, then updating the OS might be the solution. If you have the latest build/leak installed, wipe it and install it again!

    Good luck, pal.
  5. PALeafs67's Avatar
    CrackBerry Addict

    Posts
    587 Posts
    PIN
    28519AFC
    #5  

    Default

    The track pad i found was very sensitive and would do things with out me touching it as soon as i upgraded i have had no further issues the phone is running great now for the past two weeks.... Running Leaked OS7.1.0.258...
    Paul Atherton
  6. -BlueBerry's Avatar
    CrackBerry User

    Posts
    14 Posts
    PIN
    Will give it if I get to know you(:
    #6  

    Default

    You could try updating the OS version, if that doesn't work then you might have dirt or something stuck underneath the trackpad, hence causing clicking to be a problem.
  7. Kridiot's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #7  

    Default

    I'm having the exact same problem. I can scroll with my trackpad fine, but it won't click. Now instead of clicking any time I push the trackpad, I usually have to press it about 10 times before it actually clicks enter. Did anyone find a solution to this?!

    I have a Curve 9360 version 7.1.0 Bundle 1647 and it says it's all up to date. I don't know why it's not working :/
  8. Kris308's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #8  

    Default

    same issue here, i have to press the trackpad atleast twice or thrice to open up an icon..pretty frustrating.Thinking of getting the hardware checked
  9. derick234's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #9  

    Default Trackpad Not Clicking

    mind had same issue couple of weeks ago but since i updated it, it stop giving such problems! try and update urs!

    Sent from my BlackBerry 9360 using Tapatalk
  10. muss429's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #10  

    Default

    I am having this same issue, trackpad will move around fine but won't click. How can I update the os if I cannot click anything? Im not very good with blackberry phones.
  11. Crime's Avatar
    CrackBerry Abuser

    Posts
    163 Posts
    #11  

    Default

    u can update the OS via pc.... therefore u don't hav to click on the phone.. everything is done via pc.

    on another note I noticed my trackpad was very sensitive when I jus got the phone....but now it seems a lil slow to respond. I always try to make sure my fingers don't hav no sort of residue on them. so im not sure as to why the sudden "lag"
  12. Lesley Horner's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #12  

    Default help

    you can't do everything on the pc..my trackpad doesn't work at all and i updated some apps including facebook and now i have to click on ' i agree' on the license agreement on my phone.... is there a workaround or shortcut keys i can use for this?
  13. catholiclibertarian's Avatar
    CrackBerry Abuser

    Posts
    110 Posts
    PIN
    33317b2E
    #13  

    Default

    Have you tried cleaning it with a dry Towel? I was surprised that this fized my problem when I was like you.

    Sent from my BlackBerry 9370 using Tapatalk
  14. Jordan Kent's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #14  

    Default

    Yeah i had the same issue with my 9700. I took it apart, and the connection of the track pad wasn't fully connected to the back of the mother board, so i just clicked it in, cleaned the inside of the phone a bit, put it back together, and bam! She's working just fine!
  15. blackberryuser14's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #15  

    Default trackpad isnt allowing me to click anything;

    hi my trackpad isnt allowing me to click anything; it lets me move around. ive reset it about 5 times left it off and everything; still not working.


    HELP PLEASE

Posting Permissions