1. Nick9581's Avatar
    Hey, so basically I bought my blackberry in november and since then I don't have 3G, I do get Wi-Fi, I do get the 3G sign on top too but nothing, even BBM is not working with the new update it keeps on "associating BBM with BlackBerry ID" I went on host routing table and tried to register but they never sent me a message and I don't have a enterprise account too, does it have anything to do with it ? Could you help ?

    Thanks

    Just saying but I do have 1gb of data
    01-02-13 03:11 PM
  2. SwitchBeach's Avatar
    What carrier?
    What country?
    Do you have a BLACKBERRY Data Plan (and a generic smartphone data plan)?
    Are you logged in with your BlackBerry ID?
    01-02-13 04:54 PM
  3. Nick9581's Avatar
    My carrier is Talkmobile and i live in London.
    On the offer it says free BBM so i think i have a BlackBerry data plan and i am connected with my blackberry id. And also when i go to app store they tell me i can't download anything because they can't get a new token because of offline state
    01-02-13 05:22 PM
  4. SwitchBeach's Avatar
    Contact the carrier and verify that they set up the proper data plan for the device and that the device is active on their BIS.
    01-02-13 07:07 PM
  5. Taigatrommel's Avatar
    Sounds like a carrier glitch. You should really talk to your carrier support, just like SwitchBeach I think your device is not really registered on their BIS system.
    01-03-13 06:01 PM

Similar Threads

  1. Blackberry internet...but no email or bbm
    By philo in forum T-Mobile
    Replies: 7
    Last Post: 04-25-10, 09:01 PM
  2. HELP! unlocked verizon storm 2, using rogers network... NO 3G? OR BLUETOOTH??
    By cocochanel12 in forum General BlackBerry Discussion
    Replies: 4
    Last Post: 01-07-10, 04:25 PM
  3. 8310 on fido, no email or bbm
    By bggr0 in forum Fido
    Replies: 4
    Last Post: 11-22-09, 10:14 PM
  4. No 3G or BIS Logo
    By pink2 in forum AT&T
    Replies: 19
    Last Post: 04-11-09, 05:14 PM
  5. No 3G or EDGE on my phone. What's wrong?!
    By mweglarz0 in forum Apple iPhone/iPad
    Replies: 2
    Last Post: 08-04-08, 07:53 PM
LINK TO POST COPIED TO CLIPBOARD