Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 32
  1. raunakj's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #1  

    Default Curve 8900 not responding

    All of the buttons, including the keyboard and side buttons, have stopped working. The select ball still scrolls, but when I push down on it, it will not select anything. I've taken the battery out to restart my phone, but the buttons are still not working. What can I do?
  2. aristile's Avatar
    CrackBerry Genius of Geniuses

    Posts
    8,455 Posts
    Global Posts
    8,458 Global Posts
    #2  

    Default

    Sounds like you have gotten water damage on yourr phone.
  3. fatboy97's Avatar
    CrackBerry Genius of Geniuses

    Posts
    8,701 Posts
    Global Posts
    12,984 Global Posts
    #3  

    Default

    I don't want to make light of this, but did you put the battery back in the phone, and did it look like it booted up ok?
  4. raunakj's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #4  

    Default

    There is no water damage as far as I know.....

    What can i do to get it to work? Will a software update help?
  5. raunakj's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    Thread AuthorThread Author   #5  

    Default

    Yes I have put the battery and sim back in the phone and it does boot up ok till the home screen after which I am unable to do anything as the trackball cannot be clicked and none of the buttons respond on being pressed
  6. ClintRo's Avatar
    CrackBerry Genius of Geniuses

    Posts
    9,820 Posts
    Global Posts
    10,061 Global Posts
    PIN
    323E1E5A
    #6  

    Default

    Try this... it was an issue with the 8120 and this worked for my daughters phone.... Pull the battery and leave it out overnight....then try it in the morning....

    She had the exact same symptoms and this fixed it.
    Collect coins or want extra income??? https://www.numisnetwork.com/CER

    I'll Stop procrastinating tomorrow!!
  7. thebignewt's Avatar
    CrackBerry Genius

    Posts
    1,783 Posts
    Global Posts
    2,178 Global Posts
    #7  

    Default

    A little more info: how long have you had it, have you installed any apps or themes, if it worked fine for how long did it work?
    Samsung Galaxy Nexus, iPad2 and iMac. Former BB 8100 and 8900 owner.
  8. fatboy97's Avatar
    CrackBerry Genius of Geniuses

    Posts
    8,701 Posts
    Global Posts
    12,984 Global Posts
    #8  

    Default

    Themes was my next guess... did you download one recently???

    Press the "O" key and see if Options opens up > Themes > switch back to a theme that was shipped with your 8900... then exit and see if your buttons work... if not do another battery pull and see what happens.
  9. rbremner's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #9  

    Default

    I have the same problem right now. any sugestion?
  10. CatAlex's Avatar
    CrackBerry Master

    Posts
    1,300 Posts
    PIN
    up grrrrrl
    #10  

    Default

    Something weird like this happened to me before too. It was right after I'd downloaded a 3rd party app. I connected to DM and uninstalled the app, rebooted, and voila - my phone was fine.

    Posted from my CrackBerry at wapforums.crackberry.com
  11. rbremner's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #11  

    Default

    I follow more or less the advice of ClinRo: without battery for about 1 hour and it came back to life...
  12. archagnel991's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #12  

    Default

    I have the same problem too, no water damage, i did a Full system restore, pulled out the sim chip, pulled out the memory card, and still no dice, any solutions?
  13. tbag80's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #13  

    Default Similar Problem with 8900

    I too am having the issue with the 8900 not responding to any inputs. The trackball moves and occasionaly the convenience keys will respond, but beyond that there is no response. It will clear up for a short while after an hour + battery pull. I definitely have not added any apps nor is there any water damage. This must be a software glitch and clearly not an isolated event. Is there any way to update software the software and perhaps solve this really annoying glitch?
  14. fatboy97's Avatar
    CrackBerry Genius of Geniuses

    Posts
    8,701 Posts
    Global Posts
    12,984 Global Posts
    #14  

    Default

    Quote Originally Posted by tbag80 View Post
    I too am having the issue with the 8900 not responding to any inputs. The trackball moves and occasionaly the convenience keys will respond, but beyond that there is no response. It will clear up for a short while after an hour + battery pull. I definitely have not added any apps nor is there any water damage. This must be a software glitch and clearly not an isolated event. Is there any way to update software the software and perhaps solve this really annoying glitch?
    First post... you should get to know your device... do a battery pull once a week will help a great deal: leave your device on, pull the battery for 20 seconds, put it back in, wait for your device to boot up.

    Next, do a lot of reading on the topic of OS upgrades... the first one, check out the Blackberry 101 lesson on the subject... it's located under the "Blackberry Help" dropdown menu at the top of every forum page... the second one is the upgrade/downgrade procedure link in my signature below.

    You should know your device before you upgrade it!!!
  15. cjarauj's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #15  

    Talking Same problem

    hey guys i have a 8900 and im also having the same problem, the keyboard wont work at all. the only thing that works is the trackball but only side to side and when i push it, wont do anything.... any sugestions?
  16. Snypa's Avatar
    CrackBerry Abuser

    Posts
    183 Posts
    #16  

    Default

    ran into the same proble since night. No clue whats going on here.
  17. opiapr's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #17  

    Default same here with 8900

    I am having the exact same issue with my Curve 8900 it started happening out of the blue. I haven't installed anything new for weeks and have the default theme. No water damage or drops either. The only thing working is the scroll but only for scrolling.

    I have try about everything. Full system restore battery off overnight and nothing.
  18. thabruiser41's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #18  

    Default

    ANY SOLUTION TO THIS??? I am having exact same problem. Just began today after a phone call was ended....
  19. PhunkmasterX's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #19  

    Default

    I am on my second 8900 and this has now happened for the second time. The first time the buttons were unresponsive for two days so I called Blackberry and they sent me a new phone. When I received the new phone I packaged the old phone for return and it was working fine. Oops. Now the new phone has started doing the same thing and I may know what it is. I was talking on the phone outside on a hot day for about an hour. All of a sudden the audio began sounding like the other person was in a tunnel. I ended the call and noticed a fair amount of sweat on the screen. At this point the buttons were unresponsive. Two days later the phone is still not working. I guess the sweat seeped into the keyboard and caused the problem. However, I would have assumed that it would have dried out by now, yet it still doesn't work. I'll give it another couple of days before I call again, but this is seriously getting frustrating. Hope this helps anyone else with this problem.
  20. cabletow's Avatar
    CrackBerry Addict

    Posts
    633 Posts
    #20  

    Default

    I have just posted another thread about this - no apps loaded, no water damage phone over a year old and the keyboard just tops responding. Clearly this is an 8900 issue.


    Any suggestions - long battery pulls and system restores not successful

    Posted from my CrackBerry at wapforums.crackberry.com
  21. achiquitachaser's Avatar
    CrackBerry Abuser

    Posts
    380 Posts
    Global Posts
    431 Global Posts
    #21  

    Default

    I had the exact same problem with my old curve 8900. I bought mine off craigslist, there wasn't any sign of water damage (the indicators looked fine). However 2 days later the berry locked up just like everyone else's. I tried the oven trick, worked fine for a couple hours and then locked up. Since I upgraded to a 9700 and that was about 6 months ago.

    Recently pulled it out of a drawer and it will work fine without a sim card, but as soon as a sim card is in there it locks up (and I have tried cleaning the contacts and trying other sim cards). I have to believe that the 8900 was not sealed the best to prevent sweat damage through the keypad since alot of people are having/had this issue.
  22. Nokazar's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #22  

    Default

    I have the same problem today.

    - the device can be rebooted. But right after it entered home screen, the phone becomes not responding. No matter how I tried to put any buttons.
    - Cannot connect to Desktop Manager at all.

    I believe it happened because of a theme. I installed a theme from official Blackberry App World. Because the problem occurs once after I rebooted my phone after the thme was installed.

    Crossing my fingers for the solution. Many thanks.
  23. gregerator's Avatar
    CrackBerry Genius

    Posts
    2,775 Posts
    PIN
    T anyone?
    #23  

    Default

    Had 2 8900s with the same problem. Call it a known issue. I replaced them on my insurance. Replace$ent is the only known solution. Sorry.

    Posted from my CrackBerry at wapforums.crackberry.com
  24. ac01908zzz's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #24  

    Default

    im having the same problem with my phone. yesterday the keyboard was playing up, when i clicked 'delete', it would send, random letters kept coming up etc. so i did a battery pull and now none of the buttons on my phone are working.

    the actual phone is functioning fine, i can still receive messages and phone calls. but i cant do anything with it! the trackerball still scrolls but i cant click with it.

    im sure it's not water damage since this happened when id been home the whole day and the sticker on the battery is still white. what can i do? iv tried leaving it in rice but it's still not working. iv heard that you can try putting it in the oven, do you think this will work? im desperate for a solution since i have a few months left on my contract but my warranty is out and i dont have insurance :S
  25. gelaigurl05's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    #25  

    Default

    after downloading a couple of themes from bb app world, my 8900 freezes on the home screen.

    i cant even get on the main menu. i tried shift alt delete thing and it restarted, but after boot up its still stuck on the homescreen. i did several battery pulls already and still no luck.

    too bad i dont have my usb cable now... will have to wait til later so i can try it on the DM.
Page 1 of 2 12 LastLast

Posting Permissions