Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 54
Like Tree1Likes
  1. maxiime223's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    Thread AuthorThread Author   #1  

    Default Wifi connection, but can't use internet...

    Hello, I own an unlocked blackberry curve 8520, using a SIM card with Fido Canada(I don't have a data plan).
    My phone is connected to my home WiFi, I had no problems doing it. However, when I try to open the browser, it say : " unable to connect to internet, please try again later. If the problem persists please contact your service provider."

    I tried playing with the settings but could figure it out. Anyone could help me?
  2. step12's Avatar
    CrackBerry Abuser

    Posts
    153 Posts
    Global Posts
    157 Global Posts
    #2  

    Default

    You need to change the browser to hotspot browser...You do this by opening the browser--->options-->browser configuration...then change the browser option to Hotspot browser
    The choices that you make governs the consequences that you face


    Common sense is common but the use of common sense is not so common


    If I helped you, please don't forget to press the thank you button
    Thanked by:
    Tttexast (01-18-2013) 
  3. maxiime223's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    Thread AuthorThread Author   #3  

    Default

    It still doesnt work... any other idea?

    btw, I know that the problem isnt my router, I've got three laptops connected to it...
  4. Motorcycle Mama's Avatar
    CrackBerry Genius of Geniuses

    Posts
    10,170 Posts
    Global Posts
    10,172 Global Posts
    #4  

    Default

    You need an active BlackBerry Data Plan.
  5. Reed McLay's Avatar
    Retired Moderator

    Posts
    9,473 Posts
    #5  

    Default

    You can double check your setting at:

    Browser / Options / Browser Configuration.

    If it is set to Internet Browser, it needs the BlackBerry Internet Service (BIS) plan.

    If it is set to Hotspot Browser, it should work.
    Thanked by:
    Tttexast (01-18-2013) 
  6. Jonathan-Archer's Avatar
    CrackBerry Abuser

    Posts
    418 Posts
    #6  

    Default

    I've got a question about the Hotspot Browser configuration; does this also mean it'll connect to BIS or does it just enable the phone to go onto the internet only via the browser?
  7. littona's Avatar
    CrackBerry Abuser

    Posts
    319 Posts
    Global Posts
    322 Global Posts
    #7  

    Default

    Hotspot bypasses BIS.

    Posted from my CrackBerry at wapforums.crackberry.com
  8. dylanleopold's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    Global Posts
    2 Global Posts
    #8  

    Default Re: Wifi connection, but can't use internet...

    i went into mobile network and data services was turned off and i turned it off and it worked for me
    Thanked by:
    Ghufran Jalil (08-31-2013) 
    Ghufran Jalil likes this.
  9. toodle_pip's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #9  

    Default

    When I bought my 8520 I thought I could connect to any Wi Fi network WITHOUT a dataplan.
    However I have since discovered this is not the case. It works okay at home but only intermittently out and about. This is not good enough for my purposes.
    I don't want a phone with a massive screen because I am afraid it will get broken, nor one which is bulky in my pocket like a brick!
    Please can someone suggest a different model of Blackberry I can get which will allow me to surf through Wi Fi without a data contract?
    Thanks in advance.
  10. SwitchBeach's Avatar
    CrackBerry Genius

    Posts
    2,734 Posts
    Global Posts
    2,988 Global Posts
    #10  

    Default

    You will need a data plan in order to surf even over WiFi. If that's not what you want to do, then you need something other than a BlackBerry.
  11. 59Martins59's Avatar
    CrackBerry User

    Posts
    47 Posts
    Global Posts
    62 Global Posts
    #11  

    Default

    Quote Originally Posted by maxiime223 View Post
    Hello, I own an unlocked blackberry curve 8520, using a SIM card with Fido Canada(I don't have a data plan).
    My phone is connected to my home WiFi, I had no problems doing it. However, when I try to open the browser, it say : " unable to connect to internet, please try again later. If the problem persists please contact your service provider."

    I tried playing with the settings but could figure it out. Anyone could help me?
    Do what step12 told you but check if the settings stayed there after saving them. That used to happen to me all the time. You need to change to browser hotpost in Browser Configuration and General Properties.

    Quote Originally Posted by SwitchBeach View Post
    You will need a data plan in order to surf even over WiFi. If that's not what you want to do, then you need something other than a BlackBerry.
    Not really. I didn't have a data plan in the first month of having a 8520 and I could access the internet (even on apps) withou having BIS.
  12. Pradeep Kumar1's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #12  

    Default same problem badly needed help

    same problem dude......................
    i've used this before but its not working now.............................
    any solution............................?
  13. crazzy_rapper's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #13  

    Default my blackberry

    i changed to hotspot in browser option but still it doesnt show any other option to change and facebook with browser arent working so could someone plz help.. :/
  14. crazzy_rapper's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #14  

    Default

    still it is not working . what should i do.. ? it is on hotspot .. :/
  15. SwitchBeach's Avatar
    CrackBerry Genius

    Posts
    2,734 Posts
    Global Posts
    2,988 Global Posts
    #15  

    Default

    You need a BlackBerry Data Plan.
  16. TheBear64's Avatar
    CrackBerry User

    Posts
    30 Posts
    #16  

    Default

    First off, ignore the idiots in here that are saying that you have to have a data plan; YOU DON'T. I had a Curve 8520 for a long time on Fido and never had a data plan, and it worked fine, if a little slow. Unfortunately, I no longer have the Curve so can't point you to the exact settings, but the browser will definately work on WIFI. I don't think "Hotspot" is what you want, because on my newer Torch 9810, the "Hotspot Browser" setting looks for a data connection. I believe what you need to look for is a setting that says to use "WIFI only". It may be in the settings for the browser itself.
  17. Goblok's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    #17  

    Unhappy You do not need a data plan.

    Please quit saying that you need a Data plan. My open Blackberry Torch 9800 has been working fine on WIFI while on various pay as you go plans with no Data. Now with PetroCan pay as you go. This has been working perfectly fine for last 3 years. Yesterday after my 9 year old daughter was using the phone (Games) must have somehow changed some settings as I now have the same problem, connects to any WIFI network but now says unable to connect to internet, please try again. So I now too need some help.
  18. ruffainn's Avatar
    CrackBerry User

    Posts
    28 Posts
    #18  

    Default Wifi connection, but can't use internet...

    HI i had the same problem once whn i got a new router "Dlink" since i was dealing with networking so i did a little research and found out blackberry's are APSD mean they have a default setting for power saving mode "automatic power saving devices" and routers of some brand whn getting they type of devices they send a few packets to these devices which result in no or slow speed internet all u need to do is find the setting "WMM APSD" and its shd be prolly as enabled u need to disable it to thts it if u tell me ur router brand and model i might help with the settings too hope this works
  19. Goblok's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    #19  

    Default

    Well after about a week of pulling hair, I found it. No you don't need a data plan but you do need to turn on your data under network options. That is all it was and now all works like it should. I even pulled out the sim card and WIFI still works.
  20. Flynner2013's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #20  

    Default hi

    hi im having a problem with my blackberry torch. it says im connected to wifi but when i try to connect to the internet through apps like facebook, twitter and even the browser a message tells me to change to a wifi network and i have no idea how to do that... can you help me??
  21. Sanchi Munghate's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #21  

    Default

    thankss mahnn!! it worked for me
  22. Eon Ramirez's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #22  

    Default To GOBLOK!

    Just wanna clarify, coz I'm using 9900.. When you say we have to turn on the data, are you pertaining to the one in mobile networks?
  23. Eon Ramirez's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #23  

    Default

    Quote Originally Posted by Goblok View Post
    Well after about a week of pulling hair, I found it. No you don't need a data plan but you do need to turn on your data under network options. That is all it was and now all works like it should. I even pulled out the sim card and WIFI still works.

    Just wanna clarify, coz I'm using 9900.. When you say we have to turn on the data, are you pertaining to the one in mobile networks?
  24. Eon Ramirez's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #24  

    Default

    Quote Originally Posted by Sanchi Munghate View Post
    thankss mahnn!! it worked for me
    Did you use Goblok's suggestion?
  25. musabm1's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #25  

    Default

    since you are an experienced BB user and i m a newbie i would like to know whether or not i can use apps without BIS
    because on my curve 8520 i can browse web with ease on default browser but in any of apps it just doesnt connect
    says i need to be connected to wifi even if i am connected
    i m guessing it has something to do with permissions
    please help me out
    thanks in advance
Page 1 of 3 123 LastLast

Posting Permissions