Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Fynz's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #1  

    Default Uncaught Exception 8>=8 or index 7>=7?

    As the title says. I'm on a Blackberry Curve 8530, and lately, whenever reloading from installing/uninstalling an app, or a battery pull, I get an error.

    Either an Uncaught Exception 8>=8 or Uncaught Exception index 7>=7.

    I looked through the logs (Alt lglg) but didn't see anything in there that had any of those words in it, which is what I was told to look for.

    I was wondering if anyone knew how to fix this? I wouldn't really care, as it's just at startup, but after startup, the phone lags incredibly bad for about 5 minutes.

    EDIT: Now all the sound has stopped working. No sound at all will work. :S But the error didn't pop up.

    EDIT2: Upon using the voice command, I got a white screen with very small text for about a second, and the blackberry shut off. I battery pulled and reset it. The errors in the topic returned, as did the sound.

    I'm slightly tempted to try a reformat. >_<
    Last edited by Fynz; 03-06-2011 at 08:16 PM.
  2. echo2011's Avatar
    CrackBerry Abuser

    Posts
    128 Posts
    Global Posts
    129 Global Posts
    PIN
    E=mc
    #2  

    Default

    I'm pretty sure its a bad app causing this...I upgraded my 8530 operating system from version .654 to the newest .1030 and got these errors all the time, looking at the logs I saw nothing relating to the errors either...so I downgraded to a couple different versions settling on version .886 and all the errors vanished. Not sure if there's an easy way to locate the offending app or not, as it could be a third party or add-on, maybe even a core component.

    If you decide to reinstall the OS, heres the link with info:
    http://forums.crackberry.com/f3/how-...3/#post5753704
    Last edited by echo2011; 03-06-2011 at 08:27 PM.
  3. Fynz's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    Thread AuthorThread Author   #3  

    Default

    The issue is, I haven't added/removed any apps within the past month.

    The errors just randomly started popping up.
  4. echo2011's Avatar
    CrackBerry Abuser

    Posts
    128 Posts
    Global Posts
    129 Global Posts
    PIN
    E=mc
    #4  

    Default

    Then I'd say it's time for a re-install of the OS following that guide I posted. What OS version are you running?

Posting Permissions