1. Daayyummmboi's Avatar
    The alarm clock has been working just fine ever since I have owned this BB. And even when the operating system had been updated a couple of months ago, everything has been operating normally. Then just a couple of days ago, suddenly, nothing.

    I have done battery pulls, and checked all of my settings.
    Any suggestions?
    10-19-10 08:08 AM
  2. rcnathan's Avatar
    What is it not doing? Opening, alarming, clock isn't working? Please explain a lil more

    Posted from my CrackBerry at wapforums.crackberry.com
    10-19-10 08:49 AM
  3. Fubaz's Avatar
    Yes please elaborate

    Posted from my CrackBerry at wapforums.crackberry.com
    10-19-10 10:24 AM
  4. Daayyummmboi's Avatar
    I'm sorry. Let me be a little more clear. The alarm sound itself is not working. I can set the alarm clock. See that afterwards that it has actually went off because the display will ask me if I want to hit the 5 minute snooze. But, no audible alarm sounds.
    10-19-10 11:52 AM
  5. TDRock's Avatar
    BUMP! Having same problem. Alarm went off fine this morning to wake me up, but now it sets and I see that its gone off because it gives me the option to snooze or dismiss but its not making an audible sound. Battery pull didn't correct the problem.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-21-10 12:19 PM
  6. RWWackostu's Avatar
    Have both of you recently upgraded to 5.0.0.822?
    10-21-10 02:27 PM
  7. jasondart's Avatar
    Have both of you recently upgraded to 5.0.0.822?
    Not sure about those guys, but I recently updated and the alarm sound does not work. Well it works sometimes, but the sound after snooze does not work at all.

    Also i no longer have the option for a keyboard lock with my left side button.
    11-22-10 12:42 AM
  8. Jvaf's Avatar

    Also i no longer have the option for a keyboard lock with my left side button.
    This is a known issue with OS 5.0. In order to get the keyboard lock you will have to set a new password
    11-23-10 10:44 AM
  9. jasondart's Avatar
    Anyone else find a fix for the alarm clock? I was damn near late to work today because of it. Worked fine last 2 days, but today the snooze screen came up at the proper alarm time, but no vibrate or sound.

    Honestly how can BlackBerry mess up an alarm clock.
    11-28-10 06:20 PM
  10. rynbeed's Avatar
    I have been having this issue for some time now. You can set set the alarm just fine, just when the alarm should sound you instead get the prompt to "dismiss" or "snooze" although the phone has not given an alarm or vibrated. Have had to go back to using my alarm by the bed and setting both a "reminder" and "alarm" on my blackberry. Also, after you hit "snooze" the alarm will sound after that.

    I missed work because of this once as well. Since I have a backup alarm I haven't done any research into fixing the issue [and I will be getting a Droid Pro shortly], but my guess is that you might be able to find a 3rd party app to act as an alarm?

    This I noted this happening after the .8xx update. Now currently using the .1xxx, which has phenomenal battery life but seems to still be carrying the alarm issue.
    11-29-10 12:34 AM
  11. Federicongo's Avatar
    I'm writing to share that I have the same issue with my BB flip (8220 or 8230). The thing with mine is that sometimes it all works fine and sometimes it doesn't!! I hate inconsistency, especially when it comes to technology and trouble shooting...

    Another thing that is different about my issue is that the phone will come on (or wake up) but with no alarm sound...and NO, I don't get the 'snooze' message or 'cancel snoozed alarm'. Nothing...the phone just wakes up but not me!! Do you guys have any ideas??

    FEDERICONGO
    04-01-11 02:06 PM
  12. Teess Maar Khan's Avatar
    My blackberry (8520) alarm clock isn't working. If i go to the clock (digital), then press the ,, option '' menu, then ,, set alarm '' ,

    i DO NOT see anything (example: numbers (min. or hours)). So i CAN NOT set my alarm. Help please. Pull battery/updated software DIDN'T work
    12-11-12 08:18 PM
  13. Lyndonious Brocksson's Avatar
    My blackberry (8520) alarm clock isn't working. If i go to the clock (digital), then press the ,, option '' menu, then ,, set alarm '' ,

    i DO NOT see anything (example: numbers (min. or hours)). So i CAN NOT set my alarm. Help please. Pull battery/updated software DIDN'T work
    i had the same problem but change the theme by clicking the menu button then while on the menu screen, click the BB button again and going to options then again press BB button then go to theme options change to default theme, then go back to clock and set the alarm then repeat this process to revert back to the desired theme and your alarm will be back up to view and change hope this helped
    07-01-13 08:31 PM
  14. millerj555's Avatar
    I have a similar problem, after I started using my backup 9700 with 6.0 Bundle 3049 installed. The alarm sounds once and opens the snooze/dismiss window opens. If I select snooze, the alarm will again sound after the snooze period, but stop after one alarm and the snooze/dismiss window opens. My old 9700 ( 6.0 Bundle 1879 and earlier) would alarm continuously until the snooze or dismiss was selected. How do I make the alarm sound until the snooze or dismiss is selected.
    11-06-13 12:30 PM
LINK TO POST COPIED TO CLIPBOARD