Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 17 of 17
  1. kneilson's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    PIN
    2062b55d
    Thread AuthorThread Author   #1  

    Default Incoming call display

    Hi, I've had my Curve for a month or so now and have noticed that it sometimes does not display the details for a contact when receiving an incoming call. It is also a bit choosy when it comes to using the Important Calls profile. The people who are calling me have never changed their settings to hide their number etc. Is this a network thing??? (O2 - UK).

    Thanks,

    K
  2. kneilson's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    PIN
    2062b55d
    Thread AuthorThread Author   #2  

    Default

    71 views and no replies, I guess it's just me then ????
  3. ncc1701p's Avatar
    CrackBerry Abuser

    Posts
    108 Posts
    Global Posts
    435 Global Posts
    PIN
    ask nicely :)
    #3  

    Default

    U know.. I got that JUST now after I did a SYNCH....

    i read about that somewhere but cant recall where.. ill keep researching
  4. tevansen's Avatar
    CrackBerry User

    Posts
    79 Posts
    PIN
    3064320D
    #4  

    Default

    I'm guessing this only happens if your BB is locked when the call comes in, right? If so, try going to Options/Security/General Settings and disable the Content Protection. That should take care of it.

    Once you know if that fixes it, you can try re-enabling content protection and changing "include address book" to no. Then test it that way and see if it works for you.
  5. Clyde Smith's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    #5  

    Default

    Hi, By default ur handheld will display all calls and show calls placed or received n the Messages screen. If that not the case then
    - From the handheld home screen, click Phone icon. The phone screen appears.
    - Click the trackwheel and click Options. The Phone Option screen appears
    - Click Call Logging. The Call Logging screen appears.
    - Scroll to Show Logs In Message List field, and click the Space bar to change option to No.
    - Scroll the trackwheel to select the types of calls that you want to display

    - By default, all types of calls (Incoming Calls)
    - Outgoing Calls
    - Attempted Calls
    - Missed Calls
    - Press the SPACE to select the option beside the type of call that you want to display.
    - Press SPACE again to select the option you wouldnt like todisplayed.
    - Click the trackwheel and click Save.
    Hope this helps!!
  6. kneilson's Avatar
    CrackBerry Newbie

    Posts
    6 Posts
    PIN
    2062b55d
    Thread AuthorThread Author   #6  

    Default

    Quote Originally Posted by tevansen View Post
    I'm guessing this only happens if your BB is locked when the call comes in, right? If so, try going to Options/Security/General Settings and disable the Content Protection. That should take care of it.

    Once you know if that fixes it, you can try re-enabling content protection and changing "include address book" to no. Then test it that way and see if it works for you.
    Well done Tevansen, problem solved. It would appear that having the address book protected prevented my incoming callers being recognised.

    Thanks for your help!

    K
  7. xshingax's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #7  

    Thumbs up Better than Help sites...

    Quote Originally Posted by tevansen View Post
    I'm guessing this only happens if your BB is locked when the call comes in, right? If so, try going to Options/Security/General Settings and disable the Content Protection. That should take care of it.

    Once you know if that fixes it, you can try re-enabling content protection and changing "include address book" to no. Then test it that way and see if it works for you.
    Thanks. It works now and your help was better than the tech manuals
  8. demonfist's Avatar
    CrackBerry User

    Posts
    12 Posts
    #8  

    Default

    Tevansen;

    I would also like to thankyou as i was receiving this problem.
  9. BlackberryJoe's Avatar
    CrackBerry Newbie

    Posts
    3 Posts
    #9  

    Default No Caller ID when locked.

    I wish I had seen this post 4 mo ago when I was struggling with this problem. It took me several weeks to figure out why my caller ID didn't always work and I could have solved it in a few minutes with a search here. It makes sense that if the phone book is encrypted and the device locked that the phone can't match the phone number to a name. It is a security feature. I still have content encryption enabled but don't encrypt the phone book. Like the other poster, I don't care if anyone has my mother-in-law's or bosses or whoever's phone number.

    Joe
  10. pmiguel's Avatar
    CrackBerry User

    Posts
    31 Posts
    #10  

    Default

    finally, the answer to the problem that i been havign for the last 3 weeks
    Paula
  11. Pilgrim's Avatar
    CrackBerry User

    Posts
    61 Posts
    #11  

    Default

    What is the advantage of having Content Protection enabled?
  12. Username5300's Avatar
    CrackBerry Genius

    Posts
    4,244 Posts
    Global Posts
    4,260 Global Posts
    #12  

    Default

    Protecting your contents.
  13. mookish's Avatar
    CrackBerry Master

    Posts
    1,479 Posts
    PIN
    21E50A3A
    #13  

    Default

    Quote Originally Posted by Threefive View Post
    Protecting your contents.
    In what way? Please explain...
  14. mookish's Avatar
    CrackBerry Master

    Posts
    1,479 Posts
    PIN
    21E50A3A
    #14  

    Default

    Quote Originally Posted by mookish View Post
    In what way? Please explain...
    Nevermind, figured it out...

    Although your BlackBerry transmits data over the air very securely, it does not store data on the handheld securely, unless you enable content protection.

    To enable content protection, go to Options --> Security and set Content Protection = enabled, which will also require you to enable a password.

    When you enable content protection on your BlackBerry, the BlackBerry will encrypt data that it determines to be sensitive, e.g. emails, browser cache, address book entries etc. This prevents someone with physical access to your handheld, from connecting it to a PC and extracting sensitive data. This will give you piece of mind, if your handheld is lost or stolen.

    When you lock your handheld, the BlackBerry will start to encrypt data, initially this may take quite some time. While the BlackBerry is encrypting data, an Open Pad Lock icon will be displayed. When the BlackBerry is finished encrypting data, the Pad Lock icon will close.

    The BlackBerry will continue to encrypt new data you enter, or receive over the air.
  15. NamelessLiar's Avatar
    CrackBerry User

    Posts
    75 Posts
    PIN
    T's of Beer
    #15  

    Default

    Quote Originally Posted by BlackberryJoe View Post
    I wish I had seen this post 4 mo ago when I was struggling with this problem. It took me several weeks to figure out why my caller ID didn't always work and I could have solved it in a few minutes with a search here. It makes sense that if the phone book is encrypted and the device locked that the phone can't match the phone number to a name. It is a security feature. I still have content encryption enabled but don't encrypt the phone book. Like the other poster, I don't care if anyone has my mother-in-law's or bosses or whoever's phone number.

    Joe

    Ah, another example of the usefulness of CrackBerry.com!
    My "Hit Me On My Blackberry" video!

    http://www.youtube.com/watch?v=0cdsHieoBPk
  16. shooptek's Avatar
    CrackBerry Addict

    Posts
    545 Posts
    Global Posts
    546 Global Posts
    #16  

    Default

    Wow I have been wondering what Content Protection is and how it works for a while now. It is really unclear as to what that is and how it works. Good problem solving!

    Posted from my CrackBerry at wapforums.crackberry.com
  17. majo3131's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #17  

    Default

    I am still having the same problem, and I noticed too it started happening since I synched my BB with my Mac, I tried going to Options/Security/General Settings but my menu is different (I have a BB Curve 9300), mine is Options/Security Options and there's no General settings option. I don't know where to disable my content protection (or just the phone book). My main problem is that when I check my call list it just displays my outgoing calls and not incoming calls, and it did before synching. Thanks!
    Last edited by majo3131; 02-09-2011 at 01:58 PM.

Posting Permissions