Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 3 of 3
  1. orionstarman's Avatar
    CrackBerry User

    Posts
    14 Posts
    Thread AuthorThread Author   #1  

    Default ALT key and Trackball ENTER not working. Please Help.

    Hello.
    Just a few days ago I noticed my Curve(8300) was displaying the "about" screens on it's own. Normally, you would have to go to SETTINGS>OPTIONS>ABOUT to get this. Scratching my head how this happened...shrugged my shoulders.
    To my disdain, shortly after, I noticed pressing on the trackball intermittently worked, sometimes not at all. The trackball moves flawlessly, but pushing it would not work as the "ENTER" key 90% of the time!

    Then I discovered that my ALT button was giving me problems. The push seems to be recognized since the icon on the top right of the screen displays it, however pressing ANY key in conjunction with the ALT such as a number or punctuation did not register as if I was not typing anything.

    Yes, I have reset it and also have taken the battery out and placed it back in.

    And no I don't have a warranty. I bought the phone from Newegg and did not buy a plan. I know better now.
    I am on AT&T
    OS 4.2.2.89

    Is this a hardware problem or a software problem?
    Any help would be so greatly appreciated. This is totally bumming me out.
  2. kumainn's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #2  

    Default

    I have the same exact problem except I'm on T-mobile. Have you heard any news regarding this issue?
  3. JRSCCivic98's Avatar
    CrackBerry Genius of Geniuses

    Posts
    14,514 Posts
    PIN
    I'm the Page Ranking person for Crackberry. :p | Don't be a CEO, Search the Forums! | Hybrids Suck!
    #3  

    Default

    RIM has a warranty on all phones for 1 year, regardless of who you bought it from.

Posting Permissions