Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 21 of 21
Like Tree1Likes
  • 1 Post By auditman
  1. Rigid's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Global Posts
    23 Global Posts
    Thread AuthorThread Author   #1  

    Default Trackpad, can't scroll!!

    It all just started happening randomly. I didn't do anything to cause my phone to act this way.

    It can scroll side to side fine, but will only scroll up or down depending on what menu its on. To scroll up or down on the menus where it doesn't work, I have to hold the shift or alt keys. While I am holding them down, I can scroll fine.

    BUT, it is registering my scrolling because I turned on the scrolling sound and am hearing it even if I scroll up or down.

    Also, It doesn't seem to register all my key presses anymore. If I press a and press s immediately after while a is still held down, it won't register the s. Basically, I can't press two keys simultaneously.

    ALSO, it sometimes turns itself off... AND my end call button seems to be unresponsive...

    Any ideas?? :S
    Last edited by Marakalastic; 04-25-2012 at 09:04 PM.
  2. o4liberty's Avatar
    CrackBerry Genius

    Posts
    2,510 Posts
    Global Posts
    3,335 Global Posts
    #2  

    Default

    Have you tried a battery pull? If that won't work try re loading the OS.

    Sent from my BlackBerry 9930 using Tapatalk
    Make sure you vote! Your vote counts!
    Support the 9-12 Project
  3. Rigid's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Global Posts
    23 Global Posts
    Thread AuthorThread Author   #3  

    Default

    Oh yea, sorry I didn't include in the original post that I have...

    -battery-pulled multiple times
    -updated to 7.1 from 7.0

    Anything else I could do?
  4. jc
    jc is offline
    jc's Avatar
    CrackBerry Addict

    Posts
    605 Posts
    #4  

    Default

    It happened to me with my 9810, I also did many battery pulls and even downgraded. I had to end up calling att and they sent me a reconditioned 9810.
  5. Rigid's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Global Posts
    23 Global Posts
    Thread AuthorThread Author   #5  

    Default

    damn, would I have to downgrade back to 7.0 so that Rogers will take a look at it? I'm just so puzzled as to why this happened to my 9900 all of a sudden.
  6. jc
    jc is offline
    jc's Avatar
    CrackBerry Addict

    Posts
    605 Posts
    #6  

    Default

    I have att and ine of their troubleshooting suggestions was that I downgrade to the os version my bb came with. I'm sure rogers will ask you to do the same thing.
  7. Rigid's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Global Posts
    23 Global Posts
    Thread AuthorThread Author   #7  

    Default

    *sigh*

    Well, called them and they said to try reloading an OS so I tried that to no avail. Going to send it in tomorrow

    I really wish I knew what exactly is going on so that I could atleast prevent this from happening in the future though...
  8. Rootbrian's Avatar
    CrackBerry Genius of Geniuses

    Posts
    12,332 Posts
    PIN
    Optional, but not needed.
    #8  

    Default

    Things happen. Maybe the trackpad wasn't good from the start.

    By the way, did you use it in direct or passive sunlight? Does it happen indoors? Was it dropped? Any water damage of any kind (Even if it's moisture from sweat?)?
  9. Rigid's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Global Posts
    23 Global Posts
    Thread AuthorThread Author   #9  

    Default

    Hmmm, maybe. Then again, it's not just the trackpad but the end call button as well. I can't even type fast on it anymore as not all the presses will register so I have to press each key one at a time.

    It happens everywhere, inside and outside. Unless dropping it from 30cm onto soft carpet counts as a drop, I have never dropped it actually, it's only a month old!!

    I don't believe so, I have rarely used it outside when it's raining. It's been somewhat chilly in BC still, so sweating probably isn't the reason.

    It just happened all of a sudden. In the morning when I got up, it worked just like normal. I'm hanging out at my girlfriend's place and it just starts acting like this
  10. Rootbrian's Avatar
    CrackBerry Genius of Geniuses

    Posts
    12,332 Posts
    PIN
    Optional, but not needed.
    #10  

    Default

    Quote Originally Posted by Marakalastic View Post
    Hmmm, maybe. Then again, it's not just the trackpad but the end call button as well. I can't even type fast on it anymore as not all the presses will register so I have to press each key one at a time.

    It happens everywhere, inside and outside. Unless dropping it from 30cm onto soft carpet counts as a drop, I have never dropped it actually, it's only a month old!!

    I don't believe so, I have rarely used it outside when it's raining. It's been somewhat chilly in BC still, so sweating probably isn't the reason.

    It just happened all of a sudden. In the morning when I got up, it worked just like normal. I'm hanging out at my girlfriend's place and it just starts acting like this
    So if you used it in the rain, that bit of moisture may have caused damage to the membrane. That's one of the ways water can damage things. It happened to my feature phone, before I got a blackberry.
  11. NellieRose's Avatar
    CrackBerry Abuser

    Posts
    295 Posts
    Global Posts
    316 Global Posts
    PIN
    terest
    #11  

    Default

    Quote Originally Posted by Marakalastic View Post
    Hmmm, maybe. Then again, it's not just the trackpad but the end call button as well. I can't even type fast on it anymore as not all the presses will register so I have to press each key one at a time.

    It happens everywhere, inside and outside. Unless dropping it from 30cm onto soft carpet counts as a drop, I have never dropped it actually, it's only a month old!!

    (
    I have the exact same problem as you are describing and just haven't had the time to get over to the Sprint store for a repair. It started clear out of the blue...was using the phone without problem, placed it down to put on my dog's leash, walked into the house and it no longer worked properly in the matter of about a minute. No dropping, no getting any liquid on it, nothing. Walking from the driveway to the house it suddenly no longer worked as it should.

    Typing has to be done painfully slow or you only get a letter here and there, the scrolling only works on some menus and if I dare happen to hit the "lock screen" button I have to do a battery pull to access the phone again. It is painfully annoying but haven't had the time to get over for a repair. Hoping to do that today or tomorrow. Not looking forward to a repair bill on a phone that was 1 month old at the time. Also, I have looked around via Google and we are not the only people to experience this, it is somewhat of a known issue.
  12. auditman's Avatar
    CrackBerry Addict

    Posts
    771 Posts
    Global Posts
    778 Global Posts
    #12  

    Default

    Quote Originally Posted by NellieRose View Post
    It is painfully annoying but haven't had the time to get over for a repair. Hoping to do that today or tomorrow. Not looking forward to a repair bill on a phone that was 1 month old at the time. Also, I have looked around via Google and we are not the only people to experience this, it is somewhat of a known issue.
    If its one month old no need to worry bout repair bills. It will be under warranty.
    Thanked by:
    NellieRose (04-29-2012) 
    NellieRose likes this.
  13. NellieRose's Avatar
    CrackBerry Abuser

    Posts
    295 Posts
    Global Posts
    316 Global Posts
    PIN
    terest
    #13  

    Default

    Quote Originally Posted by auditman View Post
    If its one month old no need to worry bout repair bills. It will be under warranty.
    That's great to know....now, my inability to get over there sooner will probably bite me in the backside!
    Last edited by NellieRose; 04-29-2012 at 12:38 PM. Reason: Type-o
  14. Rigid's Avatar
    CrackBerry Newbie

    Posts
    9 Posts
    Global Posts
    23 Global Posts
    Thread AuthorThread Author   #14  

    Default

    Quote Originally Posted by Rootbrian View Post
    So if you used it in the rain, that bit of moisture may have caused damage to the membrane. That's one of the ways water can damage things. It happened to my feature phone, before I got a blackberry.
    I don't think water damage is the cause, unless the water took a couple of days to affect the phone somehow? All these problems happened out of the blue, with no obvious reason why just like NellieRose.

    Just to let you guys know, I sent my phone in so hopefully, its all good when I get it back in 10 business days. I don't think there's an actual to fix to this sort of problem, the only solution is to simply send it in. Man, would I feel bad for whoever doesn't have a warranty :S
  15. fresnarus's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #15  

    Default Your symbol key is stuck!

    I have this problem on my blackberry bold. I thought the problem was simply that they symbol key was jammed on, which would explain why the cursor is being used to change between special and international symbols rather than to move the cursor. This explanation was also consistent with the problem going away when shift or alt are pressed, since they could simply override the symbol key. But strangely enough, when I'm typing and email normally and I press the symbol key the symbol menu opens up! So there is some other problem. Anyone know if it is hardware or software?
    Last edited by fresnarus; 05-10-2012 at 03:06 AM. Reason: previous answer wrong.
  16. trufflenose's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #16  

    Default

    I was just trying for "light sensitivity" on mine, as I have trouble sometimes. I believe that may be the issue for me. At work, it is very bright in my workspace - and that is where I have the issue of the trackpad "sticking". When I shade the trackpad with my hand, it works fine. Interesting...
  17. Akii9780's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #17  

    Default

    I Have the exact same problem, it is so annoying..!! it starts going through all these different symbols when i move track pad after typing..!! my letter 'P' keeps typing automatically specially if i press delete... By the way i use a blackberry bold 9780... i fitted a new housing and keypad, and today brand new trackpad today, no difference..!! if there is any solution to this please do tell me..!

    I cant send it for reconditioning as i cant back up anything on the phone, and have 100's of contacts and cant do with them being deleted..!!
    ANY SOLUTION? PLEASE HELP..
    Thank You.
    Akii..
  18. cbeeches's Avatar
    CrackBerry User

    Posts
    45 Posts
    #18  

    Default

    Yeah, I have a trackpad problem all of the sudden on my 9810. Just won't work, then have to use without. Kinda infuriating. I try to keep cool, but it is a pain.
    I pull the battery and sim and it seems to work for a day or so before going out again.
  19. Rootbrian's Avatar
    CrackBerry Genius of Geniuses

    Posts
    12,332 Posts
    PIN
    Optional, but not needed.
    #19  

    Default

    This is the 9900/9930 forums, not the 9780 forums.

    Quote Originally Posted by Akii9780 View Post
    I Have the exact same problem, it is so annoying..!! it starts going through all these different symbols when i move track pad after typing..!! my letter 'P' keeps typing automatically specially if i press delete... By the way i use a blackberry bold 9780... i fitted a new housing and keypad, and today brand new trackpad today, no difference..!! if there is any solution to this please do tell me..!

    I cant send it for reconditioning as i cant back up anything on the phone, and have 100's of contacts and cant do with them being deleted..!!
    ANY SOLUTION? PLEASE HELP..
    Thank You.
    Akii..
  20. robby999's Avatar
    CrackBerry User

    Posts
    16 Posts
    #20  

    Default

    About a month ago my trackpad started scrolling on it's own. After a week of that, the trackpad stopped responding at all. Then for no apparent reason the trackpad started working normally. It's been working for about two weeks now. I hope the 9900's self healing powers continue.
  21. opiksbdg's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #21  

    Default

    Hmmm, Just an hour ago before I posted this, I had same problem with my BB9930 track pad. Last time before the symptom came out, I just to replace the battery with other one of battery's as my backup unit.

    WHAT THE SOLUTION IS:
    I started with removing the Battery unit, SIM card including MicroSD card out from device.
    I leave it without those units in almost 15 minute and placed the all units back. Since the battery Installed properly on the device, it was immediately turn on and booting process came normally. Then when the desktop display was appeared, I try to move the pointer scroll up and down, it work normally!!!
    Last edited by opiksbdg; 12-12-2013 at 06:07 AM.

Posting Permissions