Results 1 to 5 of 5
  1. mr_gill's Avatar
    CrackBerry User

    Posts
    35 Posts
    Thread AuthorThread Author   #1  

    Default New Bold 9900 won't boot up..Battery icon with red cross and egg timer???!

    Hey guys, just got my new Bold 9900 delivered today. Put the battery in, and connected up the USB cable, the red LED light comes on for a second, and then all I see is a battery icon in the middle of the screen with a red cross and an egg timer! Have tried removing the battery and putting back in, leaving it plugged in for a couple of hours, no use, it simply won't boot up
    Anyone else had this problem and managed to resolve it? Or are we looking at a duff battery/phone here?
    Thanks!

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by mr_gill; 10-05-2011 at 04:25 AM.
  2. MrLynd54's Avatar
    CrackBerry Abuser

    Posts
    354 Posts
    #2  

    Default

    If it were me I would send the battery back to where you got the phone for a new one. If that does not work, then I would return the phone and request a refund.
  3. rrrebo's Avatar
    CrackBerry Genius

    Posts
    3,527 Posts
    Global Posts
    3,528 Global Posts
    PIN
    T of Strongbow, please.
    #3  

    Default

    ^^^^^ This. Sounds like a bad battery.

    Posted from my CrackBerry at wapforums.crackberry.com
  4. mr_gill's Avatar
    CrackBerry User

    Posts
    35 Posts
    Thread AuthorThread Author   #4  

    Default

    hmm, im thinking its a duff battery too.

    Strange thing is, when i connect to my laptop, the phone is recognised in desktop manager, comes up with the PIN, but it doesnt get any further and is unable to connect.

    Getting a new battery sent out for tomorrow, so will try that and if see it makes any difference.
  5. chefhunter's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #5  

    Default I have the same problem

    I have had my BB 9930 for 3 weeks now and last night i put it on charge and then this morning woke up to the hour glass and the red light coming on repeatedly.
    it will conect to the computer for a second and then disconect. the battery has been out and back in but nothing works.
    so is the new BB battery going to cause a recal?

Posting Permissions