1. big_sule's Avatar
    i have a blackberyy 9900, and today i was listening to music and left my headphones in and left them for a bit...i come back to my screen bein blank with a white background, and it saying 'jvm error 517' only giving me an option to reset my fone and if i click yes it jus starts loading up as usual then ends up going back to the error halfway through loading up... is there anyway of fixing this problem without all my music, videos, pictures and contacts because i have over 450 bbm contacts and i havent backed up anything and really dont want to lose all this. is there anyways to resolve this problem someone plz gimme a solution this has ruined my day and i really need cheering up ty for any answers
    08-01-12 04:49 AM
  2. Hgouck's Avatar
    Have you tried removing the battery, wait 1-2 minutes, than re install the battery. This will give the phone a chance to reset all its functions.
    08-01-12 06:00 AM
  3. sedalia066's Avatar
    Like Hgouck says, try a battery pull. Take the battery out with the phone turned on. In most every weird instance that will bring functions back to normal. If not return for more help. Most anything can be restored on a BlackBerry. Hope springs eternal.
    08-01-12 06:43 AM
  4. BigBadWulf's Avatar
    Sounds more like 507 to me, but either way......

    You've never done an OS upgrade, which would create a backup automatically, set up BlackBerry Protect, used the internal device switch in Setup to back your info on your SD/internal memory, utilized your carrier's backup assistant app, or the backup features within BBM itself?
    08-01-12 07:35 AM
  5. big_sule's Avatar
    ive tried takin battery out that didnt work amd mp i havent done an os upgrade btw i think on some phones its called error 507 aswell as 517
    08-01-12 04:51 PM
  6. BigBadWulf's Avatar
    http://btsc.webapps.blackberry.com/b...ListHelperImpl

    "JVM Error 517" appears on the BlackBerry Bold 9900 smartphone

    Article ID: KB30332

    Type:Support Content

    Last Modified: 06-25-2012

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    Product(s) Affected:

    BlackBerry Bold 9900
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    Jump to: Environment | Overview | Cause | Resolution | Workaround | Additional Information
    Environment
    BlackBerry� Device Software
    BlackBerry� Bold 9900 smartphone
    DT 2086208
    DT 1968897
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    Overview
    The BlackBerry� Bold™ 9900 smartphone stops responding, and the following error message appears:

    JVM error 517 Reset

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    Cause
    JVM Errors are raised by the BlackBerry Device Software during various activities to make the BlackBerry smartphone user aware of a failure in which the BlackBerry smartphone could not safely recover normal operation. Although JVM errors may occur as a result of software related issues only, JVM Error 517 is known to occur due to interactions with the BlackBerry smartphone hardware:

    JVM Error 517: The BlackBerry Device Software encountered unexpected data in a memory location which is used for normal operations

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    Resolution
    Ensure the BlackBerry smartphone is running the latest version of BlackBerry Device Software provided by the associated wireless service provider. If it is running older BlackBerry Device Software, please upgrade to the latest available version. For instructions on how to update the BlackBerry Device Software, visit the BlackBerry Device Software Updates web site or see KB03621.

    If the issue persists after reload or upgrade, please contact the wireless service provider for repair or replacement options should the BlackBerry smartphone still fall under the warranty coverage.

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    Workaround
    Though JVM Error 517 is typically indicative of an issue with the BlackBerry Device Software interacting with the underlying BlackBerry smartphone hardware that is no longer operating as expected, this specific occurrence of JVM 517 can be resolved by updating the BlackBerry Device Software.
    In other words, either way you'll need to reload the OS, and without being able to fully boot, you have virtually zero chance of recovering your personal info unless it's been previously backed up.
    08-01-12 05:07 PM
  7. big_sule's Avatar
    damn man thats real bad news
    08-01-12 05:32 PM
  8. BigBadWulf's Avatar
    Yeppers

    And good reason why, no matter what device you choose (PC included), it's always a good idea to back up regularly. Nothing is infallible, but helping yourself is easy.
    08-01-12 06:44 PM
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