Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
  1. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #1  

    Default BB 9930 - "Unidentified subscriber" when sending sms

    Hey guys,

    I'm having big trouble with my blackberry bold 9930.
    It is a Verizon branded device but worked perfectly with t-mobile germany the past weeks. SMS, Internet, BBM, etc. - everything was just smooth!
    This morning I wanted to send a SMS to a friend but the BB didn't send it. It showed me a red cross and the text "unidentified subscriber". I can receive SMS, I just can't sent it.
    I read thousands of threads but nothing works. I tried the following things to solve this issue:

    - hard reset the device: removing battery for more than 30 seconds, reboot --> didn't work
    - SMS Service center number: I changed the service number to the same number I had in my work phone (t-mobile germany, too). I saved changes --> didn't work. Reboot device -> old number is stored.
    - SIM card exchange. I inserted my work sim card in my blackberry and could send SMS without any trouble. I inserted my blackberry simcard in my work phone and could send SMS, too! I put my sim back to the blackberry --> unidentified subscriber! I also checked service center number when my work sim card was in the blackberry and there was the same old number but it worked great! It isn't a payment issue, either because in other phones I can send messages without any problems!

    WTF is going on with it!?! I was so lucky when switching back to blackberry but I'm really bit confused if this was the right decision.
    Does anybody of you have other chances how to fix this?

    Thanks and best regards
    -Matt
  2. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #2  

    Default

    Oh another thing.
    I also changed smart dialing settings. I changed to country code +49 (Germany). But there is no difference switching between US and Germany. It doesn't work either.
  3. infinus's Avatar
    CrackBerry Genius

    Posts
    1,602 Posts
    Global Posts
    1,605 Global Posts
    PIN
    Point
    #3  

    Default BB 9930 - "Unidentified subscriber" when sending sms

    Are you sure that your 9930 is fully unlocked....
    Search crackberry to how you can check for carrier lock status.
    tangled in BB;
    undo with CB.
  4. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #4  

    Default

    Hey,
    honestly I'm sure. Thing is, it worked smooth for weeks and I could send sms without any trouble.
    This morning it didn't work anymore.
    Could my playbook play a role in this issue?
  5. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #5  

    Default

    OK, checked my Sim card status. Network lock is inactive. So it's unlocked.
  6. infinus's Avatar
    CrackBerry Genius

    Posts
    1,602 Posts
    Global Posts
    1,605 Global Posts
    PIN
    Point
    #6  

    Default BB 9930 - "Unidentified subscriber" when sending sms

    Quote Originally Posted by Matt_sleepless_in_NYC View Post
    Hey,
    honestly I'm sure. Thing is, it worked smooth for weeks and I could send sms without any trouble.
    This morning it didn't work anymore.
    Could my playbook play a role in this issue?
    Try asking your carrier, may be some setting in your account is needed or they will suggest something...
    ....
    ...

    If nothing works....
    Wipe and clean install make lot of problem disappear...try that too..
    tangled in BB;
    undo with CB.
  7. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #7  

    Default

    OK, I talked to my provider. They couldn't see any issue with my contract or sim. They let me test the sim card in another device and everything works great there, also SMS.
    I already wiped the device completely but no chance. I was really lucky when seeing I can send and receive SMS with my old phone. But when putting it back to my bold I still have the unidentified subscriber issue.
  8. infinus's Avatar
    CrackBerry Genius

    Posts
    1,602 Posts
    Global Posts
    1,605 Global Posts
    PIN
    Point
    #8  

    Default BB 9930 - "Unidentified subscriber" when sending sms

    Try other simcard and see if same error appears..
    ....
    Also check if policy is enabled.... Google to see how to do that....
    ....
    Also check if bold sim contact pins are not broken, they are under battery
    ....
    tangled in BB;
    undo with CB.
  9. SwitchBeach's Avatar
    CrackBerry Genius

    Posts
    2,733 Posts
    Global Posts
    3,221 Global Posts
    #9  

    Default

    Is this happening with all SMS or only to one contact?
  10. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #10  

    Default

    hey,
    there is no policy on it installed.
    contacts of sim and sim card reader are OK.
    When using my work sim card in my berry, everything works fine. The sim card that doesn't work in my blackberry works great in other phones, too. But when i put it back to the BB I get the same issue.
    My provider (t-mobile germany) says that it's no carrier issue because in other phones I can send SMS without any issues.
  11. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #11  

    Default

    I have another question. Where can I set the number for the sms service center in OS7?
    Could CDMA be an issue? We don't have CDMA here in Germany.
    I changed settings for mobile network from CDMA to 3G and GSM. So usually CDMA shouldn't be an issue anymore right?
    Could a firmware downgrade bring any solution?
    Buying a blackberry was really a big misstake...
  12. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #12  

    Default

    OK, done with this Berry. I sold it last night at ebay and ordered a new iPhone. Sorry RIM, you had more than just one chance!
  13. SwitchBeach's Avatar
    CrackBerry Genius

    Posts
    2,733 Posts
    Global Posts
    3,221 Global Posts
    #13  

    Default

    Your mistake wasn't in "buying a blackBerry". Your mistake was buying one that wasn't supported natively by your carrier. If you had gotten the 9900, everything would have been fine.

    Good luck.
  14. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #14  

    Default

    See, I used blackberry for more than 7 years. Then I used an iPhone for a few months but it wasn't the same. So I got a 9700 and had trouble all the time. My carrier exchanged the phone twice. Now, back after a year and ready for a second chance RIM fails again. My colleague uses a 9930 with t-mobile germany, too. No issues. I think the time of bb or rim is over and I'm sure that bb os 10 will not save them. Apple isn't the phone I would prefer but it works really good and is a good pal in my daily business...
  15. infinus's Avatar
    CrackBerry Genius

    Posts
    1,602 Posts
    Global Posts
    1,605 Global Posts
    PIN
    Point
    #15  

    Default BB 9930 - "Unidentified subscriber" when sending sms

    Don't get so upset...
    1. See. All your phone features are unlocked.
    2. Take 9930 to carrier's shop and ask to check for SMS settings.
    3. Advance backup and wipe current OS
    4. Download new and recant OS 7.1.x and install..
    ..
    If all this fail...
    Try to sell 9930 and buy 9900.
    9900 is really good device except battery, but I used Sedio extended battery.
    ....
    tangled in BB;
    undo with CB.
  16. Matt_sleepless_in_NYC's Avatar
    CrackBerry User

    Posts
    52 Posts
    PIN
    22CD0A68
    Thread AuthorThread Author   #16  

    Default

    It's exactly what I did.
    1. everything was unlocked
    2. I was at the carrier's store and they checked all settings. They confirmed that everything is correctly configured.
    3. The guys at the stores kept it for nearly 3 hours to upgrade to latest 7.1 Version, security wiped it, removed all 3rd party apps and wiped again - nothing

    I payed $400 for the phone. When I'll sell it, I'll never get this money. So I have to pay a 9900 + the loss of selling the 9930. The phone is just a few weeks old.
    Verizon and T-mobile don't want to exchange or fix it for free.
    It's a pain in the . The service of verizon and t-mobile seems to be a fairytale. Both confirmed me it's not their fault and there is no way for them to exchange it for free.

    I browsed several hours through the web to find a solution - no way!
  17. Tam Flo's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #17  

    Default BB9930 "unidentified subscriber"

    Hey guys,
    I have the exact same phone (BB9930 CDMA-GSM), exact same issue.
    Almost pulled my hair out not find the solution right away, because about a year ago fixed the same problem after an update/hard reset, but I already forgotten how?

    All the advise are good in the thread, but this is how I fixed my BB9930 CDMA-GSM.
    Simple..
    - Insert your SIM card to another phone, ( I've used my old BB85xx)
    - Enter your SMS service center number, provided by your carrier
    Setting -> Option -> SMS text -> Service center: _ _ _ _ _ _(call your provider for the number)
    - Insert your SIM card to BB9930, and turn it on.
    It should work, worked for me.
    Good luck.
  18. Chancery Koncept's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #18  

    Default

    i just happened to me, the same phone. so i only put the sim card into another phone, checked the sms centre number, which i found empty, i inserted it, saved and returned the sim card to my 9930. tested it by sending a message and it went straight away. thanks guys for the info.

Similar Threads

  1. BB 9930 makes a beeping tone when answering phone
    By babymama032111 in forum BlackBerry Ringtones
    Replies: 0
    Last Post: 10-06-2011, 05:54 PM
  2. BB 9930 makes a beeping tone when answering phone
    By babymama032111 in forum BlackBerry Bold 9930/9900
    Replies: 0
    Last Post: 10-06-2011, 05:54 PM
  3. Hide Phone number when sending SMS
    By queenz_gambit in forum BlackBerry Curve 83xx
    Replies: 10
    Last Post: 08-25-2008, 12:56 AM
  4. Can I turn autotext off when sending SMS messages?
    By Joem1cha3l in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 05-26-2008, 08:03 PM
  5. Can I turn autotext off when sending SMS messages?
    By Joem1cha3l in forum BlackBerry Pearl 81xx
    Replies: 1
    Last Post: 05-26-2008, 12:43 AM

Posting Permissions