Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 6 of 6
  1. a346pilot's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Thread AuthorThread Author   #1  

    Default Problem with the display

    Hello,

    I got a Bold 9700 some days ago and I actually love it. But as you can see on the picture, the display might have a problem in the upper right corner. I tried to look for it here but there are so many threads and I actually didn't know what to look for as I'm not from an english talking country.
    Do you have an idea what that could be, if I can and how to solve it? Is that a common problem?
    Thank you very much for the help!
    So long
    Attached Thumbnails Attached Thumbnails Problem with the display-wp_000030.jpg  
  2. SlcCorrado's Avatar
    BlackBerry

    Posts
    6,242 Posts
    Global Posts
    6,295 Global Posts
    #2  

    Default

    From the picture it looks like screen separation. You could replace it but I doubt it's worth it. If it's not too annoying you may just have to live with it. Welcome to CB
    BB4Life
  3. a346pilot's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Thread AuthorThread Author   #3  

    Default

    Hey SlcCorrado,
    thanks for your quick reply, I guess I will have to live with it and hope that it won't get bigger. If there are any changements, I will let you know.
    Cheers
  4. Techmajesty1's Avatar
    CrackBerry User

    Posts
    14 Posts
    Global Posts
    27 Global Posts
    #4  

    Default

    Is there any text at all on the screen, small message in center of display? Or is it a blank white screen. T-Mobile has a troubleshooting article for problems with the display in the documents section. Take a look at it.

    If you have a blank white screen, solid, no text, and the device appears to be working except for the display, and you reinstalled the OS and it didn't fix it, then the problem is almost certainly hardware. There are some posts on other forums where people have claimed to have fixed itby reinforcing the damaged connection with electrical tape. Search and you should find. There is a thread on blackberryforums.com with pictures that I'm aware of.

    Unlock HTC One X
  5. auto208562's Avatar
    CrackBerry Abuser

    Posts
    132 Posts
    Global Posts
    138 Global Posts
    #5  

    Default

    I would just leave it alone for now. It's most likely hardware but it's just a guess. Here's the electrical tape fix techmajesty was referring to but it's only for WSD issue as he mentioned.

    WHITE SCREEN of DEATH FIXED WITH ELECTRICAL TAPE. - BlackBerry Forums Support Community
  6. marius_902002's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #6  

    Default

    Hi.

    I bought a BB 9700 2 days ago and an it came with 12 months warranty and the described status was: reconditioned. It is said to have new battery, new battery cover and it looks very well except for a few very fine scratches, barely observable.
    My first concern was the phone was too light (being used to heavier phones; and it only has 118 gr measured, not 122 gr as stated) but apart that everything works fine: wi-fi, bluetooth, text message, browser (no BIS yet).

    The "problem" I would like to present to you is the following: if I press on the edge of the phone(on the screen, actually, but only on it's edges) the screen gets colored weird, the well know colorations of LCD Screens. Is it normal? Does anyone else get this? I didn't get this at any other phone, because of the more solid cases, probably.

    Thanks

Similar Threads

  1. Problem with the 8300 Music player
    By k1000 in forum BlackBerry Curve 83xx
    Replies: 12
    Last Post: 04-21-2009, 11:40 AM
  2. Any Dust problem under the display with BOLD?
    By jlingo in forum BlackBerry Bold 9000
    Replies: 9
    Last Post: 11-19-2008, 03:19 AM
  3. Replies: 9
    Last Post: 05-01-2008, 05:50 PM
  4. having problems with the call log on the Curve/8300
    By dyouness in forum Introductions
    Replies: 2
    Last Post: 01-10-2008, 06:42 PM
  5. problem with the new im+
    By thewegforth4 in forum Introductions
    Replies: 1
    Last Post: 07-06-2007, 01:36 PM

Posting Permissions