Results 1 to 9 of 9
  1. Thauwa's Avatar
    CrackBerry User

    Posts
    20 Posts
    Thread AuthorThread Author   #1  

    Default Curse - Battery Problem?

    Hey all. I'm new to the forums and RIM.

    I've got a Bold 9000 and its super cool. I got it from my dad when he got a Torch. But.....

    A few weeks before he even knew that he was getting a BB Torch, his (now mine) Bold started acting weird. And the same weirdness now haunts me.

    Without being plugged to the power supply, the phone lasts a maximum of around 5 hrs IN BEDSIDE MODE. For emergencies, when I needed to use the phone for a longer time, and only for SMS too, I had to turn it off soon after reading/sending an SMS. When not in bedside mode, it lasts a maximum of 1.5-2 hours...

    And another part of the curse is that randomly (when not plugged in to the power) the screen goes white all of a sudden. Nothing other than white remains on the screen. Before I found a temparory cure for this (which was removing and refixing the battery), the screen stayed glowing for over a day! This 'glowing' has never happened while plugged to the charger.

    The other thing is that when I unplug my BB Bold from its power source, starting at 100%, and start using an application like Opera Mini or a game, by the end of 10 minutes of continuous use, the screen'd be glowing white again. When I do a 'battery pull', it resumes functioning, but with the power level at 0%! And this is 'too low for radio use'. Out of frustration then I'd do another 'battery pull' and find the battery level at 10% even without the slightest influence of the charger!

    So, could I know what I should be doing? Should I get a new battery (the present one is about a year old)? Or is it some software problem? Or... Is it a curse?!

    Oh and the local retailer (couldn't successfully diaggnose her quandary)

    Thanks for any help and any attempts of aid, in advance. I really appreciate.

    Regards,
    Thauwa


    P.S. Oh and I also have a problem with my BB Desktop Manager 6.
    The "Apply Now" button is frozen, below the Applications list... What do I do?

    P.S.S. Oh and my LED notifier doesn't sparkle when a new SMS message arrives. I know that it hasn't blown out because I've seen it illuminate on 'battery pull'. I even checked with the Advanced Settings in the "Profiles" section and logically have done all necessary for the LED to work (it stopped working one afternoon the previous week).

    Thanks Again!

    Posted from my CrackBerry at wapforums.crackberry.com
  2. #2  

    Default

    Sounds like new battery time. If you have the chance borrow a battery. If not then replace the one you have with a new OEM battery. As a rule I replace my batteries about every 6 months but that may be overkill. A year is enough for most of them.

    Sorry I cannot help with the other issues. Wait around and someone will likely arrive to help.
    Bits--C000C6078 for links to world news and views, technology and science postings.
  3. mayniak's Avatar
    CrackBerry User

    Posts
    47 Posts
    Global Posts
    62 Global Posts
    #3  

    Default

    ^^ what he said. aslo what OS you runnin?
  4. Thauwa's Avatar
    CrackBerry User

    Posts
    20 Posts
    Thread AuthorThread Author   #4  

    Default

    Quote Originally Posted by sedalia066 View Post
    Sounds like new battery time. If you have the chance borrow a battery. If not then replace the one you have with a new OEM battery. As a rule I replace my batteries about every 6 months but that may be overkill. A year is enough for most of them.

    Sorry I cannot help with the other issues. Wait around and someone will likely arrive to help.
    Thank you very much. I'll try it asap.

    Posted from my CrackBerry at wapforums.crackberry.com
  5. Thauwa's Avatar
    CrackBerry User

    Posts
    20 Posts
    Thread AuthorThread Author   #5  

    Default

    Quote Originally Posted by mayniak View Post
    ^^ what he said. aslo what OS you runnin?
    Thanks again. Umm. I'm not that sure about the OS. But from "options"->"about", it is....
    9000/4.6.0.144 (autotext "myver").

    And because that 'Apply' button is frozen, I can't update it to v5. I also get an error "not enough free space, you need at least 34MB to update"...... I've got 1GB device memory free and 4GB in the memory card...

    Posted from my CrackBerry at wapforums.crackberry.com
  6. Thauwa's Avatar
    CrackBerry User

    Posts
    20 Posts
    Thread AuthorThread Author   #6  

    Default

    Quote Originally Posted by sedalia066 View Post
    Sounds like new battery time. If you have the chance borrow a battery. If not then replace the one you have with a new OEM battery. As a rule I replace my batteries about every 6 months but that may be overkill. A year is enough for most of them.

    Sorry I cannot help with the other issues. Wait around and someone will likely arrive to help.
    So shall I get a new battery? I can borrow one from no where.....
  7. #7  

    Default

    Yes. Try a new one. In the store if possible. There is a very good chance that will make the phone all better.

    Then plan to replace the battery at least one time a year. More if you are obsessive.
    Bits--C000C6078 for links to world news and views, technology and science postings.
  8. pineypl's Avatar
    CrackBerry Abuser

    Posts
    473 Posts
    Global Posts
    514 Global Posts
    #8  

    Default

    My Bold was doing almost the same things as yours and I purchased a new OEM battery. The Bold has been perfect since then. Get the battery.

    I'll bet the other issues are power/battery related. When you get the new battery charge it over night before using the phone. Let it get a good full charge.

    Posted from my CrackBerry at wapforums.crackberry.com
  9. Thauwa's Avatar
    CrackBerry User

    Posts
    20 Posts
    Thread AuthorThread Author   #9  

    Default

    Thank you very much everyone. I ordered an OEM battery today.

Posting Permissions