05-30-13 03:17 PM
40 12
tools
  1. montygood's Avatar
    Hi everyone,

    My Bold was sitting in it's charger and I looked over and the screen was white. I took out the battery and now the phone doesn't turn on or anything. It's DEAD! I've left the battery out overnight and when I put the battery in, the LED light comes on a solid red for about a minute, then nothing. It was at 80 % battery life when I started charging, so I know the battery was okay.

    Any ideas? Is there a reset button or something? Help please. I've put my SIM in my iPhone, but I hate the iPhone.

    Thanks, Robb
    Last edited by montygood; 10-13-08 at 09:53 AM.
    10-13-08 09:37 AM
  2. kasw3670's Avatar
    i had this happen to me. i did the battery pull with the whitescreen still showing (ie. not turned off) left it 30seconds and put the batter back in and all was ok thankfully.
    10-13-08 09:39 AM
  3. montygood's Avatar
    hello,

    Rogers is sending me a new one. Anyone have this happen to them?

    Robb
    10-13-08 12:21 PM
  4. PBSLTD's Avatar
    Happened to me, all I do is pull the battery, and put it back in and it is fixed

    Posted from my CrackBerry at wapforums.crackberry.com
    10-13-08 02:11 PM
  5. chapsrulez's Avatar
    I had the same issue, just pulled the battery, waited for about half an hour, put it back and problem solved.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-13-08 10:22 PM
  6. phonegeek#AC's Avatar
    Had something similar happen with an 8120 about nine months ago or so. I used jl_cmdr to wipe it clean or reset to factory I can't remember for certain which option I used and then restored my last backup and it worked fine...
    10-13-08 10:29 PM
  7. BlackMcBerry's Avatar
    Had this happen today. The IT policy hacks at corporate have got my functionality so locked down I thought for a minute I might have caused it myself by looking at basketball scores.

    The thing is, if the WSOD kicks in while your security lock is in place (note previous reference to corporate IT policy hacks) it appears that your BB is frozen up. Only after a battery re-boot do you get the WSOD. I did the battery thing three times then left it charging for a while and it finally cleared itself out.
    03-15-09 12:24 PM
  8. Crackberrykills's Avatar
    hello,

    Rogers is sending me a new one. Anyone have this happen to them?

    Robb
    No, and thank all that is holy that it has not. I would probably cry. Well, not really.
    03-15-09 12:30 PM
  9. yanapa2's Avatar
    please guys my Bold gone all white all of a sudden.. i still can get calls, mails etc...but cant see a thing ! didnt drop it or anything !! any suggestions ?
    03-15-09 11:46 PM
  10. carbide50's Avatar
    Hi everyone,

    My Bold was sitting in it's charger and I looked over and the screen was white. I took out the battery and now the phone doesn't turn on or anything. It's DEAD! I've left the battery out overnight and when I put the battery in, the LED light comes on a solid red for about a minute, then nothing. It was at 80 % battery life when I started charging, so I know the battery was okay.

    Any ideas? Is there a reset button or something? Help please. I've put my SIM in my iPhone, but I hate the iPhone.

    Thanks, Robb
    Check out the link in my signature on how to recover a dead BlackBerry.

    Bryan
    03-16-09 12:12 AM
  11. bineon's Avatar
    Same happened to me. Was under warranty now I have a new one! :P

    Hope you backed up your data!
    03-16-09 12:44 AM
  12. spegase's Avatar
    Suffering from this also ... I found the method.
    This seems to be working only if you are having WhiteScreen but with ALT or ****F buttons still working
    The problem comes from the SD card (for my it was that)

    - make a hard reboot (holding ALT + right SHIRT + DEL)
    - once the red light off
    - open the SD card slot and remove the card
    - the system autoboot and the white screen desepears
    - Welcome back to the world ...

    ps: This happened to me offen when the weather is hot, or when the BBB stays under heavy sun a few minutes

    good luck to everyone
    damnphone likes this.
    05-19-09 11:56 AM
  13. tazu's Avatar
    its static forming on the screen, i tried opening the phone , and removed the screen form the board, on the anti-static mat,
    when it got discharged its working without any problems.

    and also i noted , that when a track ball goes black or dirty, it somehow jams, or stay on.

    and current is giving the LCD to freeze up .

    i have been leaving the phone off . removing the battery for an hour it works great no white screen or static showing on the screen like TV.
    07-15-09 05:56 PM
  14. bigtony8's Avatar
    hi i have a blackberry bold and its weird i just put the battery in and the led light goes red for a few seconds and the screen truns on then a little clock comes on the screen for about a minute and the screen stays white can somebody help me please?
    08-28-09 09:25 PM
  15. reshad9482's Avatar
    hi everyone , im new so sorry if im posting in the wrong convo. basically i got a bold 9000, with the white screen ie nothing comes up apart from the white screen, initially i though it was the screen, so i changed it with same part number etc ie blackberry got 3 kinds of screen, the phone is not water damage or nufin. flashed reset etc with jl software on the pc it does say process complete, use blackberry apps to re install the software on it which goes thru the whole process and state process complete but stil the white screen on. ive use bb screenstreamer to connect my laptop to blackberry n to c wats going on the screen as on the blackberry cant c nuthing, on pc then i can c ie my blackberry is working ie its showin the clok and all the setting wizard etc. so any advice will be much appreciated ie i think i tried pretty everything.
    03-17-10 06:11 AM
  16. sskiles's Avatar
    I've had a similar problem before with the screen freezing up & showing the "white screen of death". However, a simple battery pull has always done the trick.
    03-23-10 03:40 PM
  17. zervyn's Avatar
    after i drop my phone on the ground, my bold screen turn white.. cant call or receive sms.. the white screen kinda fickle.. button still working.. anyone please save my bold...
    06-08-10 04:26 AM
  18. bbboy1's Avatar
    ya i just pull the battery
    06-08-10 06:46 PM
  19. dclemhay's Avatar
    hello..ive had this problem for a couple of months..what works everytime is take the battery out, put it back in but RIGHT when you put the battery back in, put it in the charger..let it chill for a while because it needs the energy because the white screen sucks out the energy..its best to have a extra charger whenever it happens or a car charger
    07-19-10 08:28 AM
  20. CarlosYYC's Avatar
    Suffering from this also ... I found the method.
    This seems to be working only if you are having WhiteScreen but with ALT or ****F buttons still working
    The problem comes from the SD card (for my it was that)

    - make a hard reboot (holding ALT + right SHIRT + DEL)
    - once the red light off
    - open the SD card slot and remove the card
    - the system autoboot and the white screen desepears
    - Welcome back to the world ...

    ps: This happened to me offen when the weather is hot, or when the BBB stays under heavy sun a few minutes

    good luck to everyone
    It looks like it's working! I've never been so happy about seing the Loading Timer before!!!

    Thanks man!!!
    08-01-10 02:00 AM
  21. palladium83's Avatar
    Suffering from this also ... I found the method.
    This seems to be working only if you are having WhiteScreen but with ALT or ****F buttons still working
    The problem comes from the SD card (for my it was that)

    - make a hard reboot (holding ALT + right SHIRT + DEL)
    - once the red light off
    - open the SD card slot and remove the card
    - the system autoboot and the white screen desepears
    - Welcome back to the world ...

    ps: This happened to me offen when the weather is hot, or when the BBB stays under heavy sun a few minutes

    good luck to everyone
    Hi thanks for the head up,
    My onxy 9700 also experienced the white screen,no water or any liquid was in my onyx.i can still make a call or recieve a call but the screen goes to white. I already gold the alt plus shift and del and remove the memory card but the screen is still white after rebooting. Any help or suggstion is highly appreciated. Thank you so much
    12-25-10 11:27 AM
  22. Antonug's Avatar
    It looks like it's working! I've never been so happy about seing the Loading Timer before!!!

    Thanks man!!!
    I was trying to do the same and nothing happen, was trying with rebooting, with pulling out the battery also hard resetting it and nothing happen. Everything work properly, could that be the software? I am not sure how I can reinstall the software.
    01-02-11 09:44 PM
  23. sudburyontario's Avatar
    my bold 9000 is doing this as well. the white screen says reload software 507
    02-05-11 03:30 PM
  24. snp_ethan's Avatar
    Hello Guys, I have a 9700.

    This is what happened to me. I went to the MD today for an ecography/ultrasound (IDK if that is even the right term in English) on my left ankle.

    The BB was on my right pocket along an IPOD touch. they were literally laying on each other, and when I walked out of the hospital I had the white screen.

    Ive tried pulling out the bat, pulling the micro SD, alt+shft+del reboot.

    and nothing.

    Im about to try:

    Reed McLay's guide at post:

    post281396

    yeah, sorry, I cant post the link

    If I get lucky i'll let you know.
    02-28-11 01:35 PM
  25. snp_ethan's Avatar
    So, after dismantling the whole thing I was able to make it work for a couple of hourse, but then the volume keys werent working right so I dismantled it again, on my 2nd try I noticed that to disassemble the last part(the case and the motherboard) the connectors to the screen are exactly where the latch for the motherboard and the case actually attach to each other so it seems the wires are messed up there somewhere.

    so, does anybody have the schematics to repair that? or spare parts vendor?

    Thanks!
    02-28-11 08:22 PM
40 12
LINK TO POST COPIED TO CLIPBOARD