Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
Like Tree3Likes
  • 1 Post By jgrzadka
  1. unbreakablej's Avatar
    CrackBerry Master

    Posts
    1,076 Posts
    Global Posts
    1,078 Global Posts
    Thread AuthorThread Author   #1  

    Default z10 not charging

    Hi, i just got my BlackBerry z10 on friday but there have been some problems with it my handset does not seem to be charging even when i plugged it in. I know it was working the night before (although it refused to charge when i used another older bb charger) and this morning it won't work on my new charger as well!

    Alao, im not sure if is my carrier's (o2)problem or the phone but halfway through the day i could not use 3g internet at all, although wireless is fine.
    Anyone could wnlighten me as to the problem nd hopefully provide a solution?
  2. amjass12's Avatar
    CrackBerry Genius

    Posts
    1,550 Posts
    #2  

    Default

    hey.. i got my z10 from o2 the other day... i also had the same problem.. but found out it wasnt a problem.. you have to push the charger in until it clicks... and you will see the lightning bold flashing on the battery,... let me know if that works...

    its weird cos its very very stiff and needs a lil force... but it should work
  3. lunaticwithin's Avatar
    CrackBerry Addict

    Posts
    633 Posts
    Global Posts
    634 Global Posts
    #3  

    Default

    I found the same and took it back to the EE store where I got it, they tried with several chargers and noticed the one I had was "reluctant" to go in - they changed the charger for me.
  4. knighty2112's Avatar
    CrackBerry Master

    Posts
    1,091 Posts
    Global Posts
    1,109 Global Posts
    #4  

    Default

    I have a Blackberry charger for my Playbook & one for my (now) old Torch 9800, & also my works BB phone (a lowly Curve) which work fine on the new Z10 if I plug them in. I think the new usb to micro usb cable that they supply new with the Z10 is too tight for the micro usb port on the side of the Z10 forcing me to have to jiggle the cable in the port to get it to charge if I use the new one, but with the other older Blackberry chargers I have they fit into the socket much better without having to force it in or jiggle them & they start charging right away. If you can get another Blackberry charger from a friend or anywhere try this.
  5. knighty2112's Avatar
    CrackBerry Master

    Posts
    1,091 Posts
    Global Posts
    1,109 Global Posts
    #5  

    Default

    Sorry, just re-read your post & noticed that you have already tried other BB chargers. If you still have problems I would get your Z10 replaced.
  6. thorstenpleasefixit's Avatar
    CrackBerry Abuser

    Posts
    127 Posts
    #6  

    Default

    I have noticed there is a 1 or 2 second delay between plugging in and the charging Z appearing above the battery icon. It made me think "uh oh, broken" the first few times too.
    ==========================================
    - Avid fan of BB 9700 and 9850 - the 5mp camera addition made life so much easier (even though it was fairly crap!). Waited a long time for a Q10, including being 5 months past my 'upgrade' date from the carrier - lost my nerve and got the Z10 1st Feb 2013. Probably switching back to a 9900 while I wait for OS fixes/upgrades. Proud Londoner (that's in the UK, guys!)
    http://www.thorstenfixplease.co.uk/
    ==========================================
  7. jgrzadka's Avatar
    CrackBerry User

    Posts
    60 Posts
    #7  

    Default

    I just got my Z10 and noticed that the Playbook charger will not charge the device. It only works with the charger provided. I made sure the cable is connected tight but still wouldn't work.
    Yesh007 likes this.
  8. Gelzz's Avatar
    CrackBerry Abuser

    Posts
    363 Posts
    PIN
    28E0854D
    #8  

    Default

    never mind guys got it working lol
    Last edited by Gelzz; 02-05-2013 at 08:07 PM.

    YOU HAVE GOT TO SAY WHAT'S ON YOUR MIND!
  9. Kevin Michaluk's Avatar
    CrackBerry Founder

    Posts
    3,417 Posts
    Global Posts
    3,706 Global Posts
    PIN
    It's complicated...
    #9  

    Default

    Hey Guys,

    BlackBerry noticed this thread and sent me a reply to post on their behalf.... here you go... from #TEAMBLACKBERRY:

    "We’ve found that if you plug the USB cable into the phone slowly it may not make a proper connection to begin charging. Be careful, but make sure you get a good firm connection.

    The lightning bolt symbol will confirm you’ve got a good connection. It might take a few seconds to display the lightning bolt after you’ve plugged in."

    Hopefully that helps!

    Kevin
    Kevin Michaluk
    Founder, CrackBerry.com
    Chief Media Officer, Mobile Nations
  10. robgallop's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #10  

    Default

    Mine is showing the lightning bolt, but still isn't charging. Same with several chargers Battery issue or phone ?
  11. kill_9's Avatar
    Banned

    Posts
    5,168 Posts
    Global Posts
    5,169 Global Posts
    #11  

    Default

    Quote Originally Posted by unbreakablej View Post
    Hi, i just got my BlackBerry z10 on friday but there have been some problems with it my handset does not seem to be charging even when i plugged it in. I know it was working the night before (although it refused to charge when i used another older bb charger) and this morning it won't work on my new charger as well!
    Make absolutely certain the microUSB connector is fully seated in the USB port. I noticed this just the other day when the flashing lightning bolt did not appear over the battery charge- level indicator. Hope this resolves your situation.
  12. #12  

    Default

    Wow. I love that Blackberry is actually reading threads on this forum. That's great!
  13. INTz's Avatar
    CrackBerry Abuser

    Posts
    295 Posts
    #13  

    Default

    Quote Originally Posted by Kevin Michaluk View Post
    Hey Guys,

    BlackBerry noticed this thread and sent me a reply to post on their behalf.... here you go... from #TEAMBLACKBERRY:

    "We’ve found that if you plug the USB cable into the phone slowly it may not make a proper connection to begin charging. Be careful, but make sure you get a good firm connection.

    The lightning bolt symbol will confirm you’ve got a good connection. It might take a few seconds to display the lightning bolt after you’ve plugged in."

    Hopefully that helps!

    Kevin
    See this thread: Z10 wont charge when plugged in initially - BlackBerry Support Community Forums

    There is a KB article posted there. have a look for more details
  14. koool1's Avatar
    CrackBerry Addict

    Posts
    969 Posts
    Global Posts
    971 Global Posts
    #14  

    Default

    My first time charging I had the same issue. I did a shut down and re-booted and it charged fine.

    I find the OS has some minor glitches but just like our I/T department says - did you shut down and re-start your system?

    ;-)
  15. Scooter68's Avatar
    CrackBerry Abuser

    Posts
    216 Posts
    #15  

    Default

    Ya I have seen a slow to get to the lightning bolt before but today I plugged in and expected it to be charged, came back and hr later and nada. So as above i rebooted and it came right to charging. Ahhh the thrills of being an early adopter. Glad BB is reading the posts as well... Must be a software glitch.
  16. jgrzadka's Avatar
    CrackBerry User

    Posts
    60 Posts
    #16  

    Default

    Quote Originally Posted by Kevin Michaluk View Post
    Hey Guys,

    BlackBerry noticed this thread and sent me a reply to post on their behalf.... here you go... from #TEAMBLACKBERRY:

    "We’ve found that if you plug the USB cable into the phone slowly it may not make a proper connection to begin charging. Be careful, but make sure you get a good firm connection.

    The lightning bolt symbol will confirm you’ve got a good connection. It might take a few seconds to display the lightning bolt after you’ve plugged in."

    Hopefully that helps!

    Kevin
    It worked for me. The key is to plug in quickly otherwise it does not work. My error was in plugging it in slowly think it will connect better. I am guessing this must be an unresolved bounce electricity issue. Thanks for the tip on the workaround.
  17. rmp1993's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #17  

    Default

    I'm having the same problem, ive tried all these things! And it's still not working
  18. StevieOntario's Avatar
    CrackBerry Newbie

    Posts
    2 Posts
    Global Posts
    5 Global Posts
    #18  

    Default reboot solved my problem (I hope)

    I have a problem opposite to that of one of the other posters, who said he/she gets the charge lightning bolt but no charge. My phone charges, but does not show the lightning bolt or any progress in the charge bar, no matter how many times I unplug and replug.

    However, the tipoff that my problem is software/OS related is that the charge bar did not indicate loss of charge either.

    On rebooting, the charge bar appeared full (as it should have, since I had left the charge cord plugged in overnight, even with no lightning bolt) and when I plugged in after rebooting the charge cord to the phone the lightning bolt appeared.

    Hope this provides a piece of the puzzle.
  19. B_Boss's Avatar
    CrackBerry Newbie

    Posts
    5 Posts
    #19  

    Default

    Same issue. Sometimes charging just don't work.
    Reboot helps in this case, however if you don't pay attention It is not being charged - you stay without phone..
  20. MarthaBarbee's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #20  

    Default Battery causes charging problem

    If I forget to charge my z10 overnight, in the morning it's completely dead and will not charge unless I hold the top button for about 10 seconds. THIS DOES NOT ALWAYS WORK and at one point I had to take my phone to the authorized center in Torrance. They said the battery is controlled by the software. They gave me a new battery and voila my phone started charging! Well that battery only lasted for 3 MONTHS and now it's dead and won't charge! Lucky I had a spare which I just put in my phone and it is now charging. So in short, the blackberry batteries really suck! You should keep a new spare.

Similar Threads

  1. HELP! Pearl not charging, no red LED
    By bamafannga in forum BlackBerry Pearl 8100
    Replies: 3
    Last Post: 11-26-2008, 09:52 AM
  2. Battery not charging
    By Sonshyne in forum BlackBerry Pearl 81xx
    Replies: 8
    Last Post: 05-04-2008, 11:16 AM
  3. Not Charging?
    By jhood25 in forum BlackBerry Pearl 81xx
    Replies: 2
    Last Post: 03-09-2008, 05:16 AM
  4. Usb not showing connection/not charging
    By ftgjr in forum BlackBerry Pearl 81xx
    Replies: 2
    Last Post: 02-17-2008, 10:19 PM

Posting Permissions