Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 18 of 18
  1. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #1  

    Default Z10 / Google Calendar Issue

    This is driving me nuts, so I'm really hoping somebody can help me with this. I've tried using the forum search function and looking for an answer, along with simply Googling the issue, but nothing I've found either answers the specific issue, or if a solution does appear, it doesn't seem to work.

    The problem: My BB Calendar won't communicate with Google Calendar. I can enter items into my BB Calendar on the Z10, and it'll even let me send out gmail invites for the 'events' (managing client appointments), but the events never show up in Google Calendar. It won't seem to synch.

    Oddly, the invites work, and clients can confirm the appointments, but then Google sends me messages warning me that no such event exists.

    I've tried deleting and restoring Google Calendar on the Z10 in a couple different ways. The latest was through CalDAV (using the following instructions).
    1. On the home screen, swipe down from the top bezel and select Settings.
    2. Select Accounts > Add New Account > Email, Calendar and Contacts > Advanced Setup > CalDAV.
    3. On the CalDAV screen, the Description field is optional, but can be filled in for clarity.
    4. Enter the full email address in the Username and Email Address fields.
    5. Enter the password used to access Google Calendar in the Password field. Use the Show Password checkbox to ensure it is correct.
    6. In the Server Address field, enter https://www.google.com/calendar/dav/<emailaddress>/events where <emailaddress> is the Google email address.
    7. Sync Interval can be changed with these values : 15 Minutes , 30 Minutes , 1 Hour , 2 Hours , 4 Hours , 24 Hours , or Manual . The default is 30 Minutes.
    8. Click Save.
    No luck, however. It still doesn't work. I'm ready to pull my hair out. Using a Blackberry isn't supposed to be this much of a headache, and I'm hoping I'm just missing something really basic. Does anybody have another solution or workaround for this, short of dumping any hope of BB & Google actually communicating?

    Edit: I do have the latest OS update as well.
    Last edited by Ed Northcott; 12-22-2013 at 08:29 PM.
  2. underway99's Avatar
    CrackBerry Master

    Posts
    1,411 Posts
    Global Posts
    1,452 Global Posts
    #2  

    Default

    I don't recall having to add a custom server address when I set up my Z10. I just used www.google.com as the server, the same as what I used for my contacts.
    Palm Treo 700P, 755P, Storm 9530, Tour 9630, Bold 9650, Bold 9930, Samsung Galaxy S3, Z10, Q10, Z10, LG G3, Z10 and now Z30, all on Big Red.
    Nook Color w/CM7.2, iPad2, Nook Color w/CM10.1.3, Dell Venue 8 Pro
    Thanked by:
    Ed Northcott (12-26-2013) 
  3. runriverrun's Avatar
    CrackBerry User

    Posts
    22 Posts
    #3  

    Default

    I had issues too; finally found these instructions that fixed the problem for me: yellowchilli's musings.: How to setup Google Calendar and Contacts in Blackberry 10
    Thanked by:
    Ed Northcott (12-26-2013) 
  4. genesis101's Avatar
    CrackBerry Abuser

    Posts
    251 Posts
    #4  

    Default

    If it helps, I just used www.google.com also and it has worked very well for me. I do know it works great so don't give up.....

    Posted via CB10
    Thanked by:
    Ed Northcott (12-26-2013) 
  5. twstd.reality's Avatar
    CrackBerry Master

    Posts
    1,250 Posts
    #5  

    Default

    Have you set your default calendar? If I remember correctly, the default is set to the local calendar on bb10.

    Settings>accounts>set defaults on the bottom menu.

    Posted via CB10
    Thanked by:
    Ed Northcott (12-26-2013) 
  6. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #6  

    Default

    Thanks for the replies, folks.

    Yeah, originally I had just "google.com" set, and didn't used the advanced settings for the calendar. I should have mentioned that in the first post. I'm far from an in-depth user -- I'm just a small businessman who uses the z10 as a personal assistant. That's why I found it so frustrating when the calendars stopped talking after one of the earlier Blackberry OS upgrades (it had worked fine when I first bought the phone at the end of May/beginning of June).

    It's only now as I'm preparing to open the doors of my studio, after months of prep, that I noticed that booking clients through my BB doesn't show up in the Google Calendar. After much experimenting, including changing the defaults, I finally had to delete the info and re-enter it -- I tried the advanced method above as my last-ditch attempt before asking for help.

    However, after doing that I forgot to look at default settings again! For Calendar, I have three choices: device-home; Gmail - (email here); Gmail - Contacts' birthdays and events.

    I've set it at the last for now, to see if that does what I need. Once they've had a chance to sync, I'll write back with whether or not it's worked.
  7. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #7  

    Default

    That method failed. Attempting 2nd option in the list.

    If this fails, I'll try the link Runriverrun posted -- though I've tried the google.com approach before, perhaps something else was 'off'.

    The really frustrating part is that gmail and contacts are syncing perfectly. Not a problem. Calendar's the killer.

    Edit: Damn. Didn't work. Next attempt, deleting all Google functionality, and re-installing.

    Edit 2: That doesn't work, either. Tried Runriverrun's method. That doesn't appear to work, either.

    The Z10 will recognize calendar items entered in Google, but Google will not recognize the items entered in Z10's calendar.
    Last edited by Ed Northcott; 12-23-2013 at 02:53 PM.
  8. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #8  

    Default

    Narrowed it down further. They're communicating, but I can't get Google Calendar to show the tasks from the BB Calendar. But when I create a scheduled event on Google, it shows up on the BB; and when I delete it on the BB Calendar, it disappears on the Google Calendar.

    This means they're communicating, but Google Calendar's simply not displaying the BB Calendar's tasks. So close! Driving me nuts.
  9. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #9  

    Default

    Any other solutions I'm missing? I'm pretty much at the end of my rope.
  10. twstd.reality's Avatar
    CrackBerry Master

    Posts
    1,250 Posts
    #10  

    Default

    Have you tried this?

    Sync Multiple Calendars
    Visit the following page from your device's mobile browser: https://www.google.com/calendar/syncselect
    Google Apps users can go to https://m.google.com/sync/settings/
    Select the calendars you'd like to sync, then click Save.
    The selected calendars will be displayed on your device at the time of the next sync.
    This might help as well: https://support.google.com/calendar/...ef_topic=13950

    Not an android but it might still apply.

    Posted via CB10
    Thanked by 2:
    Brandon Orr (01-17-2014),  Ed Northcott (12-26-2013) 
  11. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #11  

    Default

    I didn't expect the iphone sync process would make a difference for the BB -- sadly, I was right. Nothing came of it. I couldn't find any relevant information on the page for syncing Android phones, either.

    This is absolute madness. This process should not be this much trouble. This phone has been a consistent headache since I got it. Thank you all for your advice and efforts -- without the community that backs it, the Blackberry would be an absolute disaster.
  12. genesis101's Avatar
    CrackBerry Abuser

    Posts
    251 Posts
    #12  

    Default

    Some have used m.google.com. As the server address. Try that and let us know.

    Posted via CB10
    Thanked by:
    Ed Northcott (12-26-2013) 
  13. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #13  

    Default

    This is a new one. I tried "m.google.com" as the server, and when I went to save my BB gave me the following message:

    Accounts
    Your account Google Calendar - (email address) - (email address) cannot be authenticated with your service provider. Please make sure that the account settings are correct.
    I haven't seen that one before!
  14. tacit's Avatar
    CrackBerry User

    Posts
    38 Posts
    #14  

    Default

    Although I don't personally have much use for using the calendar or having it sync between google calendar and Z10 Calendar I was sort of intrigued by the fact that you were having problems.
    Over the past few days I have been adding simple events in both z10 and google calendar to see if they would sync between each other. On every occasion they did sync albeit not immediately which I presume is the time setting for syncing.

    My email account settings on the z10 are as such..

    Username = my email address xxxxxx@gmail.com
    Email Address = xxxxxx@gmail.com
    server address=imap.gmail.com
    port=993
    encryption=SSL
    Imap Path prefix (Blank)
    Smtp Username= xxxxxx@gmail.com
    smtp.gmail.com
    SMTP Port= 465
    Smtp Encryption SSL
    Use push if supported ON
    Sync interval 30 minutes
    Edit folder settings (sync all email folders is OFF) Although inbox ,sent and drafts are ticked they are greyed out

    Gmail Calendar settings
    Description = gmail
    username xxxxxx@gmail.com
    email address xxxxxx@gmail.com
    server address = http://www.google.com/calendar/dav/x...il.com/events/
    sync interval 15 minutes

    Whether this is of any help I am not sure, it's just that it is working OK for me
    Thanked by:
    Ed Northcott (12-26-2013) 
  15. timboalogo's Avatar
    CrackBerry Abuser

    Posts
    258 Posts
    #15  

    Default

    The previous posters method for Gmail is what I use and it works fine on my Z10. I did however have problems with my live.ca calendar on my Z10 after an OS upgrade. It wouldn't sync all the time, or I would get duplicate items on different days, or an item would dissappear from my device after attempting to sync to live.ca. It's okay now after a further OS upgrade during which I think I did a security wipe of the phone. there must have been some corrupt PIM data after the update, and it needed totalling wiping. That might me the only solution, although it is such a hassle to do.

    Posted via CB10
    Thanked by:
    Ed Northcott (12-26-2013) 
  16. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #16  

    Default

    Unfortunately, when I try that method I get the error message above. Which means it would probably work, save that somewhere along the chain it's breaking. I'm afraid it's time to simply give up on it.
  17. Ed Northcott's Avatar
    CrackBerry User

    Posts
    15 Posts
    Thread AuthorThread Author   #17  

    Default

    Holy Hell. I just gave up, threw in "www.google.com" as the server (after deleting Calendar and re-setting through the CalDav/advanced function again) ... and this time it synched.

    I figured I'd just keep it on, as it was at least pulling the Google information onto my BB, even if it wouldn't work the other way around. But suddenly, out of the blue, it kicked in. Days of metaphorically banging my head off the brick wall, and I can't figure out why it's suddenly working. But it is, and I won't look a gift horse in the mouth.

    Once again, thank you all for your advice and ideas. Blackberry's company support may be dismal, but the community is remarkable.
  18. Gearheadaddy's Avatar
    CrackBerry Genius

    Posts
    4,250 Posts
    Global Posts
    4,278 Global Posts
    #18  

    Default

    Google has had a few bugs in the last couple of months...It wasn't your phone...

    Posted via CB10
    Rockin' a Black STL100-4...Z10 10.3.1.1154, Debug Token ...on Verizon, 64 GB WiFi Playbook.
    HP Elite M9340f Quad Core, OCZ 64GB Vertex 3 SSD +1TB HDD, Vista SP2 Media Center Edition, 6GB Ram,
    Logitech MOMO Force Feedback Racing Wheel with Pedals and Shifter.

Similar Threads

  1. Bb10 on z10 battery life
    By spikesolie in forum BlackBerry 10 OS
    Replies: 29
    Last Post: 12-29-2013, 09:33 PM
  2. Sony Camera with Wi-Fi and Z10
    By presean in forum BlackBerry Z10
    Replies: 2
    Last Post: 12-28-2013, 10:00 AM
  3. Bank of America mobile app: Z10 needs one!
    By josecabita in forum BlackBerry 10 Apps
    Replies: 4
    Last Post: 12-23-2013, 09:16 PM
  4. Q10 1259 charging issue
    By kfehling in forum BB10 Leaked/Beta OS
    Replies: 7
    Last Post: 12-23-2013, 05:42 PM
  5. Q10 Charging Issues with 1259
    By kfehling in forum BB10 Leaked/Beta OS
    Replies: 7
    Last Post: 12-23-2013, 05:39 PM

Posting Permissions