1. clmazda's Avatar
    Hey guys.. I was wondering if this happened to you guys, I bought my z10 on release days and it's been good on the battery, but since yesterday it goes down 5% every 5 minutes... usually I charge it before going to bed and when I wake up in the morning its at 90% but this morning it was at 25%...

    I also notice that my phone is really hot after charging and even when I don't use it its still warm...

    Yesterday I had about 10.5 GB free space and this morning I have 8.5 GB free.. which is weird because I deleted some apps last night...

    Did this happened to any of you?

    Posted via CB10
    03-19-13 09:05 AM
  2. jrohland's Avatar
    Probably an app is stuck. Most likely an Android app. I recommend holding the top button and tapping the Restart point on the screen. This will reboot the phone.
    03-19-13 09:11 AM
  3. MrHomz's Avatar
    Hey guys.. I was wondering if this happened to you guys, I bought my z10 on release days and it's been good on the battery, but since yesterday it goes down 5% every 5 minutes... usually I charge it before going to bed and when I wake up in the morning its at 90% but this morning it was at 25%...

    I also notice that my phone is really hot after charging and even when I don't use it its still warm...

    Yesterday I had about 10.5 GB free space and this morning I have 8.5 GB free.. which is weird because I deleted some apps last night...

    Did this happened to any of you?

    Posted via CB10
    I don't have this problem....my battery was worse before I did the software update, now it goes 2 days on a charge. Have you updated to the latest software? One other thing you may want to try is reloading the software altogether. (Do a backup first of course..) There is a thread here somewhere on how to reinstall the OS (you need BB Link). That does seem strange that it gets hot and discharges so quickly...as if an app is continuously running and eating up resources.
    03-19-13 09:13 AM
  4. adrianod1993's Avatar
    Try checking if all ur emails are pulling correctly sign in to them online and see if you have any emails that weren't on your Z10)

    Posted via CB10
    03-19-13 10:41 AM
  5. clmazda's Avatar
    Alright thanks guys! And yes I did update it to the latest OS update. And yeah I will try the reload option with blackberry link, hopefully that will help. There's definitely something wrong, it's only 10 am and it's at 45%... already

    Posted via CB10
    03-19-13 11:02 AM
  6. NoAhB0Dy's Avatar
    welcome to the club...

    Mine is hit and miss every day...sometimes it's hot and draining battery (most times) and sometimes is cool and being nice to my battery.

    It is extremely frustrating trying to figure out what exactly is causing this...
    03-19-13 11:17 AM
  7. clmazda's Avatar
    Alright thanks guys! I reloaded the OS and it seems like everything is back to normal!
    03-19-13 08:50 PM
  8. NoAhB0Dy's Avatar
    Good luck.... I've reloaded mine a few times with no long lasting positive results. I was at a hockey game tonight and went from full charge to 5% in a matter of 3ish hours. Not impressive...

    Posted via CB10
    03-19-13 10:51 PM
  9. MrFeilong's Avatar
    What helped for me was the following:

    1. Update OS to latest version
    2. Disable features you don't use (Like Bluetooth, NFC, DLNA, Geotagging pictures)
    3. Set screen brightness between 30% and 40% (This made a huge difference for me)
    4. The less e-mail accounts you have configured the longer your battery will last, I currently have 2 (My business e-mail through ActiveSync and my personal Hotmail account)

    After doing those simple changes my battery lasts now about 1.5 day, whereas before it was about 12 hours.
    shiakap and jojo beaconsfield like this.
    03-20-13 05:16 AM
  10. NoAhB0Dy's Avatar
    What helped for me was the following:

    1. Update OS to latest version
    2. Disable features you don't use (Like Bluetooth, NFC, DLNA, Geotagging pictures)
    3. Set screen brightness between 30% and 40% (This made a huge difference for me)
    4. The less e-mail accounts you have configured the longer your battery will last, I currently have 2 (My business e-mail through ActiveSync and my personal Hotmail account)

    After doing those simple changes my battery lasts now about 1.5 day, whereas before it was about 12 hours.
    Curious...do you have all the other accounts setup as well, like Facebook, Twitter, LinkedIn, Evernote, etc?
    03-20-13 08:29 AM
  11. srbuhr's Avatar
    I have been having the same issues. Phone running hot whenever I use the phone or if texting/BBM and battery life has been terrible just recently. I just completed the 10.10.85 update so hoping the phone is compiling and will get back to how it was before the update.

    Posted via CB10
    03-20-13 09:02 AM
  12. arvind1983's Avatar
    I am getting more than 55 hrs with medium use. I still have 15% juice left. I turned off 4G to 3G and stopped using push emails. My wifi is on most of the times. It makes a great difference.
    03-20-13 09:03 AM
  13. NoAhB0Dy's Avatar
    I am getting more than 55 hrs with medium use. I still have 15% juice left. I turned off 4G to 3G and stopped using push emails. My wifi is on most of the times. It makes a great difference.
    See but these are concessions you should not have to make. Users should not have to jump through hoops just to get a day's use out of their device.

    Posted via CB10
    adrianod1993 likes this.
    03-20-13 10:15 AM
  14. NoAhB0Dy's Avatar
    So....I discovered today what appears to be my battery problem. As I was suspicious of BDS and my work account I started focusing in that area. After much digging I believe I found the culprit. Results are preliminary but very promising.

    We use Lotus Traveler at work and after watching the activity logs I discovered that Traveler was constantly trying to send 3 contact updates to my device. I am not sure if it was 3 groups or my iPad, also using traveler, that was causing the issue but after deleting the 3 groups and removing the iPad from Traveler, the 3 contact updates stopped trying to send to my device and it is no longer running hot when idle.

    As I said....preliminary but promising!


    Posted via CB10
    mithrazor likes this.
    03-22-13 08:34 PM
  15. zsarasa's Avatar
    My battery has been the exact same... I hear people raving about how good the new os update has been on their battery, but I haven't noticed it! I'll be lucky if I get max 8 hours a day before it's completely dead whereas I read some people go a day or close to that. I have turned 4G to 3G and set the brightness on low yet this doesn't help.
    Does anyone have any other suggestions??????

    Posted via CB10
    03-22-13 11:47 PM
  16. NoAhB0Dy's Avatar
    My battery has been the exact same... I hear people raving about how good the new os update has been on their battery, but I haven't noticed it! I'll be lucky if I get max 8 hours a day before it's completely dead whereas I read some people go a day or close to that. I have turned 4G to 3G and set the brightness on low yet this doesn't help.
    Does anyone have any other suggestions??????

    Posted via CB10
    Details? How many email accounts? Work account? Do you leave apps running minimized? Think about anything that could be running that would use data....


    Posted via CB10
    03-22-13 11:56 PM
  17. NoAhB0Dy's Avatar
    Update...my Zed10 is so cold tonight it is making my hands freeze

    This is such a HUGE relief as I have been fighting with this battery crap for weeks....

    Posted via CB10
    03-22-13 11:58 PM
  18. zsarasa's Avatar
    I have 2 outlook accounts synced but that's it. And I never leave apps running so I'm not sure why my battery drains so fast. The only thing I could thing of is that my os didn't update properly. This is what my os is... This is the latest version right?

    Battery problems on my Z10-img_00000105.png

    Posted via CB10
    03-23-13 12:02 AM
  19. NoAhB0Dy's Avatar
    Yes that's the latest...does your device get hot?

    Do you have wifi normally and do you have any sort of signal issues with your cellular carrier?

    Posted via CB10
    zsarasa likes this.
    03-23-13 12:16 AM
  20. zsarasa's Avatar
    Yes it does occasionally get hot. And I usually have wifi on cause I don't have that much data in my plan. But looking at what you said earlier about some app trying to update your device..... I got group me side loaded and every 10 min I get a notification from it saying group me push is disconnected, so maybe it keeps trying to connect and that drains my battery?
    Battery problems on my Z10-img_00000106.jpg
    03-23-13 12:27 AM
  21. NoAhB0Dy's Avatar
    That's where I'd start. If device gets hot something is making it work which in turn eats valuable battery. Remove things you think it might be one by one until you start to see a difference. Focus on anything you think might use data such as this app you mentioned. (especially side loads as they are not certified/properly tested for BB10)

    Posted via CB10
    03-23-13 07:24 AM
  22. sportline's Avatar
    Lots of people sideload these android garbages..most of these apps drains battery in its native ecosystem. So being sideloaded it will surely eats battery like no tomorrow

    Z10, Indonesia
    03-23-13 07:51 AM
  23. NoAhB0Dy's Avatar
    They're not all garbage....some have value but you need to be wary of what they do. Personally I'm using Kik and Pandora side loads. I was using and tweetcaster and greader as well but dropped them when I found replacement native apps. I removed and reinstalled these side loads many times thinking they were my battery culprit but in the end, not the case.

    Posted via CB10
    03-23-13 08:08 AM
  24. clmazda's Avatar
    What I did to fix this is that I reloaded the OS, and I didn't restore my back up. I started from scratche. I only installed the native apps. And now my battery last a long time!

    Posted via CB10
    03-27-13 08:25 PM
  25. shiakap's Avatar
    any differences between wipe and reload without restoring?..1 thing in common is both will reset to factory defaults..does reload operation will delete all of your downloaded apps?

    by the way..i have battery issues on my 1st week even before whatsapp being officially released..after performed the following..my battery is ...

    1. carrier push .82 update..installed and completely wipe my device
    2. start from scratch without restoring anything
    3. reduced brightness to the lowest
    4. used wifi whenever available
    5. no sideloading any apps
    6. no bb traveler nor ebay

    100% at 20:30..sleep from 23:00-07:30..went to work 09:00-current time 15:10..53% left after 19 hours or so..i'm on average usage but still great battery life so far

    Battery problems on my Z10-img_00000197.jpg
    Battery problems on my Z10-img_00000198.jpg
    03-28-13 02:15 AM

Similar Threads

  1. Battery on my Z10 was dead by morning
    By piko 72 in forum BlackBerry Z10
    Replies: 19
    Last Post: 04-15-13, 02:42 PM
  2. Problem Accessing BB Hub on my Z10
    By ak_fraser1 in forum BlackBerry Z10
    Replies: 9
    Last Post: 02-05-13, 03:30 PM
  3. SMS problem on my 8830
    By blackberry8830telus in forum BlackBerry 8800, 8820
    Replies: 4
    Last Post: 04-30-08, 06:38 PM
  4. Battery problem on 8100
    By stevie347 in forum BlackBerry Pearl 8100
    Replies: 2
    Last Post: 04-17-08, 01:26 PM
  5. what vzw said about the memory problem on my pearl
    By scarletbegonias in forum BlackBerry Pearl 81xx
    Replies: 16
    Last Post: 04-03-08, 11:17 PM
LINK TO POST COPIED TO CLIPBOARD