Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 23 of 23
Like Tree3Likes
  • 1 Post By jaleelhamid
  • 1 Post By lurk_n_post_2000
  • 1 Post By ubermanx
  1. jaleelhamid's Avatar
    CrackBerry Addict

    Posts
    594 Posts
    Global Posts
    1,225 Global Posts
    Thread AuthorThread Author   #1  

    Default Really Lliking Waze

    I love the gps app waze I love how it knows what set of lights gave cameras

    Posted via BlackBerry 10
    Thanked by:
    KoukiFC3S (03-30-2013) 
    datgurl likes this.
  2. Edward in Toronto's Avatar
    CrackBerry Abuser

    Posts
    318 Posts
    #2  

    Default

    I gave it a try, not really know what to expect, and I do like it myself.
  3. lurk_n_post_2000's Avatar
    CrackBerry Abuser

    Posts
    141 Posts
    #3  

    Default

    Waze is a great navigation app. Highly recommended as a replacement for BlackBerry maps, free, and it's social as well!

    Posted via CB10
    KoukiFC3S likes this.
  4. ibpluto's Avatar
    CrackBerry Genius

    Posts
    2,208 Posts
    #4  

    Default

    Seems pretty clever. Just started using, and trying to figure out all of its features.

    Seems to be pretty light with battery usage, wonder what it's data usage is like?

    Posted via CB10 from my awesome Z10
  5. ubermanx's Avatar
    CrackBerry Abuser

    Posts
    248 Posts
    Global Posts
    259 Global Posts
    #5  

    Default

    I cannot endorse this app highly enough. I loved it on my Samsung SIII and not being available on the Z10 was a major nay vote to upgrading. Fortunately all the yay votes won and I got the great Z10. Now I also have Waze on BB10. Best of all outcomes for me.
    7100t -> 7230 -> 7290 -> 8700r -> 8310 -> 8900 -> 8520 -> 9800 -> 9810 -> 9900 -> Z10 -> Nexus 4 (sigh)
    KoukiFC3S likes this.
  6. vulfadli's Avatar
    CrackBerry Abuser

    Posts
    403 Posts
    #6  

    Default

    Anyone know how to get it run in the background (dimmed screen) cause wife's got an iphone and even after she locks her phone its still giving directions whilst on z10 it stopped working until I swipe up an the app stays on screen.

    Posted via CB10 on my Z10
    Bold 9000 (lost ) > Bold 9780 (also lost ) > Bold 9000 (wife's) > Z10
  7. pooger's Avatar
    CrackBerry Master

    Posts
    1,098 Posts
    Global Posts
    1,105 Global Posts
    #7  

    Default

    my waze keeps telling me I have no data connection. Anyone know why? Everything else seems to work properly on the phone.
  8. tazish's Avatar
    CrackBerry User

    Posts
    66 Posts
    Global Posts
    67 Global Posts
    #8  

    Default

    Quote Originally Posted by pooger View Post
    my waze keeps telling me I have no data connection. Anyone know why? Everything else seems to work properly on the phone.
    I have the same issue on Verizon. If I close and reopen eventually it works. Emailed the support with my specs. Hope the figure it out. Also begged for native App which he said will require good adoption of Android port as proof of user base.

    Posted via CB10
    Thanked by:
    KoukiFC3S (03-30-2013) 
  9. DINGSTER1's Avatar
    CrackBerry Addict

    Posts
    961 Posts
    Global Posts
    1,139 Global Posts
    PIN
    Maybe...
    #9  

    Default

    This is one of my must haves! Love it!
    Have you hit SEARCH today?/
  10. pooger's Avatar
    CrackBerry Master

    Posts
    1,098 Posts
    Global Posts
    1,105 Global Posts
    #10  

    Default

    Well I'll try restarting it but that sucks. Maybe the problem will fix itself with the Os update. People aren't going to adopt it if it doesn't work. They have to realize that.
  11. KoukiFC3S's Avatar
    CrackBerry Abuser

    Posts
    418 Posts
    Global Posts
    2,698 Global Posts
    #11  

    Default

    Quote Originally Posted by pooger View Post
    Well I'll try restarting it but that sucks. Maybe the problem will fix itself with the Os update. People aren't going to adopt it if it doesn't work. They have to realize that.
    Same problem here. Seems like a vzn issue tho.

    Sent from my SCH-I815 using Tapatalk HD
  12. rickgainsmith's Avatar
    CrackBerry Master

    Posts
    1,078 Posts
    Global Posts
    1,090 Global Posts
    #12  

    Default

    I really like it also. A bit of fun.

    I want more candy. :-)



    Posted via CB10
  13. mundo472's Avatar
    CrackBerry Addict

    Posts
    690 Posts
    Global Posts
    738 Global Posts
    PIN
    the tail on the donkey
    #13  

    Default

    How does this app compare and contrast with BB Navigation? I've found that to be terrific but for the lack of traffic view and updates are too slow on the overhead map view...of course, it's still in beta and I don't think it's developed for bb10 yet
  14. tazish's Avatar
    CrackBerry User

    Posts
    66 Posts
    Global Posts
    67 Global Posts
    #14  

    Default

    I used Waze on IOS and thought it was amazing. I distribute for one of the major GPS companies and have this running instead of one of their units. First thing I do when I get in car is turn it on.

    The problem with LTE appears to be a Verizon issue as it is happening with other apps. There is one post recommending reboot than open an android ported app first. Then pin player. And all seems good. Might want to search for that thread.

    Posted via CB10
  15. keith1000's Avatar
    CrackBerry Addict

    Posts
    591 Posts
    #15  

    Default

    Hi everyone.
    Is anyone else having a issue returning it full screen from minimized (active frame) when I click on it from active frame it is blank black screen. And I have to reset the app. Very annoying. Otherwise like the app although it has been wrong a couple time and got me lost lol.
    Thx

    Posted via CB10
  16. 007Storm's Avatar
    CrackBerry Addict

    Posts
    638 Posts
    #16  

    Default

    Quote Originally Posted by keith1000 View Post
    Hi everyone.
    Is anyone else having a issue returning it full screen from minimized (active frame) when I click on it from active frame it is blank black screen. And I have to reset the app. Very annoying. Otherwise like the app although it has been wrong a couple time and got me lost lol.
    Thx

    Posted via CB10
    I have the exact same problem.
  17. pooger's Avatar
    CrackBerry Master

    Posts
    1,098 Posts
    Global Posts
    1,105 Global Posts
    #17  

    Default

    On my end, I power cycled my phone and found that waze started working. I guess a reboot may have been required.
  18. LuayS's Avatar
    CrackBerry Addict

    Posts
    700 Posts
    Global Posts
    702 Global Posts
    #18  

    Default

    Mine says no data connection everytime I've yet to try it. Tried over wifi and LTE I'm with Rogers.

    Posted via CB10
  19. fred1266's Avatar
    CrackBerry Addict

    Posts
    600 Posts
    #19  

    Default

    Does this app freeze with anyone else when they are using on the Z10
  20. #20  

    Default

    Quote Originally Posted by fred1266 View Post
    Does this app freeze with anyone else when they are using on the Z10
    Works fine for me. If any hitch delete and reinstall. That often eliminates the gremlins.

    Posted via CB10
    Bits--C000C6078 for links to world news and views, technology and science postings.
  21. fred1266's Avatar
    CrackBerry Addict

    Posts
    600 Posts
    #21  

    Default

    Delete 3 times and all stick after installing

    Posted via CB10
  22. wayne504's Avatar
    CrackBerry Abuser

    Posts
    263 Posts
    PIN
    334c55d4
    #22  

    Default

    Quote Originally Posted by pooger View Post
    my waze keeps telling me I have no data connection. Anyone know why? Everything else seems to work properly on the phone.
    I had that problem on Verizon also it was fixed after I upgraded to 10.1. Also a work around on 10.0 was to start it while you have wifi access.

    Posted via CB10
  23. fred1266's Avatar
    CrackBerry Addict

    Posts
    600 Posts
    #23  

    Default

    Guess I would have to wait on 10.1

    Posted via CB10

Similar Threads

  1. Does one really need a blackberry?
    By audit in forum General BlackBerry Discussion
    Replies: 34
    Last Post: 05-27-2009, 08:42 PM
  2. im really really worried right now...
    By zYn0T in forum BlackBerry Curve 83xx
    Replies: 3
    Last Post: 08-30-2007, 04:49 AM
  3. I really need help with memory.
    By .EXE in forum BlackBerry Pearl 8100
    Replies: 2
    Last Post: 08-24-2007, 06:15 AM
  4. I Really Have No Idea What I'm Doing
    By rack9 in forum Introductions
    Replies: 6
    Last Post: 06-21-2007, 06:59 PM
  5. I really need some help! I can't find the answer...
    By AudreaTrawick in forum BlackBerry Pearl 8100
    Replies: 3
    Last Post: 06-18-2007, 11:14 PM

Posting Permissions