Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 47
Like Tree6Likes
  1. highos's Avatar
    CrackBerry Abuser

    Posts
    111 Posts
    Thread AuthorThread Author   #1  

    Default Has anyone used the updated Work Drives? (Credential Manager, Remote Drive Mapping, SharePoint)!

    I had heard this was coming down the pipe - This sounds fantastic.

    I downloaded the update on a Q10 I have activated at the moment, however I just get an 'Connection failed - An error occurred. Please try again later.'

    I take it this require updating to BES 10.2 MR 1? I had not even realized MR 1 was out until reading the forums here a few minutes ago.

    New features in this release:

    • Easy authentication with integration in BlackBerry 10 Credential Manager
    • Easier access for users now with remote drive mapping by BES administrator
    • Support for Microsoft SharePoint
    If anyone has anything to share, I'd be really appreciated it. I've been manually mapping paths to users Documents each time we deploy a new handset, however in the past few years we've migrated all of our shared documents to SharePoint libraries... This could finally turn into the killer feature for us!
  2. Sith_Apprentice's Avatar

    Posts
    10,105 Posts
    Global Posts
    10,107 Global Posts
    PIN
    Changes way too often
    #2  

    Default

    Works just fine on BES 10.2 no MR. What are you trying to set up? And did you download this on the Work Side?
    ~S_A
    Thanked by:
    highos (02-19-2014) 
    highos and Supa_Fly1 like this.
  3. highos's Avatar
    CrackBerry Abuser

    Posts
    111 Posts
    Thread AuthorThread Author   #3  

    Default

    Trying to add a SharePoint Repository / Site.

    Network Drives / Mapped SMB have been working for an long time and continued to work after upgrading to Work Drives 2.0.0.55 on the Work Side of the phone, wanted to try the new features!
  4. Sith_Apprentice's Avatar

    Posts
    10,105 Posts
    Global Posts
    10,107 Global Posts
    PIN
    Changes way too often
    #4  

    Default

    I'll have to look at the Sharepoint part, I can't remember exactly what type of Auth isn't supported yet. It came up in beta

    Posted via CB10
    ~S_A
  5. Thunderbuck's Avatar

    Posts
    5,858 Posts
    Global Posts
    5,861 Global Posts
    PIN
    2B6927F7
    #5  

    Default

    I have it installed, but I haven't tried to hook it up to our SP sites yet. Stay tuned...





    "Max Power doesn't 'cuddle'! You strap yourself in and feel the Gs!"
  6. Sith_Apprentice's Avatar

    Posts
    10,105 Posts
    Global Posts
    10,107 Global Posts
    PIN
    Changes way too often
    #6  

    Default

    NTLM session security is not supported at this time. Try turning that off (if possible) and connecting again.

    Posted via CB10
    ~S_A
  7. highos's Avatar
    CrackBerry Abuser

    Posts
    111 Posts
    Thread AuthorThread Author   #7  

    Default

    Quote Originally Posted by Sith_Apprentice View Post
    NTLM session security is not supported at this time. Try turning that off (if possible) and connecting again.
    Hi SA,

    Disable it where? I don't recall ever seeing any options in BDS to configure NTLM / security - Are you talking about disabling such security in SharePoint itself?

    Just for reference Work Drives itself works fine as does viewing SharePoint in the Work Browser, can view the full desktop site and also use the mobile version of the site without issue. Just need to enter the user credentials the first time you open the site, so really curious why it wouldn't work out of the box with Work Drives, unless this is an NTLM / security issue and it's using WebDav?

    Thanks!
  8. SupaRitchie's Avatar
    CrackBerry User

    Posts
    14 Posts
    #8  

    Default

    Hi folks,

    does anyone have the .bar-file? The update is only available in BBW, the file itself isn't available in BESC. :S
    As we distribute the app via BES we need the file.

    Regards

    Posted via CB10
  9. fooit's Avatar
    CrackBerry User

    Posts
    16 Posts
    #9  

    Default

    Quote Originally Posted by Sith_Apprentice View Post
    NTLM session security is not supported at this time. Try turning that off (if possible) and connecting again.

    Posted via CB10
    Is there an official document or something that confirms this?
    AFAIK, NTLM should work just fine.
  10. fooit's Avatar
    CrackBerry User

    Posts
    16 Posts
    #10  

    Default

    Can you try to connect to Utopia's Demo SharePoint Site and let us know how it works for you?

    Name=UtopiaDemoSP (or call it whatever you want to call it as long as the drive name is valid)
    URL=http://spdemo.utopiasp.net/Shared%20Documents
    Username=spdemo
    Password=utopia
    Thanked by:
    highos (02-19-2014) 
    highos likes this.
  11. johnnyuk's Avatar
    CrackBerry Genius

    Posts
    1,799 Posts
    Global Posts
    1,800 Global Posts
    #11  

    Default

    Just had a quick look at how you configure drive mappings to push out from the BES10 server.

    Was hoping it would be a nice GUI based setup but no such luck, configuration files and batch files it is! Oh joy.

    Posted via CB10 on Z30 STA100-2 / 10.2.1.1925 on O2 UK - Activated on BES10.2
  12. dgzagm's Avatar
    CrackBerry Newbie

    Posts
    8 Posts
    #12  

    Default

    I have BES 10.2.1 installed with a 10.2.1 Z10 and I can create the SharePoint Repository, but when using File Manager the folder is blank/empty. Get this, I can create a new folder and it show up on the SP site and the z10, then after about 1 minute it disappears from the z10 and remains on the SP site. I have a low priority case open since yesterday, but they have not contacted me yet.

    Anyone else having similar issues?
    6230/8830/9930
  13. highos's Avatar
    CrackBerry Abuser

    Posts
    111 Posts
    Thread AuthorThread Author   #13  

    Default

    Quote Originally Posted by fooit View Post
    Can you try to connect to Utopia's Demo SharePoint Site and let us know how it works for you?

    Name=UtopiaDemoSP (or call it whatever you want to call it as long as the drive name is valid)
    URL=http://spdemo.utopiasp.net/Shared%20Documents
    Username=spdemo
    Password=utopia
    I will try-I had not though of trying a public site as a baseline-going to have to get it setup again as I had to give out my test Q10 on short notice to a user that lost his phone. Will report back!
  14. highos's Avatar
    CrackBerry Abuser

    Posts
    111 Posts
    Thread AuthorThread Author   #14  

    Default

    Quote Originally Posted by johnnyuk View Post
    Just had a quick look at how you configure drive mappings to push out from the BES10 server.

    Was hoping it would be a nice GUI based setup but no such luck, configuration files and batch files it is! Oh joy.

    Posted via CB10 on Z30 STA100-2 / 10.2.1.1925 on O2 UK - Activated on BES10.2
    Hey John, is there any public documentation on what's required? When I reached out to my rep the other day he sent me to a generic public site with very little technical information as he was on the road and haven't received a follow up since. I'm not scared of configuration files or batch files... If I can plug it into PowerShell even better!
  15. highos's Avatar
    CrackBerry Abuser

    Posts
    111 Posts
    Thread AuthorThread Author   #15  

    Default

    Confirmed the above works, for anyone having issues I'd suggest using fooit's suggestion and trying the above to make sure it's not your environment that's causing the issue.

    I tried again on an Z30 and sure enough it didn't work this time-but this time I noticed the very first time I clicked on the entry (but no other time afterwards) I got a permission denied error. Odd, I was %100 sure I had typed in everything correctly and was re-using my credentials that work for the network mapping so those wouldn't be at fault, so instead I tried a very public Share Documents on our internal site (similar to the above suggestion) and sure enough that worked! So I'll have to do some research into why I got a permission denied error on the library I wanted to access in the first place (and maybe enroll the assistance of our SharePoint Admin/Dev as he's seen this in action now and is also interested in the quick adoption we could have in our mobile workforce), but so far this is looking like an success-it works!

    Now if I could only find out how to customize and push these configurations automatically... life would be fantastic! Baby steps boys...
  16. fooit's Avatar
    CrackBerry User

    Posts
    16 Posts
    #16  

    Default

    Quote Originally Posted by highos View Post
    Now if I could only find out how to customize and push these configurations automatically... life would be fantastic! Baby steps boys...
    You have the utility to push configurations, right?
    You have your first simple configuration to create drives, pushed it to you device and it works, right?
    So why is it a problem to write a small script to automate all that and have a scheduled task or cron job to execute it?
  17. johnnyuk's Avatar
    CrackBerry Genius

    Posts
    1,799 Posts
    Global Posts
    1,800 Global Posts
    #17  

    Default

    Quote Originally Posted by highos View Post
    Now if I could only find out how to customize and push these configurations automatically... life would be fantastic! Baby steps boys...
    According to the docs you can create a scheduled task in Windows to run your batch file at a time and frequency of your choosing.

    All very cobbled together and rushed of you ask me, I was hoping for something much more elegant than this.

    10.2.1.1925 on O2 UK - Activated on BES10.2.1
    Last edited by johnnyuk; 02-15-2014 at 07:57 AM.
    Thanked by:
    highos (02-19-2014) 
  18. johnnyuk's Avatar
    CrackBerry Genius

    Posts
    1,799 Posts
    Global Posts
    1,800 Global Posts
    #18  

    Default

    Quote Originally Posted by highos View Post
    Hey John, is there any public documentation on what's required? When I reached out to my rep the other day he sent me to a generic public site with very little technical information as he was on the road and haven't received a follow up since. I'm not scared of configuration files or batch files... If I can plug it into PowerShell even better!
    Here you go:

    http://docs.blackberry.com/en/admin/...ry+Work+Drives

    Not all links across BlackBerry's websites seem to point to this new version 2.0 documentation yet.

    10.2.1.1925 on O2 UK - Activated on BES10.2.1
    Thanked by:
    highos (02-19-2014) 
    highos likes this.
  19. fooit's Avatar
    CrackBerry User

    Posts
    16 Posts
    #19  

    Default

    Simple push content to create UtopiaDemoSP drive:



    {
    "Command":"ChangeMappings",
    "Content":
    [
    {
    "Action":"CREATE",
    "UniqueName":"UtopiaDemoSP",
    "Type":"SharePoint",
    "Uri":"http://spdemo.utopiasp.net/Shared%20Documents",
    "Username":"spdemo",
    "Password":"utopia"
    }
    ]
    }
    Thanked by:
    highos (02-19-2014) 
    highos likes this.
  20. Supa_Fly1's Avatar
    CrackBerry Master

    Posts
    1,469 Posts
    #20  

    Default

    Quote Originally Posted by Sith_Apprentice View Post
    NTLM session security is not supported at this time. Try turning that off (if possible) and connecting again.

    Posted via CB10
    Its this done on SharePoint Server?
    Weapon Of Choice = BlackBerry: Z10
    Amunition = BB10 Full Metal Jacket, the Mobile OS piercing violator!
  21. andi81's Avatar
    CrackBerry Newbie

    Posts
    1 Posts
    #21  

    Default

    Please provide some more information about "NTLM session security is not supported"

    Is this a sharepoint server issue?
    Is an update planed to solve this issue?
    What is the workaround?

    Thanks
    Andreas
  22. fooit's Avatar
    CrackBerry User

    Posts
    16 Posts
    #22  

    Default

    Quote Originally Posted by andi81 View Post
    Please provide some more information about "NTLM session security is not supported"

    Is this a sharepoint server issue?
    Is an update planed to solve this issue?
    What is the workaround?

    Thanks
    Andreas
    Maybe NTLM wasn't supported in Beta versions but the current release has no problems with NTLM.
    If you can map into Utopia Demo SP site above then you are using NTLM,
  23. govingto's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #23  

    Default

    I am also having issues with accessing SharePoint internally. The demo site as mentioned above works well, but I only ever see a blank screen where I would expect to see the SharePoint documents on our internal servers. The file share portion works very well, using the same username [DOMAIN\username].

    Does anyone have any ideas for me to try before I try creating a support case?

    Thanks,

    Guy
  24. fooit's Avatar
    CrackBerry User

    Posts
    16 Posts
    #24  

    Default

    Quote Originally Posted by govingto View Post
    I am also having issues with accessing SharePoint internally. The demo site as mentioned above works well, but I only ever see a blank screen where I would expect to see the SharePoint documents on our internal servers. The file share portion works very well, using the same username [DOMAIN\username].

    Does anyone have any ideas for me to try before I try creating a support case?

    Thanks,

    Guy
    Let's go over the obvious stuff -
    1. What version of SharePoint? SharePoint 2007, 2010 or 2013?
    2. What kind of authentication? NTLM? Kerberos? Something else?
    3. Are you using SharePoint Sub Sites?
    4. Can you access this SharePoint site from Work browser on the device?
  25. govingto's Avatar
    CrackBerry Newbie

    Posts
    7 Posts
    #25  

    Default

    1. What version of SharePoint? SharePoint 2013
    2. What kind of authentication? NTLM
    3. Are you using SharePoint Sub Sites? Yes
    4. Can you access this SharePoint site from Work browser on the device? Yes
Page 1 of 2 12 LastLast

Similar Threads

  1. Developers: PLEASE Make More Apps Compatible With The Q10
    By nerdydaddyo in forum BlackBerry Q10
    Replies: 15
    Last Post: 02-20-2014, 11:11 PM
  2. BlackBerry Link STOPPED WORKING
    By Mark Dyer in forum BlackBerry Link
    Replies: 4
    Last Post: 02-12-2014, 11:05 AM
  3. Cannot Use BBM while on wifi
    By paramranjan in forum BlackBerry Curve 9370/9360/9350
    Replies: 5
    Last Post: 02-12-2014, 02:42 AM
  4. Replies: 4
    Last Post: 02-11-2014, 01:39 PM
  5. Snap update??
    By khader alkhateeb1 in forum PlayBook Apps & Games
    Replies: 1
    Last Post: 02-11-2014, 08:59 AM

Posting Permissions