03-12-17 05:40 PM
100 123 ...
tools
  1. oddboy's Avatar
    The Crackberry team has a post that you can use 64 GB SD cards, but they recommend reformatting to FAT132 first.

    To do that, insert the card, go to Settings, Storage. *make sure USA mode is turned off*, then format.

    The option to format isn't there if UsB model is on.
    R Field, TGaT and semperfi45 like this.
    02-25-13 09:44 AM
  2. Bold_until_Hybrid_Comes's Avatar
    Just take it out put it in again. Should format itself
    FSeverino and semperfi45 like this.
    02-26-13 04:47 AM
  3. TGaT's Avatar
    SD card was unrecognized when going in to settings > storage there was a button saying to format. Click that and you are good to go
    FSeverino and Supa_Fly1 like this.
    02-27-13 05:53 PM
  4. onvisa's Avatar
    Just take it out put it in again. Should format itself
    If thats the case then we have a problem Huston.
    Once in a while i do take my memory card out, so if do that i will loose everything?
    03-14-13 08:30 AM
  5. battery's Avatar
    If thats the case then we have a problem Huston.
    Once in a while i do take my memory card out, so if do that i will loose everything?
    No You'll be fine.
    03-14-13 12:38 PM
  6. FSeverino's Avatar
    I have the 64GB card from the CB Store in mine... works fine
    03-15-13 09:27 AM
  7. fbloise's Avatar
    glad to know a 64gb memory card is compatible, I'm thinking getting one for my Z10.
    03-20-13 07:48 AM
  8. ryanlrobinson's Avatar
    Mine isn't working, same SanDisk Ultra that's in the store. I've formatted multiple times on the device as described here and elsewhere. I've tried formatting a couple of times with different Windows utilities; this made the media I put on it show up in the Pictures and Music apps but selecting them doesn't work and I can't see anything in File Browsers (including trying to select a wallpaper or ringtone).
    03-22-13 12:37 PM
  9. SlcCorrado's Avatar
    Mine isn't working, same SanDisk Ultra that's in the store. I've formatted multiple times on the device as described here and elsewhere. I've tried formatting a couple of times with different Windows utilities; this made the media I put on it show up in the Pictures and Music apps but selecting them doesn't work and I can't see anything in File Browsers (including trying to select a wallpaper or ringtone).
    Why use windows?? Format the card directly from the device. Worked like a charm for me

    Posted via CB10
    LudwigvonKast likes this.
    03-23-13 09:05 AM
  10. jafobabe's Avatar
    Why use windows?? Format the card directly from the device. Worked like a charm for me

    Posted via CB10
    +1 Same here
    03-23-13 01:26 PM
  11. ryanlrobinson's Avatar
    Sorry, maybe I wasn't clear: I formatted multiple times - about 20 - on the device before resorting to Windows.

    Here's what eventually has mine sort of working: I tried to format using the command line on Windows, about the fifth Windows tool I tried. It hit 99% and then said that it is too big for FAT32, so now the card is in RAW. Took the card out, put it in the Z10. Reset the Z10. Formatted the card on the Z10. Reset the Z10. Started synchronizing with Link, completed about a third of my library before it says the card is no longer available. This is the point where the files do show up in the Music and Pictures apps on the phone but they won't open and aren't viewable in File Browser or any other app that uses File Browser (setting Screensaver, ringtone, etc). Reset the phone again and they have so far been accessible. Sync a bit more until it says that the card is no longer accessible again. Reset device. I hope to finish copying my library by the end of today by repeating the last two steps; I just have to be paying attention in order to reset it every time it fails or I can't even access what is already copied.
    kendraon likes this.
    03-24-13 05:42 AM
  12. battery's Avatar
    Sounds like a bad card to me.

    Posted via CB10
    FSeverino and Mangelhaft like this.
    03-24-13 10:47 AM
  13. tinker2000's Avatar
    Mine wouldn't work at all until formatted on the phone, but has behaved impeccably since it was formatted by the Z10. I fear you have a dodgy card, as had similar experience with a Sony MemoryStick some years ago.
    03-24-13 12:13 PM
  14. SlcCorrado's Avatar
    Sorry, maybe I wasn't clear: I formatted multiple times - about 20 - on the device before resorting to Windows.

    Here's what eventually has mine sort of working: I tried to format using the command line on Windows, about the fifth Windows tool I tried. It hit 99% and then said that it is too big for FAT32, so now the card is in RAW. Took the card out, put it in the Z10. Reset the Z10. Formatted the card on the Z10. Reset the Z10. Started synchronizing with Link, completed about a third of my library before it says the card is no longer available. This is the point where the files do show up in the Music and Pictures apps on the phone but they won't open and aren't viewable in File Browser or any other app that uses File Browser (setting Screensaver, ringtone, etc). Reset the phone again and they have so far been accessible. Sync a bit more until it says that the card is no longer accessible again. Reset device. I hope to finish copying my library by the end of today by repeating the last two steps; I just have to be paying attention in order to reset it every time it fails or I can't even access what is already copied.
    Dude you have some knock off card or something? I don't think anyone but you has had this problem. Sorry
    03-24-13 12:25 PM
  15. Ryan Simmons's Avatar
    Just got my 64GB SanDisk Ultra Mobile class 10 and it works fine. Just formatted it in the phone and have not had a single issue so far.

    Posted via CB10
    ivos#CB likes this.
    04-01-13 09:45 PM
  16. so crow's Avatar
    Yeah I'm gonna get myself a 64gb card real soon.

    Posted via CB10
    04-04-13 02:55 PM
  17. FSeverino's Avatar
    Sounds like a bad card to me.

    Posted via CB10
    this
    04-04-13 05:52 PM
  18. capcom303's Avatar
    Got a 64 g card from best buys on Easter for only $37 with tax because of a $10 bonus rewards card. Its working fine in my Z10
    04-04-13 06:55 PM
  19. schiri's Avatar
    Slightly OT:
    Currently using just a 4gb card but how do you save media straight to the card and not the device?

    THX
    04-05-13 07:43 AM
  20. brandonsalim's Avatar
    Why is the feature to safely remove card in Z10 not there? I usually press that upon removing media card in my 9810..
    04-05-13 08:32 AM
  21. Ryan Simmons's Avatar
    Slightly OT:
    Currently using just a 4gb card but how do you save media straight to the card and not the device?

    THX
    I think there is an option in BlackBerry App World to save music, pics etc to the sd card and in the camera settings, you can set SD card there. apart from that I don't know of any other ways. I think the phone knows you have an sd and automatically stores the files there

    Posted via CB10
    04-05-13 09:06 AM
  22. b121's Avatar
    Posted via CB10
    ReneV likes this.
    04-05-13 07:23 PM
  23. curvezzz's Avatar
    I have had 3 cards. I formated in the phone then removed the card to transfer the data from my 16 gb card takes hours to do so and when I pop the 64 in the phone some stuff doesn't show. I have tried several times also formated on pc dropped and dragged one by one folder ar all at once same result. Then on last try I got close to being able to access most of my stuff when the card is now unreadable which I didn't notice till my ringtones went to default.

    Posted via CB10 from my AT&T Z10
    04-07-13 01:50 PM
  24. John Pawling's Avatar
    Sounds like a bad card to me.

    Posted via CB10
    The OP should try scanning and fixing it in Windows. Took me about 30 minutes for a 32GB card and then my card stopped being temperamental.

    Posted Via CB10 on my Zed10
    battery likes this.
    04-07-13 01:55 PM
  25. HedoBum's Avatar
    To do that, insert the card, go to Settings, Storage. *make sure USA mode is turned off*, then format.
    Help! Can't find USA mode! Is that because I'm using a Canadian phone?
    04-07-13 01:58 PM
100 123 ...

Similar Threads

  1. Will this 16 GB SD Card work on the Tour?
    By nomadpass in forum BlackBerry Tour 9630
    Replies: 7
    Last Post: 07-19-09, 11:00 PM
  2. 16 GB SD Cards for your 8330
    By tbhlhi in forum BlackBerry Curve 83xx
    Replies: 3
    Last Post: 04-14-09, 12:24 PM
  3. 16 gb sd card owners
    By i_have_a_berry in forum General BlackBerry Discussion
    Replies: 5
    Last Post: 02-13-09, 01:39 PM
  4. 16 gb sd card in 8330 curve
    By gizorge in forum BlackBerry Curve 83xx
    Replies: 8
    Last Post: 11-24-08, 05:13 AM
  5. 8 GB SD Card
    By LaSalle05 in forum BlackBerry Curve 83xx
    Replies: 32
    Last Post: 10-14-08, 08:49 PM
LINK TO POST COPIED TO CLIPBOARD