Welcome to the CrackBerry Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 24 of 24
Like Tree5Likes
  • 1 Post By Motherboard2010
  • 1 Post By mithrazor
  • 2 Post By Cobalt232
  • 1 Post By Cobalt232
  1. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #1  

    Default 10.2.1.1925 and Google Play services

    I installed .1925 and also followed the guidance in this how-to-fix-side-loading thread, but I still get the error "Google Play Services has stopped" in many (probably all) the side-loaded apps. That didn't use to happen before .1925.

    Almost all the time, it is annoying but harmless. I just press OK and it goes away only to come back again in 5-10 secs.

    Thanks.

    10.2.1.1925 and Google Play services-img_20140115_135608.png
    Thanked by:
    aminrajabi (01-15-2014) 
    Dunmanway Emar likes this.
  2. Andrew4life's Avatar
    CrackBerry Genius

    Posts
    2,933 Posts
    Global Posts
    2,934 Global Posts
    #2  

    Default

    Why are you sideloading Ebay? There is an Android port in BlackBerry world. (though it is out of date, it works)
  3. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #3  

    Default

    eBay was only an example. Every side loaded app that uses Google Play Service is behaving that way ... and I have many. As for why eBay... you said it... "out of date". Yes the old one works, but ... hey... with .1925 I'm living dangerously
    Last edited by Motherboard2010; 01-14-2014 at 11:39 PM.
  4. mithrazor's Avatar
    CrackBerry Master

    Posts
    1,203 Posts
    PIN
    2B1BC93C
    #4  

    Default

    Oh this isn't supposed to happen? It's always happened with me. I went from 10.1 MR to 10.2.1.1925.

    In snapchat, instagram etc.

    Posted via CB10
    mundo472 likes this.
  5. Azrae49's Avatar
    CrackBerry Abuser

    Posts
    443 Posts
    PIN
    24D33D18
    #5  

    Default

    Well not all of them, Google maps, Google play music, Google earth, Google voice and ingress + a few more, are running fine if you install the modified google play services and login services.

    Posted via CB10
    Check out BB10Store for working android apps, games and their obb data: http://forums.crackberry.com/android...ptoide-892140/
  6. yeek's Avatar
    CrackBerry Abuser

    Posts
    153 Posts
    #6  

    Default

    Do not use DDAP and bar files to side load android apps on 1925? Use either 1mobile or snap to install apk file directly.

    Posted via CB10
  7. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #7  

    Default

    Quote Originally Posted by Azrae49 View Post
    Well not all of them, Google maps, Google play music, Google earth, Google voice and ingress + a few more, are running fine if you install the modified google play services and login services.

    Posted via CB10
    If you are right, that some are fine, why aren't some others working just as well? When you say "modified"... are you referring to the mods made by Cobalt232 in the thread, How to fix any Android app dependent on Google Maps API and make maps working? If not, please expand so I can compare. Thanks.

    But if I can clarify, when I use Google Maps... I do have a problem when google map tries to login. It says "no network connection". I haven't worried to much about it, because I don't have to login. Haven't found a benefit in needing to ... so I've left it.
  8. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #8  

    Default

    Quote Originally Posted by yeek View Post
    Do not use DDAP and bar files to side load android apps on 1925? Use either 1mobile or snap to install apk file directly.

    Posted via CB10
    I used Snap and I also used Chrome Extension for BB10 / PlayBook App Manager. The eBay apk (pictured in my original post) was loaded from snap and it still has that problem. I don't know 1mobile. I'll dig up on that... I'm willing to try anything. Thanks.
  9. Cobalt232's Avatar
    CrackBerry Master

    Posts
    1,013 Posts
    #9  

    Default

    If you want to login succesfully with Google Maps and use ie. starred places, you must remove Google Play Services.


    Posted via CB10
    Need original Google Play Store? VISIT MY GOOGLE APPS LANDING PAGE
    Does your Android app cry for Google Play Services? Try my GMAPS PATCHER
    Want to pull Android Runtime logs from your Blackberry? Try my BLACKBERRY LOGGER
    Install Snap Google Play store without any hassle? Try my SNAP INSTALLER
    Thanked by 2:
    damien kupuku (01-17-2014),  Motherboard2010 (01-16-2014) 
  10. yeek's Avatar
    CrackBerry Abuser

    Posts
    153 Posts
    #10  

    Default

    For eBay specifically, I suggest use the native BlackBerry 10 version, there is no advantages to use the android one.

    Posted via CB10
  11. Dealz417's Avatar
    CrackBerry Abuser

    Posts
    499 Posts
    #11  

    Default

    Quote Originally Posted by yeek View Post
    For eBay specifically, I suggest use the native BlackBerry 10 version, there is no advantages to use the android one.

    Posted via CB10
    Native? I'm sure the Ebay app in BlackBerry World is also Android plus it's an older version. I use a newer version via the Google Play Store which works just fine.

    Posted via CB10
    Blackberry Z10 (STL100-2): 10.2.1.2947
  12. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #12  

    Default

    Quote Originally Posted by yeek View Post
    For eBay specifically, I suggest use the native BlackBerry 10 version, there is no advantages to use the android one.

    Posted via CB10
    Agree with Dealz417. There is no "native" BB10 ebay app. But the point is it isn't just that app. I have two other apps Urbanspoon and Gumtree below. Australian Open app, Viber, etc are others.

    I am probably doing something wrong. Question is ... "What?"

    10.2.1.1925 and Google Play services-img_20140116_074749.png10.2.1.1925 and Google Play services-img_20140116_070126.png
  13. Azrae49's Avatar
    CrackBerry Abuser

    Posts
    443 Posts
    PIN
    24D33D18
    #13  

    Default

    Quote Originally Posted by Motherboard2010 View Post
    If you are right, that some are fine, why aren't some others working just as well? When you say "modified"... are you referring to the mods made by Cobalt232 in the thread, How to fix any Android app dependent on Google Maps API and make maps working? If not, please expand so I can compare. Thanks.

    But if I can clarify, when I use Google Maps... I do have a problem when google map tries to login. It says "no network connection". I haven't worried to much about it, because I don't have to login. Haven't found a benefit in needing to ... so I've left it.
    The reason that one some of them aren't working is because of the stub installed where google services framework should be on our phone, we can't remove it because we don't have root level access and we can't install another version while the stub is present. Some apps function fine without the framework, using the partial google play services that we have. Some apps will pick up on the missing framework or on our device models and give an error saying play services is not supported on our devices. So basically to be able to use those apps we need to wait for BlackBerry to release a version on the OS without the stub, or somehow gain root access and remove it ourselves. If we we're able to install google services framework, we would also be able to use the play store.

    Posted via CB10
    Check out BB10Store for working android apps, games and their obb data: http://forums.crackberry.com/android...ptoide-892140/
    Thanked by:
    Dunmanway Emar (01-19-2014) 
  14. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #14  

    Default

    Quote Originally Posted by Azrae49 View Post
    The reason that one some of them aren't working is because of the stub installed where google services framework should be on our phone, we can't remove it because we don't have root level access and we can't install another version while the stub is present.

    Posted via CB10
    Thanks Azrae49. That does make sense. I'm wondering though if that is what is wrong in my system. I'm including a screenshot of what's seen by Chrome BB10 PlayBook App Manager. It seems to suggest I've got com.google.android.gsf.login ... is that the stub you are referring to? It seems that I can uninstall this 2.19MB APK file.

    As a last ditch, I'm going to uninstall it and if it works ... I'll report it. If its still not good, I'll reinstall 1925 and start from a clean slate.

    10.2.1.1925 and Google Play services-gsf.jpg
  15. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #15  

    Default

    Quote Originally Posted by Cobalt232 View Post
    If you want to login succesfully with Google Maps and use ie. starred places, you must remove Google Play Services.


    Posted via CB10
    Cobalt232, I was following your guide installing all APKs and installing Maps. Also most of the threads suggest needing GPS, so what do I miss out without GPS?

    Btw, I fixed this problem. I reversed all your instructions, and started again and it fixed the problem. Needed a few strategic reboots.

    Thanks.

    Posted via CB10
  16. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #16  

    Default

    Quote Originally Posted by Motherboard2010 View Post
    .
    As a last ditch, I'm going to uninstall it and if it works ... I'll report it.

    Click image for larger version. 

Name:	GSF.jpg 
Views:	4189 
Size:	77.9 KB 
ID:	239033
    It worked!!!

    I've got a new challenge, now that this is solved. But that's another thread.

    Thanks to all who helped steer me in the right direction.

    Posted via CB10
  17. Azrae49's Avatar
    CrackBerry Abuser

    Posts
    443 Posts
    PIN
    24D33D18
    #17  

    Default

    Quote Originally Posted by Motherboard2010 View Post
    It worked!!!

    I've got a new challenge, now that this is solved. But that's another thread.

    Thanks to all who helped steer me in the right direction.

    Posted via CB10
    Wait so are you able to install google services framework now? But even if you could uninstall it, install will most probably still be blocked...

    Posted via CB10
    Check out BB10Store for working android apps, games and their obb data: http://forums.crackberry.com/android...ptoide-892140/
  18. Cobalt232's Avatar
    CrackBerry Master

    Posts
    1,013 Posts
    #18  

    Default

    Quote Originally Posted by Azrae49 View Post
    Wait so are you able to install google services framework now? But even if you could uninstall it, install will most probably still be blocked...

    Posted via CB10
    He just uninstalled the google login services (com.google.android.gsf.login) from the package I provided.
    What we need to get rid off is com.google.android.gsf, and this component can't be deleted as it is part of the OS
    Need original Google Play Store? VISIT MY GOOGLE APPS LANDING PAGE
    Does your Android app cry for Google Play Services? Try my GMAPS PATCHER
    Want to pull Android Runtime logs from your Blackberry? Try my BLACKBERRY LOGGER
    Install Snap Google Play store without any hassle? Try my SNAP INSTALLER
    gemoelle likes this.
  19. whenever's Avatar
    CrackBerry User

    Posts
    58 Posts
    #19  

    Default

    Quote Originally Posted by Azrae49 View Post
    Well not all of them, Google maps, Google play music, Google earth, Google voice and ingress + a few more, are running fine if you install the modified google play services and login services.

    Posted via CB10
    How do you install the modified google play services and login services?
  20. AshDeezy's Avatar
    CrackBerry Abuser

    Posts
    363 Posts
    Global Posts
    367 Global Posts
    #20  

    Default

    Any more progress here? This thread got me excited... I'm trying to get Lyft working.


    Black Z10, White Z10, Black Q10. Z30 coming soon (hopefully).
    Follow me on Twitter: @AshDeezy
  21. Daniel Irving's Avatar
    CrackBerry Abuser

    Posts
    417 Posts
    Global Posts
    427 Global Posts
    #21  

    Default

    Seems like a lot of hassle to use a few apps?? (Google services runaround)

    Posted via CB10
  22. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #22  

    Default

    Quote Originally Posted by AshDeezy View Post
    Any more progress here? This thread got me excited... I'm trying to get Lyft working.
    I think you should be using the official 10.2.1 that is circulating the traps. My local carrier hasn't posted it ... and I'm glad I jumped with .1925 or I'd still be waiting . If you are like me and still trying ... I hope this helps. But I think this boat has sailed for most people.

    10.2.1.1925 and Google Play services-barapps.jpg

    In accord with Cobalt's suggestion I've uninstalled Google Play Services (crossed) and haven't installed it back. I notice in the ensuing threads that he has a new Play Services apk file. I'm game ... but right now, I've been very content without Play Services. Everything I need works, so ... I'm going to sit for a while before trying the new iterations.
  23. AshDeezy's Avatar
    CrackBerry Abuser

    Posts
    363 Posts
    Global Posts
    367 Global Posts
    #23  

    Default

    Quote Originally Posted by Motherboard2010 View Post
    I think you should be using the official 10.2.1 that is circulating the traps. My local carrier hasn't posted it ... and I'm glad I jumped with .1925 or I'd still be waiting . If you are like me and still trying ... I hope this helps. But I think this boat has sailed for most people.

    Click image for larger version. 

Name:	BARapps.jpg 
Views:	616 
Size:	200.0 KB 
ID:	243219

    In accord with Cobalt's suggestion I've uninstalled Google Play Services (crossed) and haven't installed it back. I notice in the ensuing threads that he has a new Play Services apk file. I'm game ... but right now, I've been very content without Play Services. Everything I need works, so ... I'm going to sit for a while before trying the new iterations.
    I've been using 10.2.1 for some time now and I'm on 1925, Lyft still doesn't work. Are you saying that by simply delete GSF that it will work?


    Posted via CB10


    Black Z10, White Z10, Black Q10. Z30 coming soon (hopefully).
    Follow me on Twitter: @AshDeezy
  24. Motherboard2010's Avatar
    CrackBerry User

    Posts
    91 Posts
    Thread AuthorThread Author   #24  

    Default

    Quote Originally Posted by AshDeezy View Post
    I've been using 10.2.1 for some time now and I'm on 1925, Lyft still doesn't work. Are you saying that by simply delete GSF that it will work?

    Posted via CB10
    I don't need a Lyft, so I can't say for sure what your problem is. What I did to make a few of the Android apps to work was to remove and reinstall everything in the order that Cobalt suggested. I only left out GSF.

    I should say, before I did that, I was lost in a corruption of Google login services. And Google maps kept failing to login. After removing GSF, maps logged in ok. So, for you, I'd say it's worth a try. It does seem that the there is nothing to loose but the jury is still out on that.

    Posted via CB10

Similar Threads

  1. Typo and injunction
    By Tariq Nasir in forum BBRY
    Replies: 8
    Last Post: 01-19-2014, 09:08 AM
  2. Keyboard Shortcuts and Speed Dial On Touch Devices?
    By boeingrules in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 01-16-2014, 10:55 AM
  3. The great disconnect (Between Tech and User reviews)
    By 40blind40 in forum General BlackBerry Discussion
    Replies: 8
    Last Post: 01-15-2014, 07:20 AM
  4. FB Contacts issue still ongoing on 10.2?
    By Mazinger in forum BlackBerry Q10
    Replies: 1
    Last Post: 01-15-2014, 06:55 AM
  5. Flash Player Problem in 10.2?
    By podbot in forum BlackBerry Z10
    Replies: 1
    Last Post: 01-14-2014, 09:08 PM

Posting Permissions