1. EdY's Avatar
    My webworks apps work fine on the latest DevAlpha OS build (1675), which I compiled using the previous version of Webworks (1.0.3.8?).

    Do I still need to recompile with Webworks Gold SDK (1.0.4.5?) and resubmit to appworld, *even* if my apps seem to work perfectly fine on the dev alpha 10.0.9.1675?

    I am using bbUI.js and all my functions on my apps seem to be working ok, and RIM didn't send me an email (like they did last time) telling me that my apps need to be recompiled and resubmitted like happened when we went from Webworks 1.0.2.9? to 1.0.3.8?

    Thoughts anyone?


    Sent from my BlackBerry 9810 using Crackberry Tapatalk Forum app
    12-17-12 08:22 PM
  2. Morten's Avatar
    My webworks apps work fine on the latest DevAlpha OS build (1675), which I compiled using the previous version of Webworks (1.0.3.8?).

    Do I still need to recompile with Webworks Gold SDK (1.0.4.5?) and resubmit to appworld, *even* if my apps seem to work perfectly fine on the dev alpha 10.0.9.1675?

    I am using bbUI.js and all my functions on my apps seem to be working ok, and RIM didn't send me an email (like they did last time) telling me that my apps need to be recompiled and resubmitted like happened when we went from Webworks 1.0.2.9? to 1.0.3.8?

    Thoughts anyone?
    Yes You should.

    Old the "pre gold" SDKs should be considered beta, and it's only from Gold moving forward that compatibly with release version is guaranteed.
    12-17-12 09:00 PM
  3. peter9477's Avatar
    You apparently don't need to, but I really think you ought to. Are you ever planning to update your app again, ever? If so, wouldn't you think it's safer to update it now and make sure it's fully tested, before you have lots of users? If you hold off, you're just pushing that SDK upgrade into the future, where you'll probably have forgotten something about how you build or package things, or the SDK will have been updated again with incompatible changes (always a possibility), or something else. I'd say not going to gold now, when there's still lots of time before launch, would be foolish unless you plan never to make another release.
    12-17-12 09:40 PM
  4. EdY's Avatar
    Thanks for the reply.

    So basically, increase the version number on all my Webworks apps, recompile them with the Gold SDK, and update all my vendor portal file bundles?



    Sent from my BlackBerry 9810 using Crackberry Tapatalk Forum app
    12-17-12 09:40 PM
  5. peter9477's Avatar
    Yes, and re-test! :-)
    12-18-12 12:41 PM

Similar Threads

  1. Micro SD card not detected on my 9700, works fine on PC
    By thattguy in forum BlackBerry Bold 9700
    Replies: 5
    Last Post: 09-08-10, 10:51 PM
  2. Will my apps work?
    By PrimalYeti in forum BlackBerry Torch 9800
    Replies: 14
    Last Post: 08-20-10, 01:17 PM
  3. Will my apps work?
    By PrimalYeti in forum BlackBerry OS Apps
    Replies: 14
    Last Post: 08-20-10, 01:17 PM
  4. Replies: 9
    Last Post: 12-20-09, 10:07 PM
  5. Replies: 9
    Last Post: 12-20-09, 10:07 PM
LINK TO POST COPIED TO CLIPBOARD