1. lovedaazn's Avatar
    So my z30 is only 2 weeks old. Got it off kijij. It's in good physical condition and the previous owner barely used it apparently.

    My battery drained today for some reason and my BBM is at 54% of battery usage.

    Here is my screen shot of the device monitor.

    Anyone have any advice as to how I can fix this?



    Attachment 296835
    Last edited by lovedaazn; 09-09-14 at 10:22 PM.
    09-09-14 10:33 AM
  2. willowbeast's Avatar
    Reload the os, or reinstall the leaked os you have.
    Have you tried holding down both volume buttons to hard reset the phone?

    Posted via CB10
    09-09-14 10:49 AM
  3. bobshine's Avatar
    You have a serious BBM addiction buddy! Lol

    Maybe try to restart your phone.

    Posted via CB10
    09-09-14 11:01 AM
  4. lovedaazn's Avatar
    Reload the os, or reinstall the leaked os you have.
    Have you tried holding down both volume buttons to hard reset the phone?

    Posted via CB10
    Can you give me the proper steps on how to reload the OS? I haven't done that in a while. And I just tried the hard reset, doesn't seem to help.

    Either CB or my z30 isn't letting me attach the device months screen shot.

    Posted via CB10
    09-09-14 11:13 AM
  5. willowbeast's Avatar
    Can you give me the proper steps on how to reload the OS? I haven't done that in a while. And I just tried the hard reset, doesn't seem to help.

    Either CB or my z30 isn't letting me attach the device months screen shot.

    Posted via CB10
    Make sure you backup using link before doing anything. Then there is an option to reload os. Click that. Then restore. Or better yet start from scratch. You could go to the extreme in backing up then security wipe then reload os then start from scratch. This is providing you are not running a leaked os.

    Posted via CB10
    09-09-14 11:29 AM
  6. lady of the lake's Avatar
    Click image for larger version. 

Name:	IMG_20140909_095129.png 
Views:	323 
Size:	106.9 KB 
ID:	296738
    My Z30 battery life is horrible since the Verizon OS update over a week ago. I've restarted, rebooted several times and it looks like I'm going to have go back to the previous OS. I seem to be the only one complaining about this which baffles me even more. What is the procedure to go back to the old OS. I've only backed up with BlackBerry link once quite some time ago. How do I keep the current contacts and calendar? (I'm using the calendar that came with the Z30) . Can anyone please help me ? I'm not too tech savvy!

    My bitchin' Z30 BlackBerry
    09-09-14 12:10 PM
  7. lovedaazn's Avatar
    Make sure you backup using link before doing anything. Then there is an option to reload os. Click that. Then restore. Or better yet start from scratch. You could go to the extreme in backing up then security wipe then reload os then start from scratch. This is providing you are not running a leaked os.

    Posted via CB10
    I don't use leaks! Only official versions from Bell.

    When you say start from scratch you mean like don't restore my z30 with a backup? And manually add all my contacts and such?


    Posted via CB10
    09-09-14 02:13 PM
  8. willowbeast's Avatar
    I don't use leaks! Only official versions from Bell.

    When you say start from scratch you mean like don't restore my z30 with a backup? And manually add all my contacts and such?


    Posted via CB10
    Yes, your contacts should be added when you set up your email. Providing you saved them in your account. The reason I suggest from scratch is that you will avoid any possible issues you may have backed up.

    Posted via CB10
    09-09-14 03:40 PM
  9. lovedaazn's Avatar
    Yes, your contacts should be added when you set up your email. Providing you saved them in your account. The reason I suggest from scratch is that you will avoid any possible issues you may have backed up.

    Posted via CB10
    I don't think I want to start from scratch. But the hard reset actually worked.

    Is this an issue that will happen all the time or was it just bad luck?

    I've been looking through the forum and people have been having this issue on the z10 and sometimes the z30. Did I get get a bad z30 from a bad batch maybe?

    Posted via CB10
    Last edited by lovedaazn; 09-09-14 at 09:31 PM.
    andy Parnham likes this.
    09-09-14 09:00 PM
  10. lady of the lake's Avatar
    I don't think I want to start from scratch. But the hard reset actually worked.

    Is this an issue that will happen all the time or was it just bad luck?

    I've been looking through the forum and people have been having this issue on the z10 and sometimes the z30. Did I get get a bad z30 from a bad batch maybe?

    Posted via CB10
    Make sure you are using the right charger. I learned that the hard way...

    My bitchin' Z30 BlackBerry
    09-11-14 11:46 AM
  11. lovedaazn's Avatar
    Make sure you are using the right charger. I learned that the hard way...

    My bitchin' Z30 BlackBerry
    I only use blackberry chargers.

    Just out of curiosity, how did you learn it the hard way?

    Posted via CB10
    09-11-14 01:27 PM
  12. lady of the lake's Avatar
    I only use blackberry chargers.

    Just out of curiosity, how did you learn it the hard way?

    Posted via CB10
    This is a copy of my post from the
    "Verizon Confirms They No Longer Sell the Z30" thread

    Well I got my replacement Z30 which isn't what I'd expected. It is a reconditioned "Certified Like-New Replacement" that has no back on it.

    The crazy thing is my husband just got the almost indestructible Kyocera Brigadier the day before and I had a hell of a time setting it up especially accessing the Verizon cloud for his contacts from his old 3G Casino GzOne flip phone - yes I'm dragging him into the technology world slowly which hasn't been easy as the he's never sent a text, sent or had email (other than the account I set up and monitor for him for our farming operation) in his life. Ends up our broadband equipment (that had been replaced and upgraded last week and moved to a better location on our house) wasn't working even though the device monitor showed on our phones as transmitting and receiving data. It's been down intermittently the past week and may have been contributing to my poor battery life and crazy Stand By and OS usage percentages. It also caused me to burn through all my data allotment and to have to purchase more.

    I had left my wall charger at the lake house and was using an older BlackBerry one which was taking 10-12 hours to charge and making my phone hotter than hell. The Kyocera has the same non removable battery as the Z30 and would charge in less than 3 hours so I used it's wall charger to charge my Z30 for the last 2 nights and my phone and battery are working like new again.

    I'm going to wait another day or two to make sure my Z30 continues functioning normally and am going to send the "Refurbished" replacement phone back to Verizon (if it was new I'd probably keep it anyway).

    The lessons learned: Wifi must be working properly and continuously; Back up phone regularly - don't have OS updates install automatically; and finally, Using the right charger is essential to battery life and proper function of my once again awesome Z30.



    My bitchin' Z30 BlackBerry

    My bitchin' Z30 BlackBerry
    09-12-14 11:36 AM
  13. lovedaazn's Avatar
    So I don't understand why my z30 is doing this.

    I just reloaded the OS after a security wipe. Then I even started from scratch.

    And my phone is acting up again. Then battery is draining fast and the z30 is getting hot.

    The only temporary fix is a hard reset.

    Any advice?

    Attachment 297402
    09-12-14 01:33 PM
  14. lady of the lake's Avatar
    Is your charger functioning properly? Did you accidentally let your battery run completely out or to under 5%? I think maybe the OS update caused my spare BlackBerry charger I was using to malfunction and not give a good charge without heating them both up. Two days in a row I was unaware my percentage dropped below 5% or completely discharged in a very short amount of time. The following day I also had plugged my phone into my laptop and BlackBerry link while on the phone with Verizon Tech support and after that the phone stopped heating up. Probably just a coincidence but after that my phone's holding a charge and functioning normally.( I also did reboot the phone several times during that time). Good luck.


    My bitchin' Z30 BlackBerry
    09-12-14 06:42 PM

Similar Threads

  1. Z30 screen cracked!
    By Bernard Gauthier in forum BlackBerry Z30
    Replies: 23
    Last Post: 09-26-14, 12:57 PM
  2. Z30 Power Button
    By Drew 2 in forum Ask a Question
    Replies: 2
    Last Post: 09-10-14, 05:02 AM
  3. Blackberry Z30 new charger?
    By Abteen in forum Ask a Question
    Replies: 4
    Last Post: 09-09-14, 07:03 PM
  4. Q10 battery life decline
    By joshska in forum Ask a Question
    Replies: 1
    Last Post: 09-09-14, 01:55 PM
  5. Best method to break in new Z30 battery?
    By quailallstar in forum BlackBerry Z30
    Replies: 2
    Last Post: 09-09-14, 08:53 AM
LINK TO POST COPIED TO CLIPBOARD
";