1. toad-63's Avatar
    Hi all. Hoping someone can give me some advice. My 18 month old STL 100-2, Z10 has been annoyingly turning itself off over the last month with a slight jolt or pressure on the backplate. This will often happen with placing it back in its holster, but is intermittent, and might go a week with no problems, then act up for a day or so. My impression is that it happens more when it is a hot day, but I'm not completely sure. Is this a bug that's common or easily fixed, or off to the repairers or a new hand piece ?? Thanks kindly for any advice.

    Posted via CB10
    10-01-14 08:04 AM
  2. H4zN's Avatar
    One of my colleagues had the same problem as you. I advised him to put a piece of paper or something sturdy in the space between the battery and the part behind it. The connector is probably pushed a little to the inside, which gives the battery too much space to move. You need to block that movement by pushing the battery back to the connector and tada!
    10-01-14 08:09 AM
  3. toad-63's Avatar
    Cheers, shall give it a shot and get back to you. Much obliged.

    Posted via CB10
    10-01-14 08:46 AM
  4. toad-63's Avatar
    Hi there. I did as suggested and cut a few battery sized pieces of magazine paper and put them behind the battery and so far so good. Have jiggled, clicked and clicked and not a turn off yet !!
    Thanks kindly, your advice has really been a great service, saved me a trip to the phone fixers and $$$...cheers and thanks again !

    Posted via CB10
    H4zN likes this.
    10-01-14 11:50 PM
  5. H4zN's Avatar
    Hi there. I did as suggested and cut a few battery sized pieces of magazine paper and put them behind the battery and so far so good. Have jiggled, clicked and clicked and not a turn off yet !!
    Thanks kindly, your advice has really been a great service, saved me a trip to the phone fixers and $$$...cheers and thanks again !

    Posted via CB10
    Mission Accomplished! Glad I could help ;D
    10-02-14 02:59 PM

Similar Threads

  1. !!! Z3 on sale in Canda at 269.9 $CAN ? (Expansys)
    By Superfly_FR in forum News & Rumors
    Replies: 11
    Last Post: 10-22-14, 02:33 PM
  2. Hybrid radio 1131 with OS 1154??
    By frannip in forum BB10 Leaked/Beta OS
    Replies: 21
    Last Post: 10-16-14, 03:18 PM
  3. Q10 with OS 10.3.0.1154 - Advanced interactions stopped working
    By whenever in forum BB10 Leaked/Beta OS
    Replies: 13
    Last Post: 10-07-14, 04:55 PM
  4. Z10 unable to upgrade
    By gsvc2000 in forum BlackBerry Z10
    Replies: 13
    Last Post: 10-03-14, 05:05 AM
  5. How do I install Indian font on BB Curve 8520?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-01-14, 09:28 AM
LINK TO POST COPIED TO CLIPBOARD