1. jimmyjamesfc's Avatar
    Guys, hope you can help me. My Z10 is indicating zero charge after just minutes of charging up to 100% and it keeps working just fine without overheating. I have restarted the device many and removed the battery. Unfortunately, I don't have another battery and figure this can damage the battery so I'm charging up whenever I can. Hope you have any ideas. Thanks in advance.
    Click image for larger version. 

Name:	IMG_20150119_152548.png 
Views:	39 
Size:	88.4 KB 
ID:	328349
    Click image for larger version. 

Name:	IMG_20150119_152601.png 
Views:	39 
Size:	94.3 KB 
ID:	328350

    Posted via CB10
    01-19-15 01:26 PM
  2. shamazi13's Avatar
    Maybe you have to delete all your apps just to confirm whether your Battery is out of order...good luck Bro!
    jimmyjamesfc likes this.
    01-20-15 05:23 AM
  3. jimmyjamesfc's Avatar
    Thanks. I let drain out of charge and apparently it's now indicating charge correctly. !

    Posted via CB10
    01-20-15 08:04 AM

Similar Threads

  1. Replies: 3
    Last Post: 02-03-15, 10:11 PM
  2. Does anyone else think that Docs To Go needs some work?
    By jamescpage in forum General BlackBerry Discussion
    Replies: 25
    Last Post: 01-30-15, 03:06 PM
  3. Why won't my Verizon Cloud work with my BB Z-10?
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 01-27-15, 09:39 PM
  4. How do I remove information from my Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-19-15, 01:30 PM
  5. My ear piece on the z10 make annoying noise when I talk on it.
    By Jason Moore3 in forum Ask a Question
    Replies: 1
    Last Post: 01-19-15, 12:40 PM
LINK TO POST COPIED TO CLIPBOARD