1. msaterj's Avatar
    I have a Z10STL100-1/10.3.0.1052 , and whenever I have data services active on my phone my battery dies super fast (in about 3hrs) and phone tends to get really warm (over 42deg. Celsius). Without data services it last for hours. Been having this problem long before 10.3, 10.2.1 and 10.2.

    Also

    Whenever I plug in the charger it doesn't charge whenever I'm using the phone even if it's just simply texting unless I leave the phone, instead it shows that icon which means the battery is full. I was using original charger that came with it and now I'm using an original PlayBook charger and it's the same thing.

    ANY IDEAS???
    Click image for larger version. 

Name:	IMG_20140823_102531.png 
Views:	38 
Size:	217.6 KB 
ID:	292871

    Posted via CB10
    08-23-14 10:33 AM
  2. pttptppt's Avatar
    Try restarting or hard restarting. Also try the battery calibration tutorials (search crackberry for it). If nothing works, you may have to reload your os. Did this happen recently (when you updated) or has it always been a problem?
    08-23-14 11:41 AM

Similar Threads

  1. Wi-Fi Calling and REG99
    By cbvinh in forum T-Mobile
    Replies: 361
    Last Post: 12-17-14, 02:35 PM
  2. Will BES Cloud Work with my Google Apps Account?
    By zmsox in forum BES10 Cloud
    Replies: 5
    Last Post: 09-26-14, 09:24 AM
  3. Is it a good time to buy a Z10?
    By dadbritain in forum BlackBerry Z10
    Replies: 5
    Last Post: 08-24-14, 06:00 AM
  4. z10 10.3 update
    By Kayhan Zadeh in forum BlackBerry Z10
    Replies: 3
    Last Post: 08-23-14, 10:48 AM
  5. How many still like curve 9220, 8530 and os 7
    By SaurabhIb in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 08-23-14, 10:48 AM
LINK TO POST COPIED TO CLIPBOARD