1. CrackBerry Question's Avatar
    I've been running a Z10 STL100-3 on the Telus network in Canada for years. I recently purchased a used, unlocked Z10 (STL100-4) cheap. It was from the US on the Verizon network. Is there a way to get this to function here in Canada, perhaps by restoring a backup from my other phone to this one?
    jly4 likes this.
    02-28-16 03:55 AM
  2. rbtg's Avatar
    it should work but only with 3g
    02-28-16 05:30 AM
  3. raino's Avatar
    it should work but only with 3g
    Actually, unless there's a carrier with an LTE band 13 network that allows data-only connections, an STL100-4 will only work on 2G up there.

    Rogers is the only one among the Big Three that has a nationwide GSM 2G network.
    02-28-16 06:21 PM
  4. thurask's Avatar
    Incidentally, if you want to upgrade the OS with an autoloader/Sachesi/whatever, they do share the same files.
    02-28-16 07:36 PM
  5. rbtg's Avatar
    Actually, unless there's a carrier with an LTE band 13 network that allows data-only connections, an STL100-4 will only work on 2G up there.

    Rogers is the only one among the Big Three that has a nationwide GSM 2G network.
    mine works in Canada and Mexico with 3G only but with verizon sim card
    02-29-16 08:33 AM

Similar Threads

  1. Any recommendations on a Signal Booster App?
    By jbfair728 in forum BlackBerry 10 Apps
    Replies: 1
    Last Post: 02-28-16, 06:57 PM
  2. App auto on/off and mode airplane
    By duonganhtuan in forum BlackBerry Passport
    Replies: 1
    Last Post: 02-28-16, 12:34 PM
  3. Q10 leaks load on Globe Philippines
    By Wrec in forum BlackBerry Q10
    Replies: 4
    Last Post: 02-28-16, 12:58 AM
  4. Android app notification issue on hub
    By menglim in forum BlackBerry 10 OS
    Replies: 0
    Last Post: 02-28-16, 12:27 AM
  5. Replies: 1
    Last Post: 02-27-16, 11:25 PM
LINK TO POST COPIED TO CLIPBOARD