1. Charli121's Avatar
    I have this problem since yesterday. I put my cell phone on back up on via Link! After backing up the device keep turning off and on again and again. I pulled the battery for like 3 or for times for as long as I could but it didn't started. Plus now it does not give the display until I put it on a charger or PC but again it only shows the Blackberry logo again turned off then on...
    what should I do? please help me with this!
    Thanks,
    07-12-15 11:33 AM
  2. Madhuchandran's Avatar
    You might check battery efficency.

    Posted via CB10
    07-12-15 12:49 PM
  3. leese56's Avatar
    This happened to my 9810, it would continually restart until the battery was drained. While I was upgrading to my z10 the guy at Telus told me that this sometimes will happen if the battery contacts on the phone become dirty, and can sometimes be fixed by brushing them with a dry toothbrush. never bothered to try as I was upgrading anyway, but it's worth a try.

    Posted via CB10
    07-12-15 01:16 PM

Similar Threads

  1. Z10 Swipe down from top bezel issue
    By Tstark14 in forum BlackBerry Z10
    Replies: 6
    Last Post: 07-16-15, 10:17 AM
  2. JC and his Passport
    By usman_hidayat19 in forum General BlackBerry Discussion
    Replies: 44
    Last Post: 07-14-15, 12:36 PM
  3. 4G and great battery life!
    By sgosh in forum BlackBerry Z30
    Replies: 3
    Last Post: 07-12-15, 09:31 PM
  4. Which autoloader is best for Z10 in 10.3.2..... series?????
    By gyanboy in forum BB10 Leaked/Beta OS
    Replies: 1
    Last Post: 07-12-15, 11:15 AM
  5. Replies: 2
    Last Post: 07-12-15, 09:39 AM
LINK TO POST COPIED TO CLIPBOARD