1. Mel217's Avatar
    Okay, so I've got a problem with my BB playbook. I've had it for maybe 4-5 years now (so it's not a recent version, if that helps...). I'd never had any trouble with it until recently, but since about 2 days it just won't charge anymore.

    I don't know if it's the charger that's damaged or the tablet itself... My battery power isn't completely dead yet, I've got around 20% left I think. The thing is, when I try to charge it back up nothing happens, or anyway nothing that's supposed to.

    See, I plug the charger into a perfectly good wall socket, right? One that's always worked in the past. Then I plug the little USB port into my playbook. Up until now that worked perfectly well, and the small battery logo at the top of my screen got this little lightning bolt over it, indicating that the device was charging... But as of 2 days ago, nothing. I follow the exact same steps and the little lightning bolt doesn't appear, as if my playbook can't connect with its charger anymore. So the power just keeps slowly decreasing.

    I've tried using a brand new charger but even with that one the same problem occurs.

    Just in case I've also tried shutting down my playbook completely, then plugging it in while it's off. When I do that the LED light turns on red for a few seconds, then turns off. The light doesn't turn on again after that, but there's this picture that appears on the screen for another few seconds: an electrical plug with an arrow pointing towards a lightning bolt. I guess it's telling me to plug the device into some kind of electrical power station now... but it already is! (the wall socket)

    So, I'd really like to know what the problem is before the battery dies completely, and also how to solve it if at all possible. Please let me know, and thank you in advance.

    Mel
    02-10-15 07:58 AM
  2. Carl Estes's Avatar
    First look in here for the stack charging process, common issue, especially with the life use of your PB, I had 2 of them, and my number 1 PB started doing the same thing, stack charging brought it back for a while, but I suspect that the batteries in the device are starting to get beyond their "life cycle".
    If Stack charging doesn't resurrect your device and bring it back to it's glory, you can opt to replace the batteries in the device. Not hard, you tube vids will walk you thru the process...
    02-10-15 09:23 AM
  3. Mel217's Avatar
    Thanks a lot for answering so promptly!

    I've read many posts about this stack charging method; I get how it works, I think, but it seems to be mostly for BB playbooks that are completely dead (aka won't turn on at all). I can still turn mine on, it's just very low on battery power (about 18% now). I want to bring it back to 100% but as I said, when I plug the charger into the wall socket nothing happens. It's like the playbook doesn't realize it's plugged in... The little battery logo above the screen is usually white in color, but now that the power has dropped below 20% it's turned orange, and the small lightning bolt that's supposed to indicate it's charging doesn't ever appear anymore.

    Should I still try stack charging, even if my device isn't completely dead yet? Well, I did give it a try: I turned off my playbook and applied the stacked charging method for a while... I didn't see much progress. The LED light only flashes red for a few seconds, then goes off. It doesn't ever flash green or any other color. It's a bit discouraging... After about an 1 1/2 hours of doing that I turned my playbook on again. It worked fine, but no change; the battery was still at 18% and dropping. I turned the thing off again.

    Should I keep trying? Should I still try stack charging? Something else?

    Thanks in advance to whoever will answer and give me a few pointers.

    Mel

    P.S. To Carl Estes: Thank you again. I think maybe my batteries might be getting too old, like you said... I hope not, but what do I know? If nothing else works I'll follow your advice about maybe replacing them, if that's even the problem. We can never be sure with these darn gadgets! [pouts]
    02-10-15 11:25 AM
  4. pkcable's Avatar
    Possibly the port is damaged, maybe try the rapid charger?
    02-10-15 11:46 AM
  5. FrankUnderwood's Avatar
    Possibly the port is damaged, maybe try the rapid charger?
    Check with the port first...that was my issue with my first Playbook. Got the rapid charger after that...stacked it and it's good to go.

    Just make sure the PB doesn't go to zero...which has been the cause of my battery issues.

    Posted via CB10 on the President Underwood version of the BlackBerry Classic
    02-10-15 12:01 PM
  6. rebroker2009's Avatar
    Try a different compatible charger first, even better, try and get the magnetic rapid charger as it uses a different charging port beside the regular port


    Blackberry Passport running 10.3.1.2267
    02-10-15 12:14 PM
  7. Mel217's Avatar
    Thank you! I do believe the port might be damaged... I've had this playbook for over 5 years now, so... I like the idea of the rapid charger, definitely gonna get one of those, regardless of what solution I find for my problem.

    I did see something in one of the posts I read and decided to try it, just to see if it would work: I downloaded the latest BlackBerry Desktop software to my computer. Then after the program was running, I connected my playbook (it was shut off at the time) to my computer using my compatible USB cable. The playbook then turned itself on as the program connected to it. Now though a few weird things are happening...

    First, the little battery logo at the top of the screen still shows no lightning bolt (like it should), but the device seems to be charging nonetheless, although very slowly. What's up with that?

    Second, my new BlackBerry Desktop software apparently has no trouble finding and recognizing my BB playbook, but it absolutely refuses to let me access my Media (pics, music, vids). It says they are not available due to a problem while attempting to connect to my device; leads me directly to a troubleshoot window. What does that mean exactly? How do I access my files?

    Any idea? Once again I'd be very grateful!
    02-10-15 02:42 PM
  8. Mel217's Avatar
    Thank you! I do believe the port might be damaged... I've had this playbook for over 5 years now, so... I like the idea of the rapid charger, definitely gonna get one of those, regardless of what solution I find for my problem.

    I did see something in one of the posts I read and decided to try it, just to see if it would work: I downloaded the latest BlackBerry Desktop software to my computer. Then after the program was running, I connected my playbook (it was shut off at the time) to my computer using my compatible USB cable. The playbook then turned itself on as the program connected to it. Now though a few weird things are happening...

    First, the little battery logo at the top of the screen still shows no lightning bolt (like it should), but the device seems to be charging nonetheless, although very slowly. What's up with that?

    Second, my new BlackBerry Desktop software apparently has no trouble finding and recognizing my BB playbook, but it absolutely refuses to let me access my Media (pics, music, vids). It says they are not available due to a problem while attempting to connect to my device; leads me directly to a troubleshoot window. What does that mean exactly? How do I access my files?

    Any idea? Once again I'd be very grateful!
    02-10-15 10:39 PM
  9. suzicat's Avatar
    I have this same problem now. Battery is down to 14% and Playbook doesn't recognize any chargers. I've tried the USB charger, the dock rapid charger and the other rapid charger that uses the 3 prong charging port. I retrieved this Playbook from my daughter after she had let is stay completely discharged for long periods of time. Is there any hope for it? OP did you find a solution that worked?
    06-15-15 01:03 PM

Similar Threads

  1. The microphone on my Z10 is no longer working. What do I do?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 6
    Last Post: 09-17-15, 06:48 PM
  2. can I get snapchat on my z10?
    By jamesonbell in forum BlackBerry Z10
    Replies: 28
    Last Post: 07-05-15, 07:53 PM
  3. flashing led but bb is dead
    By yasheen omaram 10 in forum BlackBerry Bold 9930/9900
    Replies: 8
    Last Post: 06-17-15, 11:41 AM
  4. lost my voicemail option
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 06-16-15, 10:25 AM
  5. Why no sound on my Z10, media or notifications?
    By CrackBerry Question in forum BlackBerry Z10
    Replies: 3
    Last Post: 06-16-15, 04:36 AM
LINK TO POST COPIED TO CLIPBOARD