1. CrackBerry Question's Avatar
    I recently got a Z10 from digicel (Jamaica). It worked alright for about a month or two then when I upgraded to 10.3, shortly after I got a message saying sim card blocked... I was surprised because the phone and the sim card are both from Digicel. I thought it was a software problem so reloaded back 10.2.1 and the message came back again.. any help would be greatly appreciated.
    01-31-15 03:32 PM
  2. igotaq's Avatar
    Have you tried a different sim in the phone?

    Posted via CB10
    01-31-15 04:38 PM
  3. Adrii18's Avatar
    Uhmm well I did try another sim but it was from the same carrier
    01-31-15 07:43 PM
  4. BCLoco's Avatar
    Sounds like you need to talk to your carrier.
    01-31-15 08:28 PM
  5. raino's Avatar
    Uhmm well I did try another sim but it was from the same carrier
    And? Did that SIM work?

    Did you try your SIM in another phone, to rule out it's not the SIM card that's fried?
    01-31-15 08:54 PM
  6. Adrii18's Avatar
    I called them but they said they don't have unlocking services... I have to carry it to their head office. I also tried the sim in another phone.. it works fine
    01-31-15 09:34 PM

Similar Threads

  1. Replies: 1
    Last Post: 02-04-15, 10:24 AM
  2. Replies: 2
    Last Post: 01-31-15, 08:05 PM
  3. Why won't my Z10 turn on?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 01-31-15, 02:41 PM
  4. How do I re-calibrate my BB Z10 battery indicator?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-31-15, 01:39 PM
  5. Is Uber available for the Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-31-15, 12:48 PM
LINK TO POST COPIED TO CLIPBOARD