1. CrackBerry Question's Avatar
    Yesterday evening my Classic got very hot in its holster. I took it out and it returned to normal quickly. But the battery is losing its charge very fast since then. I bought it new in the box from a reputable major retailer less than 11 months ago. Is the battery failing? Any suggestions? Many thanks, Glenys
    11-09-16 10:56 PM
  2. rayfz's Avatar
    Sorry, I cannot really help, but your question made me wonder. Because the same problem happened to my classic. I used it for almost a year, but then I purchased a brand new Amzer Shellster, holster plus shell. Great looks, seemingly perfect fit. But the battery life deteriorated and, in fact, it is now totally dead. So, I suspect there could be a link there? Has anyone had a similar experience? Ray.
    11-10-16 10:38 AM
  3. AmritD's Avatar
    Yesterday evening my Classic got very hot in its holster. I took it out and it returned to normal quickly. But the battery is losing its charge very fast since then. I bought it new in the box from a reputable major retailer less than 11 months ago. Is the battery failing? Any suggestions? Many thanks, Glenys
    You could check your device monitor to see what's draining your battery. Post a screenshot here so it might enable people to help you out

    Z30STA100-2/10.3.2.2876
    11-10-16 10:57 AM
  4. rayfz's Avatar
    You could check your device monitor to see what's draining your battery. Post a screenshot here so it might enable people to help you out

    Z30STA100-2/10.3.2.2876
    As mentioned, my battery seems totally dead, and plugging the Classic in has no effect whatsoever. No beeps, no lights, nothing. And leaving it plugged in for an extended time period does not make any difference. Btw, the battery is "non-replaceable", so I am going to find an after market battery and then open that phone up. We'll see. And thanks for your reply. Ray.
    11-10-16 11:06 AM
  5. AmritD's Avatar
    As mentioned, my battery seems totally dead, and plugging the Classic in has no effect whatsoever. No beeps, no lights, nothing. And leaving it plugged in for an extended time period does not make any difference. Btw, the battery is "non-replaceable", so I am going to find an after market battery and then open that phone up. We'll see. And thanks for your reply. Ray.
    The holster could be messing with the signal strength and hence causing the battery to discharge faster .
    Did you try connecting the phone to link?
    See if it detects the phone


    Z30STA100-2/10.3.2.2876
    11-10-16 02:00 PM
  6. rayfz's Avatar
    To amritv, I am not quite sure what you mean when you say "....connect the phone to link". What is that link?
    Sorry for my innocence here. But I am not exactly a computer guy. Ray.
    11-10-16 05:22 PM
  7. Lusitano17's Avatar
    To amritv, I am not quite sure what you mean when you say "....connect the phone to link". What is that link?
    Sorry for my innocence here. But I am not exactly a computer guy. Ray.
    Amritv means connect the phone to desktop and see if BlackBerry Link desktop software recognizes your device.

    Posted via CB10
    11-10-16 05:33 PM
  8. Manesik's Avatar
    The holster could be messing with the signal strength and hence causing the battery to discharge faster .
    Did you try connecting the phone to link?
    See if it detects the phone


    Z30STA100-2/10.3.2.2876
    He said that the battery is totally dead. Anyways... the extra packaging you're putting on your device just worsens it's ability to cool. Therefore, your battery is running hotter and it's capacity(ie. Service life) decreases faster. Did you guys not connect the fact that it went bad after the holster got introduced?

    Posted via CB10
    11-10-16 05:56 PM
  9. glenys g's Avatar
    Thank you all. I had been checking the device monitor and everything looked OK. So, next step was I shut down completely - I call that the off setting. Then I lleft the device out of the holster and connected it to recharge in the off setting. When it was fully recharged, still keeping it out of the holster, I switched back on and put the device notifications into Bedside mode. About 14 hours later and still out of the holster, I reset notifications to vibrate only mode. The battery life looks right - it is still at 85% after 20 hours. Everything seems to be working fine again, but I haven't had it back in the holster yet.
    So, I'm thinking, as one of you suggested, it was something to do with having been in the holster. Trying a long shot, I have even checked to see if there was anything physical caught in the holster itself that might have physically interfered but didn't find anything. I am going to try a full recharge and then having it back in the holster. Will let you all know.
    Many thanks for your suggestions
    Glenys G
    11-11-16 10:56 AM

Similar Threads

  1. Is BB Torch9800 still usable nowadays?
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 11-12-16, 07:59 AM
  2. Replies: 2
    Last Post: 11-10-16, 09:34 AM
  3. How do I transfer pictures from a Bold to my computer?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 11-09-16, 07:46 PM
  4. How do I access pictures from my media card on my Z10.
    By 454vette in forum Ask a Question
    Replies: 1
    Last Post: 11-09-16, 05:31 PM
  5. HELP - My Z10 always restore
    By hoangphuong00 in forum BlackBerry Z10
    Replies: 1
    Last Post: 11-09-16, 01:09 PM
LINK TO POST COPIED TO CLIPBOARD