1. CrackBerry Question's Avatar
    I have 2x 9320
    I have 2x sims, from different networks. (vodacom, 8ta)
    I have: formatted both phones and reinstalled a vodacom (vodafone) OS on both.
    I have done a sim swop on the vodacom sim
    I have formatted the memory cards.
    Problem:
    Either phone with 8ta sim in works 100% (no BIS)
    Either phone with vodacom sim runs battery flat in 3hrs
    Either phone with any other vodacom sim, with BIS, works perfectly
    ISP says no idea what causing problem.

    Any ideas?
    11-25-14 05:35 AM
  2. DaFoxGrey's Avatar
    Is the reception low or spotty at your locations on Vodacom?
    If the signal is low, the phone works harder trying to get and keep the connection, which causes the battery to drain much faster.
    11-25-14 06:36 AM
  3. BerrySA's Avatar
    The signal does vary, but mostly above 80% with 3g the primary connection.
    11-25-14 07:18 AM
  4. DaFoxGrey's Avatar
    The signal does vary, but mostly above 80% with 3g the primary connection.
    Try this if you can be without the phone for a few hours:
    Set up the device on Vodacom.
    Turn off the Mobile Network, GPS (if the device has it), Data Services, Blue Tooth, and WiFi (if the device has it). This pretty much turns off anything the device will need to fight with in a low signal area.
    Wait a few hours, as in the time span you would normally see the battery drain down, and check the battery level.
    If it's only slightly down, it may be the signal issue.
    If it's drained down as your were experiencing, then there may be an issue with the SIM card.
    11-25-14 07:51 AM
  5. BerrySA's Avatar
    Hi.
    Did this, same result.
    Did a complete reinstall (again) with the vodacom build, and retried your suggestion.
    Problem is still there.
    Going to take phone to repairshop..
    Thanks for help
    DaFoxGrey likes this.
    11-28-14 03:29 AM
  6. Originalloverman's Avatar
    Is it very cold where you are my experience it tends to drain very fast in extreme cold

    Posted via CB10
    11-28-14 10:13 AM

Similar Threads

  1. Passport battery life
    By koltzy in forum BlackBerry Passport
    Replies: 12
    Last Post: 04-15-15, 09:20 AM
  2. My Z10 is getting poor battery performance
    By dforrest08 in forum BlackBerry Z10
    Replies: 25
    Last Post: 11-27-14, 12:30 PM
  3. Not signed into BBM but still draining battery!
    By carnivorsaurus in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 11-26-14, 06:03 AM
  4. Troubleshooting battery issues.
    By gkl in forum BlackBerry Z10
    Replies: 5
    Last Post: 11-24-14, 07:15 PM
  5. Q10 battery life issue after loading 10.3 leak
    By ammarozman in forum BlackBerry Q10
    Replies: 1
    Last Post: 11-24-14, 07:38 AM
LINK TO POST COPIED TO CLIPBOARD