1. CrackBerry Question's Avatar
    My Phone goes in turn off mode when battery is 4% (Forget this issue, It is calibration issue with Z10 & Battery ) But every time when I connect to charger no matter how much time i connect it with charger the battery remain at 5-9% ( & goes downwards either charging is connected or not) untill i reconnect the charger. already tried using different OSs first i was on 10.2.1 now using 10.3 but still with the same issue... can anybody tell me what is the solution of this irritating problem.
    10-12-14 05:25 AM
  2. ronfc's Avatar
    You may try this one trick that works on my STL100-1:

    1. Turn OFF your phone by pressing and holding the power/lock button on top until the device shuts down.
    2. Remove the battery.
    3. Plug your charger to an AC socket and the other end, to your phone's USB/charging port (as if you're charging your phone normally).
    4. After about 5 seconds, remove the charger, put back the battery, and turn ON your device.
    5. At this point, your device should display the real percentage of your battery.

    If it still doesn't work, then I suggest getting a new LS1 battery for your Z10.
    10-13-14 04:26 AM

Similar Threads

  1. Google Services and Rooting for Z10?
    By Joker And His z10 in forum BlackBerry Z10
    Replies: 40
    Last Post: 09-12-15, 05:11 AM
  2. BLA1ZE help needed on Passport VIP issue
    By CrackberryQ in forum BlackBerry Passport
    Replies: 147
    Last Post: 10-19-14, 03:20 AM
  3. Bump in steel frame on my Passport
    By Taigatrommel in forum BlackBerry Passport
    Replies: 12
    Last Post: 10-12-14, 01:44 PM
  4. Why am I unable to reload software on my Bold 9900 after a error 513?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 10-12-14, 12:04 PM
  5. How can I restore my music files?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-12-14, 05:14 AM
LINK TO POST COPIED TO CLIPBOARD