1. CrackBerry Question's Avatar
    i hvae tryed evertyhing from new battery to new charger. my z10 only sign of life in a red LED light when i connect the charger but its weird becuase the light only comes on why i take the battery of and keep it connect it. people have advise me that it might be a software glinch and this happen to me maybe a week after i installed 10.2.1 and i charged it with a motorola moto g charger and not its original charger.
    10-18-14 10:06 AM
  2. YaseenKhan's Avatar
    First of try to load your device with any new OS for that download 10.2.xx or above autoloader. Now start that autoloader connect your bb z10 USB and make sure your system have preinstalled BB link otherwise your system won't recognize the device. When you connect your device it will load new os. Wait till OS get loaded. Hope that works.
  3. danossh's Avatar
    Have you try reloading your device using BlackBerry Link? If it's still don't work you gotta factory reset then..

    Danossh7
    10-18-14 11:55 AM
  4. YaseenKhan's Avatar
    First of try to load your device with any new OS for that download 10.2.xx or above autoloader. Now start that autoloader connect your bb z10 USB and make sure your system have preinstalled BB link otherwise your system won't recognize the device. When you connect your device it will load new os. Wait till OS get loaded. Hope that works.
    10-19-14 12:43 AM

Similar Threads

  1. Replies: 13
    Last Post: 11-03-14, 02:00 PM
  2. Feel like stopping support for my colleagues
    By Loc22 in forum General BlackBerry Discussion
    Replies: 15
    Last Post: 10-19-14, 03:50 AM
  3. Email issue: random contacts appear on CC
    By rosemary quaye in forum Ask a Question
    Replies: 4
    Last Post: 10-18-14, 06:20 PM
  4. Replies: 2
    Last Post: 10-18-14, 07:39 AM
  5. How can I update my Z10 (STL100-1) to 10.3.1.396?
    By KushalBhardwaj360 in forum BB10 Leaked/Beta OS
    Replies: 2
    Last Post: 10-18-14, 07:27 AM
LINK TO POST COPIED TO CLIPBOARD