1. CrackBerry Question's Avatar
    I'm on the Z30 from Bell in Canada and have over the last week been told that my text messages have been received twice, three-five-eight, even TEN times! But I only sent said text message once. I've rebooted the unit multiple times to no avail and there's no available software update. HELP!!!
    04-17-15 09:35 AM
  2. Kris Simundson's Avatar
    Don't worry it's not just you, I have the same going on. My phone will recieve the same message multiple times sometimes. Sometimes it's even a few hours later i'll get the same msg (even though no conversation has gone on)

    I'm just chalking this up to a error in the way the companies are handling their networks. And it's likely something that hasn't been brought to their attention, or that they just don't care.
    04-17-15 09:45 AM
  3. John Vieira's Avatar
    Yeah, this seems to happen sometimes. It's definitely on the carrier end.

    You'll just have to wait until it clears up. If it goes on for more than a week or so, then call your carrier and tell them.

    And since you're with bell, demand a credit and tell them to fix it.

    Posted via CB10
    04-17-15 09:58 AM
  4. eddy_berry's Avatar
    It's funny. I seem to get weeks where my girlfriend's texts from her iPhone 5 on Rogers sends me doubles. Then sometimes it's perfectly fine. I've never had anyone tell me I was sending doubles. I'm in Bell with a Z30 as well.

    Posted via CB10
    04-17-15 10:05 AM
  5. 93Aero's Avatar
    Every time someone tells me they're getting multiple repeat from me, its when my 4GLTE signal goes to 4g.
    04-17-15 10:52 AM

Similar Threads

  1. Google maps on my passport?
    By AHAMTECH in forum Ask a Question
    Replies: 6
    Last Post: 06-18-15, 11:38 AM
  2. How to check if my radio is not faulty
    By Khizer Hayat2 in forum BlackBerry Z10
    Replies: 5
    Last Post: 04-17-15, 12:26 PM
  3. my z10 shows bberror bb10-0015 ,please help me
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 04-17-15, 08:28 AM
  4. Replies: 0
    Last Post: 04-17-15, 07:47 AM
  5. My z10 stuck on blue loading screen at 100%
    By CrackBerry Question in forum Ask a Question
    Replies: 0
    Last Post: 04-17-15, 12:21 AM
LINK TO POST COPIED TO CLIPBOARD