1. IamMilesValdez's Avatar
    I can't reach the 100% when charging my z10 using wall charger.

    But when removing battery ang vhargubg it for 30 mins using my laptop,then return the battery and charge again using laptop,it reaches 100%.i find it uneasy yo always charge removing battery and using laptop.

    Any help pls.i aalso tried draining the battery until phone shutdown and charge it again.still, it doesn't reach 100%.tha maximum is 93%.

    Does anyone of you guys encounter same prob with mr.any solution pls.is it on calibrating the battery issues?thanks

    Posted via CB10
    10-14-14 11:26 PM
  2. ronfc's Avatar
    Do you happen to use an STL100-1? Here's my workaround:

    1. Turn OFF your phone and remove the battery.
    2. Plug the charger on your device (your device's LED should lit red).
    3. Remove the charger and out back the battery (the phone will automatically turn itself ON).
    4. The phone will now display the real charge of the battery. Charge your phone normally after this. It should get you to a 100% now.

    Cave, cave, moderator videt
  3. ronfc's Avatar
    Do you happen to use an STL100-1? Here's my workaround:

    1. Turn OFF your phone and remove the battery.
    2. Plug the charger on your device (your device's LED should lit red).
    3. Remove the charger and out back the battery (the phone will automatically turn itself ON).
    4. The phone will now display the real charge of the battery. Charge your phone normally after this. It should get you to a 100% now.

    Cave, cave, moderator videt
    Lag_Fisher likes this.
    10-14-14 11:38 PM
  4. IamMilesValdez's Avatar
    Thanks Sir i'll try it.how long i'm gonna charge unit without the battery?until the red light disappear sir?

    Posted via CB10
    10-14-14 11:49 PM
  5. IamMilesValdez's Avatar
    Z10STL100-1/10.2.1.3247 this is my version sor

    Posted via CB10
    10-14-14 11:50 PM
  6. ronfc's Avatar
    Thanks Sir i'll try it.how long i'm gonna charge unit without the battery?until the red light disappear sir?

    Posted via CB10
    Yes, 10 seconds will suffice.

    Cave, cave, moderator videt
    10-15-14 03:28 AM
  7. aTrueBbLover's Avatar
    My z10 automatically switch off when 60 percent battery available. Plz help me on this. I'm on 10.2.1 with stl 1

    Posted via CB10
    01-03-15 08:11 PM
  8. Lag_Fisher's Avatar
    Do you happen to use an STL100-1? Here's my workaround:

    1. Turn OFF your phone and remove the battery.
    2. Plug the charger on your device (your device's LED should lit red).
    3. Remove the charger and out back the battery (the phone will automatically turn itself ON).
    4. The phone will now display the real charge of the battery. Charge your phone normally after this. It should get you to a 100% now.

    Cave, cave, moderator videt
    Does this work on STL100-3?

    CB on Q10
    01-14-15 10:47 PM
  9. ronfc's Avatar
    Does this work on STL100-3?
    It should work.
    01-15-15 05:52 AM
  10. girinath's Avatar
    I can't reach the 100% when charging my z10 using wall charger.

    But when removing battery ang vhargubg it for 30 mins using my laptop,then return the battery and charge again using laptop,it reaches 100%.i find it uneasy yo always charge removing battery and using laptop.

    Any help pls.i aalso tried draining the battery until phone shutdown and charge it again.still, it doesn't reach 100%.tha maximum is 93%.

    Does anyone of you guys encounter same prob with mr.any solution pls.is it on calibrating the battery issues?thanks

    Posted via CB10
    It is a more better method -
    Z10 New Battery Calibration Method

    Posted via CB10
    01-15-15 09:35 PM
  11. ronfc's Avatar
    The above method is technically the same as what I've posted, although inserting the battery while the charger is plugged in can cause short-circuit of the battery and device plates upon contact, and can cause much greater damage and risk of fire.

    Cave, cave, moderator videt
    01-16-15 12:46 AM
  12. ahamath zio's Avatar
    im using bbz10. im use after 30 mnts are my phone is heat. what a do for this??

    Posted via CB10
    01-16-15 12:56 AM
  13. ronfc's Avatar
    im using bbz10. im use after 30 mnts are my phone is heat. what a do for this??
    It is normal especially if you're playing games, multi tasking, or in a low coverage area. It only means the processor is working above normal and thus, drawing more power from your battery. If you're not doing anything but the device is still hot, check Device Monitor for any app that might be consuming battery or processor power. You might want also to restart your device. If the issue still persists, you may have to reload your BlackBerry 10 OS.

    Cave, cave, moderator videt
    01-16-15 01:16 AM

Similar Threads

  1. Any way to bypass firewall on z10 device?
    By simplykartik07 in forum BlackBerry Z10
    Replies: 10
    Last Post: 10-22-14, 08:15 AM
  2. Z10 apn settings issue.
    By mrcanoehead in forum BlackBerry Z10
    Replies: 8
    Last Post: 10-15-14, 07:43 AM
  3. Update crashes in z10
    By simplykartik07 in forum BlackBerry Z10
    Replies: 7
    Last Post: 10-15-14, 12:42 AM
  4. Why is my Bold 9900 battery draining so fast?
    By Shawn Bowman in forum BlackBerry Bold 9930/9900
    Replies: 1
    Last Post: 10-14-14, 09:58 PM
  5. How to Install .bar files in z10??
    By simplykartik07 in forum BlackBerry Z10
    Replies: 4
    Last Post: 10-14-14, 07:09 PM
LINK TO POST COPIED TO CLIPBOARD