1. gnirkatto's Avatar
    Z30, Q5, Passport on 10.3.0.1418. I can connect them to my PC via USB w/o problems, but not via WiFi. Phones and PC are on the same WiFi network with strong reception. The PC appears as 'coupled' under device connections. When trying to access the PC (e.g. through file manager), the popup 'warning - connection not possible' appears INSTANTLY (seems like the phone doesn't even check if there is a connection). Of course 'allow connections' is set to ON. There is no access restriction in my WiFi settings. I shut down both my Windows (7) firewall and my virus scanner, no success.
    I don't know what else to try. Does anyone have a good idea?
    Last edited by gnirkatto; 10-23-14 at 05:01 PM.
    10-23-14 04:14 PM
  2. diegonei's Avatar
    Double check Settings > Storage > WiFi access is turned on.

    Besides that, Link is sadly kind of unreliable. You may want to uninstall using Control Panel, run a clean up app like CCleaner and the install it again, directly from the USB (when you plug your Passport, it should prompt to install).
    10-23-14 04:32 PM
  3. gnirkatto's Avatar
    This Settings > Storage > WiFi access option is for something different, I think, because it asks for a password to be entered.
    I never was asked to enter a password when WiFi connection between a BB10 phone and my PC still worked (it did so last year, and I didn't try it out since then. Now it doesn't work).

    However, I set it to on and the connection still didn't work, this 'warning-no connection possible' -. popup still came up instantly.

    I already un- and reinstalled Link, no success.

    BLend doesn't work either. Not through WiFi (of course) nor through USB (although USB works for link and file access). It just looks for a connection for 2 minutes or so, and then ends, telling no connection possible.

    This is driving me mad.
    10-23-14 05:13 PM
  4. cdnrower's Avatar
    Z30, Q5, Passport on 10.3.0.1418. I can connect them to my PC via USB w/o problems, but not via WiFi. Phones and PC are on the same WiFi network with strong reception. The PC appears as 'coupled' under device connections. When trying to access the PC (e.g. through file manager), the popup 'warning - connection not possible' appears INSTANTLY (seems like the phone doesn't even check if there is a connection). Of course 'allow connections' is set to ON. There is no access restriction in my WiFi settings. I shut down both my Windows (7) firewall and my virus scanner, no success.
    I don't know what else to try. Does anyone have a good idea?
    Hi, I have found that I have to ensure I have turned off the radio and just leave on WiFi to connect to my PC using WiFi. I'm running Win7 and Kapersky and can connect both my Z10 and Z30 and not have to rely on Link to do it. Also, when you try to use the WiFi to connect to your PC, make sure you don't have your device connected with USB too. It doesn't like that. You do have to make sure your Link has it active for WiFi access for your device, set the folders that you are sharing on your PC, etc.. As suggested above maybe do a full uninstall and then clean install of the latest version of Link that now supports Passport for a fresh start. I had a prob in the past not being able to connect by WiFi on a device I never had the prob with before. I got around it be renaming my device so that it would see it as a new device. I was able to go back to the original name after an OS Leak update.

    Good luck, hope you get it resolved.
    10-25-14 02:47 PM
  5. rthonpm's Avatar
    A few things on the PC to check:

    Make sure that your network type is set to Home in the Network and Sharing Center, and that network discovery is turned on.

    Check and see if a BlackBerry network driver shows up in your list of network adapters.

    On the phones:

    Make sure that you have a password set for accessing via wifi (you won't necessarily need it since you'll be using Link) and also make sure that under network identification that the workgroup name is the same as your computer's. Once that's done, see if you can access your phone by its IP using that password and the username of BlackBerry.

    Make sure as well that you have the latest version of Link, and also consider a complete uninstall of all BlackBerry desktop software, downloading a fresh copy, and re-installing.

    Posted via CB10
    10-25-14 05:45 PM
  6. gnirkatto's Avatar
    I checked and followed all of the recommendations from above, no success. I also wiped BB Link completely from my system, and reinstalled it. Latest version, of course. But the popup 'connection not possible' still comes up instantly. I don't know what else to do. The phone doesn't even seem to check if there might be a connection, as this popup appears so quickly (less than a second!), whenever I try to connect to the PC.
    10-28-14 02:55 PM
  7. diegonei's Avatar
    Somebody postes a fix earlier today. Give it a try: Uninstall Link, download Blend and let Blend install Link.
    10-28-14 10:52 PM
  8. gnirkatto's Avatar
    I wiped Link again, including all drivers & settings, and reinstalled with Blend: same story. Connecting the phones via USB works, but as soon as I try to connect with no USB cable plugged in, this popup shows. Incredibly annoying.

    Looks like this could be my first time to not getting a PC/SW feature to work, after ~25 years of fiddling with PCs and other pieces of technology.
    10-29-14 06:31 AM
  9. kbz1960's Avatar
    Do you have USB mass storage on? When I try to connect to my bb from my lappy over WiFi I had to make a password when I turned on access over WiFi. So I have to enter blackberry as user name and then my password and I can search my phone all I want.
    10-29-14 06:43 AM
  10. GiantSchnauzer's Avatar
    There is a setting in link about allowing wireless connection to the phone which also must be checked.

    Z30 Pooooooooower!
    10-29-14 06:45 AM
  11. gnirkatto's Avatar
    Do you have USB mass storage on? When I try to connect to my bb from my lappy over WiFi I had to make a password when I turned on access over WiFi. So I have to enter blackberry as user name and then my password and I can search my phone all I want.
    No, USB mass storage is off. When turning it on, it says that no connection over Wifi will be possible.
    I don't fully understand, how do you connect 'to BB from PC over Wifi'? Of course all switches in Link are on, which allow for wireless access. But I was never asked for a password on the PC.
    10-29-14 08:24 AM
  12. gnirkatto's Avatar
    There is a setting in link about allowing wireless connection to the phone which also must be checked.

    Z30 Pooooooooower!
    All checked and on, long time ago, thanks anyway.
    10-29-14 08:26 AM
  13. GiantSchnauzer's Avatar
    Just grasping at straws here, is the pc and the phone connected to the router on the same 2.5 or 5ghz band? ( should not make a difference but worth a try)

    Z30 Pooooooooower!
    10-30-14 07:46 AM
  14. gnirkatto's Avatar
    Just grasping at straws here, is the pc and the phone connected to the router on the same 2.5 or 5ghz band? ( should not make a difference but worth a try)

    Z30 Pooooooooower!
    Yes it is.

    The strange thing about this is, that until some time ago, this worked flawlessly, with the same PC, on the same network, and even partly with the same phones (Q5 & Z30, no PP available back then).

    Then I didn't use WiFi connect for a couple of weeks, and now it no longer works. As I did not expect this to happen, I cannot exactly recall what I did in the meanwhile and when. What I believe I did was to update Link, as a new version was released.
    What I'm sure I did was to install Blend, a week before my PP arrived, in joyful anticipation.

    Then my PP arrived, and USB connect worked fine. Blend never connected, neither throught USB, nor through WiFi.

    Only THEN I tried to reconnect to the PC (for file transfer purposes) via WiFi, and figured it's not working. Then I tried all the things that were listed earlier in this thread, including complete uninstallation/wiping of Blend and Link. So far, nothing worked, and none of my 3 BB10 phones want to connect.

    Oh yes, I also upgraded both the Q5 and the Z30 to 10.3.0.1418 - but I don't think this is the problem, as it works for almost everybody else. And, hopefully needless to say, the 2 PCs, 2 TVs, 3 phones, an Android tablet, a Sony PS3, a Kindle reader and a heating control system are connected to the same WiFi router, and all works and talks to each other w/o any problem.
    10-30-14 09:37 AM
  15. kbz1960's Avatar
    No, USB mass storage is off. When turning it on, it says that no connection over Wifi will be possible.
    I don't fully understand, how do you connect 'to BB from PC over Wifi'? Of course all switches in Link are on, which allow for wireless access. But I was never asked for a password on the PC.
    I had to enter a password when I turned access over WiFi on my phone, not the PC. Then when I double click my phone on the PC it asks for my name and password. I guessed at blackberry for the name and put the password in that I made on my phone.

    Works perfect. I don't use link for it either. It's installed and the device manager loads at startup.
    Last edited by kbz1960; 10-30-14 at 09:56 AM. Reason: add
    10-30-14 09:51 AM
  16. gnirkatto's Avatar
    I had to enter a password when I turned access over WiFi on my phone, not the PC. Then when I double click my phone on the PC it asks for my name and password. I guessed at blackberry for the name and put the password in that I made on my phone.

    Works perfect. I don't use link for it either. It's installed and the device manager loads at startup.
    Yes I also had to enter a PWD when turning Wifi connect on on the phone, and I did.
    But where on the PC do you double klick your phone?, before it got connected?
    10-30-14 12:34 PM
  17. kbz1960's Avatar
    Yes I also had to enter a PWD when turning Wifi connect on on the phone, and I did.
    But where on the PC do you double klick your phone?, before it got connected?
    Windows explorer. Double click on your bb.

    Click image for larger version. 

Name:	Screenshot (1).png 
Views:	24 
Size:	98.1 KB 
ID:	311190

    Click image for larger version. 

Name:	Screenshot (2).png 
Views:	24 
Size:	82.9 KB 
ID:	311191

    Click image for larger version. 

Name:	Screenshot (3).png 
Views:	23 
Size:	82.7 KB 
ID:	311192

    Click image for larger version. 

Name:	Screenshot (4).png 
Views:	23 
Size:	82.3 KB 
ID:	311193

    Click image for larger version. 

Name:	Screenshot (5).png 
Views:	23 
Size:	137.7 KB 
ID:	311194
    Last edited by kbz1960; 11-01-14 at 06:43 AM.
    gnirkatto likes this.
    11-01-14 06:30 AM
  18. jhimmel's Avatar
    and also make sure that under network identification that the workgroup name is the same as your computer's.
    Where is this Network Identification - Workgroup Name you speak of on our BB10 handsets?

    Posted via CB10
    11-01-14 06:47 AM
  19. rthonpm's Avatar
    When you turn on WiFi, you're prompted to add a password and you'll also see an option for identification on Network: that will be where you can set the name, username, and preferred workgroup
    Click image for larger version. 

Name:	IMG_20141101_080838.png 
Views:	25 
Size:	63.1 KB 
ID:	311198

    Posted via CB10
    11-01-14 07:08 AM
  20. gnirkatto's Avatar
    Windows explorer. Double click on your bb.
    This worked, great thanks!
    The reason why I wasn't aware of this was because I never had to do that before, my PC and the BBs always connected by themselves, Ijust had to tapon my PC's name in file manager.....!?

    With that method, I can now at least access the BB's internal and SD storage, from my PC, and move data back and forth.

    However, accessing the PC from the BB still doesn't work! The popup still appears instantly! EVen after both devices got connected by use of this method. And with or without Link and BB device manager started. How strange is that! I have no explanation.
    kbz1960 likes this.
    11-01-14 12:23 PM
  21. lou2969's Avatar
    hi all I want revive this thread ..just because all the same is happening to me after a factory reset
    now I manage to connect to my BB trough the PC but I cant access the PC with File manager
    and in afew case when it connects it show the folder Blank with nothing in it
    why ??
    already posted some were else for the calendar problem
    this reset is driving me crazy
    need help guys ....thanks
    12-11-14 11:24 PM

Similar Threads

  1. Replies: 5
    Last Post: 10-24-14, 03:15 PM
  2. Replies: 8
    Last Post: 10-24-14, 01:28 PM
  3. How to fix blackberry z10 battery problem
    By malik ahmed1 in forum BlackBerry Z10
    Replies: 6
    Last Post: 10-23-14, 09:49 PM
  4. Can anyone assist me in updated my Q5?
    By laura rita santoro in forum BlackBerry Q5
    Replies: 3
    Last Post: 10-23-14, 07:00 PM
  5. Why can't my Bold 9900 connect to wifi?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 10-23-14, 03:07 PM
LINK TO POST COPIED TO CLIPBOARD
";