1. Manal Yousuf's Avatar
    Is there any solution to this problem??
    * * * *
    To be more precise, my camera just won't switch on. Not since I upgraded it to 10.2, and I was advised then to wait for the next update. I've upgraded to 10.3 now and no, it hasn't helped at ALL. I've tried rebooting, and it wouldn't switch on even though there were no apps running in the background or anything. And downgrading isn't a very good option for me, because I can't spare the time it'll take.

    Also, I've used the BBVE, and my phone's passing all the camera tests. Plus the camera works when I'm Skyping. So it definitely isn't a hardware thing.

    Please help me! It's been MONTHS since I've been able to use my camera. I cannot find any useful help on this problem. Seriously at my wit's end.
    03-06-15 09:16 AM
  2. jaydee5799's Avatar
    How did you update? OTA or did you install the update yourself?
    03-06-15 09:21 AM
  3. serbanescu's Avatar
    Use BlackBerry Link to reload the OS on your device.

    In Link choose Preferences > Reload Device Software

    Be sure to make a backup of your files (docs, pics etc) on the SD Card or on the PC before reloading the OS, otherwise you will lose everything stored on the internal memory.

    Very important! If your SD Card is encrypted, cancel the encryption before reloading the OS - otherwise you will lose everything stored on the SD Card, too.

    If you are dealing with a software problem, using Link to reload the OS should solve it, because Link downloads a fresh copy of the OS from BlackBerry servers.
    03-06-15 09:24 AM
  4. Manal Yousuf's Avatar
    I have already reloaded my OS! Forgot to mention that. Didn't work.
    03-06-15 10:04 AM
  5. Manal Yousuf's Avatar
    I installed the update myself once I received the notification for it.
    03-06-15 10:05 AM
  6. serbanescu's Avatar
    If you have already used BlackBerry Link to reload the OS and the camera app still doesn't open, your device has a hardware problem. The only solution is to take it to a service for a hardware repair (I don't know how feasible this could be).
    03-06-15 10:10 AM
  7. Manal Yousuf's Avatar
    Damnit you sure? Guess I'll have to try and get it fixed then. But why did it only stop working when I updated it then?
    03-06-15 10:31 AM
  8. masterscarhead1's Avatar
    Don't believe that bloke up there ^
    He doesn't know what he's talking about
    If the camera works while skyping, it means that your hardware is definitely not broken
    Sadly we have clueless people on our forum telling everyone their hardware is broken
    Next step to do is download an autoloader, DON'T USE LINK
    Download 10.3.1.1581 operating system for your device and load it
    Then come back and tell me what happens
    What I suspect you did with Link was more like a wipe than a full OS reload. In any case, using the autoloader will clear up any possibilities of it being a hardware issue
    Keep in mind, DO NOT RESTORE, or you might carry over corrupt files
    03-06-15 10:36 AM
  9. serbanescu's Avatar
    Don't believe that bloke up there ^
    He doesn't know what he's talking about
    If the camera works while skyping, it means that your hardware is definitely not broken
    Sadly we have clueless people on our forum telling everyone their hardware is broken
    Next step to do is download an autoloader, DON'T USE LINK
    Download 10.3.1.1581 operating system for your device and load it
    Then come back and tell me what happens
    What I suspect you did with Link was more like a wipe than a full OS reload. In any case, using the autoloader will clear up any possibilities of it being a hardware issue
    Keep in mind, DO NOT RESTORE, or you might carry over corrupt files
    Sorry, I haven't noticed the Skype reference

    masterscarhead1, you are true, if Skype is working, it is not a hardware problem. On the other hand, as far as I know Link should completely wipe out the phone and install a fresh copy of the OS. I find it strange that after reloading the OS with Link the problem is still there. Manal Yousuf, maybe you did a restore after the reload and in doing this you brought back the corrupted files?
    03-06-15 11:04 AM
  10. masterscarhead1's Avatar
    Sorry, I haven't noticed the Skype reference

    masterscarhead1, you are true, if Skype is working, it is not a hardware problem. On the other hand, as far as I know Link should completely wipe out the phone and install a fresh copy of the OS. I find it strange that after reloading the OS with Link the problem is still there. Manal Yousuf, maybe you did a restore after the reload and in doing this you brought back the corrupted files?
    All forgiven
    Best way to check is just use autoloader
    I'm not sure whether the OS reload with Link uses core + apps. If so, you end up with the same problem. If it uses debrick I dunno why it wouldn't have fixed the problem
    Only thing I can think of would be then the restore
    03-06-15 11:16 AM
  11. Rustybronco's Avatar
    There are two cameras. Hopefully " my phone's passing all the camera tests" means exactly that.
    Just trying to cover all bases.
    serbanescu likes this.
    03-06-15 03:19 PM
  12. serbanescu's Avatar
    There are two cameras.
    Excellent observation. Maybe only the front camera works (the one used usually by Skype), while the "main" camera (the back camera) has a hardware problem.
    03-07-15 03:12 AM
  13. Rustybronco's Avatar
    The back camera not working is a distinct possibility- especially on the STL100-1 models. The good thing is, 10.3.1 can hardware test both of them.
    03-07-15 07:19 AM
  14. Manal Yousuf's Avatar
    Serbanescu, I did the reload and then tried switching on the app. It didn't work. After that, I restored my files.

    Mastercarshead1, thanks for the advice. It'll take me a couple of days to download the autoloader and then I'll report back.

    It may be that it's the back camera that's broken, but I did run the BlackBerry Virtual Assistant after I upgraded to 10.3, and my phone passed all the tests. So I don't really think it's a hardware problem. Thoughts?
    03-07-15 03:17 PM

Similar Threads

  1. Positive article from the Globe and Mail
    By shahyaz in forum News & Rumors
    Replies: 12
    Last Post: 03-18-15, 06:21 AM
  2. Replies: 28
    Last Post: 03-11-15, 08:38 PM
  3. Does the Blackberry Classic sync to Microsoft Outlook?
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 03-07-15, 06:30 AM
  4. Turn on my BlackBerry
    By naorrazla in forum Ask a Question
    Replies: 2
    Last Post: 03-06-15, 01:47 PM
  5. Z30 for sale on TSC
    By BGK in forum BlackBerry Z30
    Replies: 1
    Last Post: 03-06-15, 08:50 AM
LINK TO POST COPIED TO CLIPBOARD