1. aussie99's Avatar
    I can't get my Whatsapp to sound alerts when a new message comes in.

    I get no LED blink and no sound.

    Both are turned on in the Whatsapp settings.

    I'm running Q10SQN100-3/10.2.1.3175

    Help?

    Posted via CB10
    12-28-14 02:23 AM
  2. aussie99's Avatar
    Bump

    Posted via CB10
    12-28-14 03:05 AM
  3. aussie99's Avatar
    Please

    Posted via CB10
    12-29-14 04:27 AM
  4. MiSsY_'s Avatar
    Have you given Whatsapp permissions?

    Posted via CB10 from my Z30
    12-29-14 04:31 AM
  5. aussie99's Avatar
    What does that mean?

    Fwiw Whatsapp had been working fine for a long time.

    Posted via CB10
    12-30-14 04:25 AM
  6. MiSsY_'s Avatar
    No recent updates?
    Have you tried to reboot the device?


    Posted via CB10 from my Z30
    12-30-14 05:16 AM
  7. aussie99's Avatar
    No updates for many many months.

    Rebooted a few times no change.

    Posted via CB10
    12-30-14 05:58 AM
  8. MiSsY_'s Avatar
    OK well then first I'd probably suggest updating the app.
    I think there was an update released in October or November.
    If you open App World and you don't see it in your available updates, then from app world, just tap the WhatsApp from the list of installed apps and then see if it says update instead of open

    Posted via CB10 from my Z30
    12-30-14 06:16 AM
  9. aussie99's Avatar
    I apologise. I thought u meant a BBOS update.

    It is the latest Whatsapp and I don't remember if it stopped working after I updated

    Posted via CB10
    12-30-14 06:33 AM
  10. aussie99's Avatar
    Anybody?

    Posted via CB10
    12-30-14 07:37 AM
  11. helalzone's Avatar
    First try a hard resetting your phone, by pressing volume up and down button for around 30 secs, if this doesn't work then, delete whatsapp and re install it.

    Helal
    12-30-14 08:17 AM
  12. helalzone's Avatar
    I m not sure how u hard reset Q10, might be a battery pull

    Helal
    12-30-14 08:18 AM
  13. MiSsY_'s Avatar
    Sorry I was going to suggest a hard reboot next.
    Also going into your Notification settings and check that the sounds are on properly before unstalling

    Posted via CB10 from my Z30
    12-30-14 10:38 AM
  14. aussie99's Avatar
    When Q10 came out we were told rebooting with holding the two buttons on side is exactly the same as battery pull.

    Posted via CB10
    12-31-14 08:03 PM
  15. Mikey_NNG's Avatar
    Lol, the reason why this is happening is because your phone's notification settings are clashing with your whatsapp settings. I had the same problem some months ago.

    Go to phone notifications in your settings
    Click image for larger version. 

Name:	IMG_20150101_023249.png 
Views:	18 
Size:	67.7 KB 
ID:	324520

    Tap on whichever profile you use, you should see a message saying your settings are different in some of the apps you use as seen in the image below
    Click image for larger version. 

Name:	IMG_20150101_023335.png 
Views:	18 
Size:	61.0 KB 
ID:	324521

    Now all you have to do is tap Customise App Notifications and find Whatsapp.. when u tap on whatsapp there should be an asterisk beside settings that differ to your phone settings, you'll want to correct this so everything works
    Click image for larger version. 

Name:	IMG_20150101_023604.png 
Views:	18 
Size:	55.9 KB 
ID:	324522

    That should fix it. Bear in mind I'm running 10.3.1.1154. No idea if this is the same process for 10.2.1. Hope it works.

    Posted via CB10
    12-31-14 08:39 PM
  16. aussie99's Avatar
    This looks interesting. Will check soon and report back.

    Posted via CB10
    12-31-14 08:54 PM

Similar Threads

  1. No more Netflix for BlackBerry Passport???
    By Sorg644 in forum Ask a Question
    Replies: 6
    Last Post: 02-21-15, 08:32 PM
  2. Whatsapp+Blend=ROCKING
    By Ajay Chopra1 in forum Ask a Question
    Replies: 27
    Last Post: 01-28-15, 01:36 PM
  3. Replies: 93
    Last Post: 01-01-15, 02:27 PM
  4. Roger's no early upgrade fee & Telus $100
    By mhw100 in forum BlackBerry Passport
    Replies: 5
    Last Post: 01-01-15, 08:03 AM
  5. Replies: 22
    Last Post: 12-29-14, 11:42 PM
LINK TO POST COPIED TO CLIPBOARD