1. CrackBerry Question's Avatar
    Hello, all. 1st time question, but long-time lurker from the UK. Really hope y'all can help.

    Got a Classic 5 days ago - switching from a much-loved 9320, having got fed up of chequer-boarding and constant charging - ironically, in view of my question.

    Love most things about the Classic, which I got off EBay - but the battery is going from full charge to near-zero in about four hours! The handset also gets very warm.

    I've done all the classic (!) battery-saving things: wifi off, brightness right down, no volume, time-out short, apps all closed, bluetooth & NFC off. I've also looked at all the forum answers I can find and followed all the tips, including a security wipe & waiting to see if things improved before reloading my data. Only using email and text messages, with very occasional browsing.

    The culprit is the system - it's using the CPU between 52% and 60%. I think I may've spotted the problem: on Settings: Data Management, the Mobile Data Usage section just scrolls constantly, not loading anything. Thing is - what can I do about this?

    The phone has clearly been dropped - there's a very, very tiny amount of damage to the screen on the right - but otherwise works perfectly.

    I thought BBM, which I never use, might be the problem but, as you'll know, it can't be uninstalled. I'm aware of Sachesi, and will give it a go if people think it'll help, but I do think that I have found the problem with the constant scrolling I mention above.

    I also have a Playbook (which does everything I want of it, beautifully), and had a similar problem with that - which I eventually worked out was the wifi constantly scanning for available networks; switching to Saved Networks solved that one. Could it be the same here? I've noticed that when I do have the wifi connected at home, it still scrolls every now and then, but not for long; I can't find any way to stop this.

    Sorry for the longevity, but I really don't want to have to send this phone back and start all over again, so would really appreciate any help you wise people can offer.

    Thanks,

    NE
    03-11-15 11:02 AM
  2. raj281977's Avatar
    provide OS version & battery stats screen shot
    03-11-15 11:07 AM
  3. kbz1960's Avatar
    Might need a wipe or OS reload.
    03-11-15 11:09 AM
  4. Chris Chin's Avatar
    ... and also CUP Current usage screen shot. Wait a few moments to let the CPU Current stats settle.


    What is killing my battery?-img_20150311_120918.png

    Posted via CB10
    03-11-15 11:10 AM
  5. Njae71's Avatar
    Hello, raj281977. I haven't provided a battery stats screen shot as I don't really need to, having given you the 'battery running out in about four hours' figure. The OS is 10.3.1.1565 - the most up-to-date I can access.

    Thanks.
    03-11-15 11:42 AM
  6. Njae71's Avatar
    Hi, kbz1960. Done both. :-)
    03-11-15 11:43 AM
  7. Njae71's Avatar
    Hi, Chris Chin. I don't really need to do this, as I'm not posting from my phone & I've given you the figure in my original post. Hope you've enough to go on.

    Thanks,
    03-11-15 11:44 AM
  8. raj281977's Avatar
    Hello, raj281977. I haven't provided a battery stats screen shot as I don't really need to, having given you the 'battery running out in about four hours' figure. The OS is 10.3.1.1565 - the most up-to-date I can access.

    Thanks.
    Have you installed any android apps?
    03-11-15 11:51 AM
  9. Njae71's Avatar
    Thanks for coming back. Only Adblock Plus. Last 48 hours, System's used 76% of the battery, PIM Services 30%, Standby 17%, Android Player 17%, Adblock Plus 4.2%.
    03-11-15 12:06 PM
  10. raj281977's Avatar
    Even after android app are closed they keep running in background. So you need to go to security and permissions, application permissions, select android app and close run in background. Then check your battery life.
    03-11-15 12:14 PM
  11. ssn494's Avatar
    Do you have remote file access turned on. Sometimes this feature seems to be the culprit and shown only under the system

    Posted via CB10
    03-11-15 12:18 PM
  12. Njae71's Avatar
    Thanks, had already checked this, but have ensured Adblock Plus, Facebook & Twitter are not running in the background.

    Still think the Mobile Data Usage constantly scrolling may be significant...
    03-11-15 12:57 PM
  13. Njae71's Avatar
    Don't THINK so, but please could you tell me where I can check.

    Thanks
    03-11-15 01:03 PM
  14. chaosdivine's Avatar
    I realize that your System is taking up most of your battery life but did you just update to 10.3.1? Have you done any OS updates since you got the phone? How can you be sure your "previously used" battery is in good condition and doesn't require replacement? Do you have access to another battery? Can you leave your phone tethered to a USB cable during the day until you can get a sense of what's going on? In only five days of use since you got it, it could still be settling the OS cleaning up after updates. How's your Wi-Fi signal? Your mobile signal too? If the signals are poor, the machine will chew up your battery in no time.

    If I were you, I'd nuke the phone and start over, factory reloading the OS and incrementally add apps back on (be sure to update them all after installation to be sure). I see you have already done this though.

    Also, this may be a long shot but it's something I'd seriously look into: I'd check the interior of the phone to see that the thermal paste is still in place and hasn't somehow come off or been disturbed by the previous owner. Thermal paste is like $9 at a computer store and it will most definitely help the CPU be kept cool (it interfaces between the CPU and metal heat plates inside the phone). Since all these phones have passive cooling, this is the ONLY way to keep the phones from overheating. Opening the phone requires some specialized screwdrivers (Torx T1 and T3 typically) by the way and aren't that easy to track down or that inexpensive unless you get lucky (I found an excellent set at Princess Auto being a 32 in 1 set that was on sale for $8.99 when I bought it but regularly $13.99 32 pc Precision Multidriver Set | Princess Auto ). YouTube has plenty of videos on dissasembly.

    When I replaced my Z10's screen (it was shattered), I changed out the thermal paste too...mine looked like grey hardened toothpaste and was NOT doing a good job in transferring heat. Once I cleaned mine off with rubbing alcohol and reapplied it, it was running much cooler to the touch.

    Oh and BBM is definitely not the problem.
    Last edited by chaosdivine; 03-11-15 at 01:47 PM.
    03-11-15 01:27 PM
  15. kbz1960's Avatar
    What's your signal like?
    03-11-15 01:36 PM
  16. ssn494's Avatar
    Don't THINK so, but please could you tell me where I can check.

    Thanks
    I was mentioning about the feature for accessing your pc from your phone if you have turned that on from BlackBerry link. Try to turn off that in your pc and remove any paired computers in device connections in your phone.

    Also can you check from device monitor is there any mobile data or wifi usage under system.
    03-11-15 01:48 PM
  17. Njae71's Avatar
    I was mentioning about the feature for accessing your pc from your phone if you have turned that on from BlackBerry link. Try to turn off that in your pc and remove any paired computers in device connections in your phone.

    Also can you check from device monitor is there any mobile data or wifi usage under system.
    Thanks. I have turned that on, but the phone was chewing through battery before I did so, and I have the wifi off and it's still doing so.

    As I've mentioned before, in Settings: Data Management, the Mobile Data Usage section just scrolls constantly, not loading anything and not stopping - I suspect this is the problem, but I'm unfortunately not seeing anything here that can help me with what to do about it.
    03-12-15 09:28 AM
  18. Njae71's Avatar
    What's your signal like?
    Pretty good.
    03-12-15 09:28 AM
  19. Njae71's Avatar
    I realize that your System is taking up most of your battery life but did you just update to 10.3.1? Have you done any OS updates since you got the phone? How can you be sure your "previously used" battery is in good condition and doesn't require replacement? Do you have access to another battery? Can you leave your phone tethered to a USB cable during the day until you can get a sense of what's going on? In only five days of use since you got it, it could still be settling the OS cleaning up after updates. How's your Wi-Fi signal? Your mobile signal too? If the signals are poor, the machine will chew up your battery in no time.

    If I were you, I'd nuke the phone and start over, factory reloading the OS and incrementally add apps back on (be sure to update them all after installation to be sure). I see you have already done this though.

    Also, this may be a long shot but it's something I'd seriously look into: I'd check the interior of the phone to see that the thermal paste is still in place and hasn't somehow come off or been disturbed by the previous owner. Thermal paste is like $9 at a computer store and it will most definitely help the CPU be kept cool (it interfaces between the CPU and metal heat plates inside the phone). Since all these phones have passive cooling, this is the ONLY way to keep the phones from overheating. Opening the phone requires some specialized screwdrivers (Torx T1 and T3 typically) by the way and aren't that easy to track down or that inexpensive unless you get lucky (I found an excellent set at Princess Auto being a 32 in 1 set that was on sale for $8.99 when I bought it but regularly $13.99 [Link redacted, as I'm not allowed to post it]. YouTube has plenty of videos on dissasembly.

    When I replaced my Z10's screen (it was shattered), I changed out the thermal paste too...mine looked like grey hardened toothpaste and was NOT doing a good job in transferring heat. Once I cleaned mine off with rubbing alcohol and reapplied it, it was running much cooler to the touch.

    Oh and BBM is definitely not the problem.
    Phew! OK: Yes, both when I initiated the phone and after I did the wipe, the phone loaded 10.3.1. I've checked for updates, and I have the most up-to-date version. I have actually wondered about loading an older version, in the hope that this will stop the battery chewing issue, which I still think is to do with the constant scrolling in the Mobile Date Usage section of the Device Monitor - anyone know how I can try this?

    I don't know the condition of the battery - and I can neither check it or do anything about it, since the battery on the Classic is not meant to be user-replaceable. I'm not going to open it up, as if I don't manage to get some help here, I will return it to the seller and I want to do that withthe phone as untouched as possible.

    Phone has spent a substantial amount of time over the last 2 days tethered to a computer via a USB cable, as that's how I've backed up and restored data.

    Wifi and mobile signal both very good.

    I think the heating is to do with the constant scrolling I've mentioned.

    Anyone here from the UK running a Classic on Vodafone Pay As You Go? I wonder if the Mobile Data Usage constant scrolling and not loading issue is to do with that.

    Thanks for all help so far.
    03-12-15 09:39 AM
  20. chaosdivine's Avatar
    Well you're due here for another update to fix the 10.3.1 fiasco so that's progress. Hopefully that update helps. I don't have mine on my Z10 yet but I hear it's coming eventually. Oh, and I messed up suggesting a battery swap, in my haste to write out my novel I didn't clue in that your battery is not replaceable (well at least not without some surgery). If you get the update report back...
    03-13-15 02:49 PM

Similar Threads

  1. Z 10 Newbie - What Andriod Apps work on Z10?
    By tracks914 in forum BlackBerry Z10
    Replies: 8
    Last Post: 03-12-15, 10:34 AM
  2. is there an equivalent command to RSET for the Z30
    By CrackBerry Question in forum Ask a Question
    Replies: 3
    Last Post: 03-12-15, 09:35 AM
  3. Why I can't use my house Wi-Fi even I already connected?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 03-12-15, 08:57 AM
  4. My last post
    By chandannegi90 in forum BlackBerry Z10
    Replies: 2
    Last Post: 03-11-15, 12:43 PM
  5. Replies: 0
    Last Post: 03-11-15, 08:18 AM
LINK TO POST COPIED TO CLIPBOARD