1. CrackBerry Question's Avatar
    I tried to download again WAZE and is not running anymore
    05-16-15 08:29 AM
  2. eldricho's Avatar
    What version did you try downloading? It might help in diagnosing what the problem could be

    Have you tried running an older version already?
    05-16-15 01:32 PM
  3. Blacklatino's Avatar
    Yeah. I'm having issues as well. Switched and deleted the BlackBerry World version and uploading the Android version to see if it is any better.
    05-16-15 01:50 PM
  4. conite's Avatar
    Waze does not update well.

    Delete old version first, then download and install latest. Get it from Google Play either with Snap or Cobalt's modified Google Play Store app.

    Z30STA100-5/10.3.2.680
    Blacklatino likes this.
    05-16-15 01:56 PM
  5. semime's Avatar
    Yeah. I'm having issues as well. Switched and deleted the BlackBerry World version and uploading the Android version to see if it is any better.
    I too have been displeased with the BlackBerry World version of this app. Aside from the perpetual crashes on my Z30 there were enough minor annoyances to prompt me to give in and install the android version. I did so via Snap. So far it's run without skipping a beat and fully functional - something I wasn't used to with the BlackBerry World version.

    Posted via CB10
    Blacklatino likes this.
    05-19-15 12:07 AM

Similar Threads

  1. Most of my inbox deleted on passport
    By curvezzz in forum BlackBerry Passport
    Replies: 14
    Last Post: 06-15-15, 08:09 AM
  2. swipe delete not working
    By djankrik86 in forum BlackBerry Z10
    Replies: 14
    Last Post: 06-08-15, 10:17 AM
  3. What is this icon?
    By easytherm in forum BB10 Leaked/Beta OS
    Replies: 8
    Last Post: 06-07-15, 12:56 PM
  4. Email account not syncing in Wifi
    By Mr 2BB89DC6 in forum Ask a Question
    Replies: 10
    Last Post: 05-29-15, 05:54 PM
  5. Replies: 4
    Last Post: 05-17-15, 03:42 AM
LINK TO POST COPIED TO CLIPBOARD