1. krcndn's Avatar
    Is it compulsory to use BIS or BES to update my BB curve 8520...?
    09-02-14 02:56 AM
  2. zocster's Avatar
    I do believe a SIM with active BIS is required to update legacy BlackBerry devices.

    Sent from my white Q10 using Tapatalk
    krcndn likes this.
    09-02-14 03:04 AM

Similar Threads

  1. whine issues
    By droiddude in forum Ask a Question
    Replies: 2
    Last Post: 09-16-14, 09:11 PM
  2. Facebook issue in z10
    By Dethpuh Narzary in forum Ask a Question
    Replies: 3
    Last Post: 09-02-14, 09:37 AM
  3. z30 link software connection issues after 10.3 .0.1052 update
    By bakron1 in forum BB10 Leaked/Beta OS
    Replies: 2
    Last Post: 09-01-14, 04:30 PM
  4. BB World Disappearing Reviews, Issue Or Censure?
    By 3ldi5 in forum BlackBerry World
    Replies: 4
    Last Post: 09-01-14, 02:49 PM
  5. blackberry bold issue
    By Unregistered in forum Ask a Question
    Replies: 1
    Last Post: 09-01-14, 08:20 AM
LINK TO POST COPIED TO CLIPBOARD