1. CrackBerry Question's Avatar
    Hi Folks!
    I have recently switched from curve 9360 to BB Z10 STL100-1, since yesterday i have been facing a very peculiar problem, whenever i am trying to open anything by taping an icon the screen flickers for a split of a second and nothing happens and i stay on home screen. The touch screen is working fine, as i can slide through all tiles and windows. Touch and hold icons, also get delete option to delete an app.

    Although i can open calls (also can make/receive a call ), access BB hub or text msgs, but when i tap on a mail or a msg it would not open up, same outcome... it flickers and then nothing happens. Thankfully the only solace is that i can make and receive calls including using a dialing pad.

    Also I am able to slide up to unlock the phone and slide down to get the settings menu. There i can toggle on / off state of all features like rotation lock / mobile network / wifi / notifications / bluetooth / NFC etc but can not open any of them including settings.
    Neither is the device able to access the internet even though wifi turns on.

    Since i had made the device switch a couple of days back I had not taken a back up on bb link (How dumb!). Now its not even accessible from link so that i could back up and restore to factory settings. It shows connected. but in actions i can preform, i get either reconnect or reload to factory setting (without any backup ).

    Please suggest guys what to do next! I never encountered such an issue with my earlier BBs for past several years, a battery pull could have sorted this out, but here restarts and battery pulls don,t seem to work at all!
    06-22-14 01:37 PM
  2. WWBlondieDo's Avatar
    When you did the Device Switch, did it wipe your old phone? If not, I'd suggest reloading to factory settings then running the device switch again.
    06-22-14 03:57 PM

Similar Threads

  1. Added two new z10 s to the family
    By 40blind40 in forum General BlackBerry Discussion
    Replies: 11
    Last Post: 06-24-14, 12:21 PM
  2. Your Reviews on the z10
    By CupcakeQ in forum Ask a Question
    Replies: 8
    Last Post: 06-23-14, 05:49 AM
  3. Replies: 4
    Last Post: 06-22-14, 09:51 PM
  4. Replies: 4
    Last Post: 06-22-14, 01:49 PM
  5. My Hub has consistently been unresponsive everyday...
    By tw1g_007 in forum BlackBerry Z10
    Replies: 4
    Last Post: 06-22-14, 01:32 PM
LINK TO POST COPIED TO CLIPBOARD