1. muindor's Avatar
    Hello,

    I have a Z30 STA100-2 , on T-Mobile Germany since August 2014, it's on the official OS 10.2.2.

    Ever since I got it, I have this problem with the headset what came with it, which is:

    When I use it calling my girlfriend for example, I can hear her very well, but when I speak I can hear myself too through the headphones. (hearing my voice in my headphones).

    Also when I touch the microphone of the headset I can hear that, as well as when I walk and the microphone is bouncing on my jacket or my jumper I hear that in the headphones. It's really annoying.

    Is the headset damaged? What could that be?

    01-19-15 03:14 PM
  2. MobileMadness002's Avatar
    Did the issue persist when you tried another headset?
    01-19-15 04:36 PM
  3. muindor's Avatar
    Did the issue persist when you tried another headset?
    I'm the only one here with a BlackBerry so I haven't been able to try it with a BlackBerry headset.
    I tried to use my old iPhone headset but it wouldn't work at all.

    Could it be the phone what's causing that or is the culprit in the headset?

    01-19-15 05:02 PM
  4. muindor's Avatar
    I assume no one else has got this problem? Should I replace the headset?

    01-20-15 02:55 AM
  5. Carjackd's Avatar
    Try a hard reset on you device and see if that clears it up

    Executive Producer of a Bunch of Losers for a BBM Group that doesn't Exist via My Passport
    01-20-15 03:03 AM
  6. muindor's Avatar
    Try a hard reset on you device and see if that clears it up

    Executive Producer of a Bunch of Losers for a BBM Group that doesn't Exist via My Passport
    I can't even count anymore how many hard resets I've done.

    So could something be wrong with the headset itself? Or could it be software related? Or is something in the phone is broken?

    01-22-15 03:55 PM
  7. Lawrence Steinbach's Avatar
    I have this issue also since I got my Z30 direct from BlackBerry (unlocked STA100-5 on AT&T ). At first I thought it must be a software issue, since in the past I've had the same problem on Skype, though it worked fine with phone calls on Z10. But now I'm thinking if may be a hardware issue, since I've since installed several leaks and issue has persisted. I'm on 10.3.1.1949 right now, and need to update to the newest to see what happens. But I'm also using a Skull candy headset, which could be the problem also, even though it works fine on my Z10. I also have 5 different headsets of the same brand, and it is the same with all of them.
    01-23-15 06:16 PM
  8. screenVia's Avatar
    Is it guaranteed , I would take it right away to them before they start making excuses that I must done something bad to th phone.

    Posted via CB10
    01-24-15 12:03 AM
  9. muindor's Avatar
    It's so nice to see that I'm not the only one with this problem. However, it's definitely not nice for all of us having this problem. I got it back in August 2014 from my carrier here, so I assume I can't take it back without paying for a replacement.

    I'll try though. I hoped the new OS would fix this problem but apparently it doesn't. I might call my carrier to see what they say.

    01-24-15 02:53 AM
  10. Lawrence Steinbach's Avatar
    BlackBerry agrees with me that it is probably not a software problem, but a hardware one. My guess is a faulty headset jack. At any rate they are having me send it back to them to have it repaired. It can take up to two weeks to get it back. I will keep you updated. BTW, after 14 days has passed, you get no replacement device for your warranty, and no free tech support. The only way to get them to talk to you is to call your carrier and have your carrier call them to transfer you over. If your carrier has the Z30, they probably will just take care of the warranty for you. AT&T was trying to see if they could even though they don't carry it, which was nice of them, but I have to go through BlackBerry, and find a way to survive on a Q10 for a couple weeks.
    02-01-15 02:41 PM

Similar Threads

  1. TMobile must be sold
    By gariac in forum T-Mobile
    Replies: 11
    Last Post: 01-27-15, 07:53 AM
  2. My thoughts on the BlackBerry Q10
    By bozzg86 in forum BlackBerry Q10
    Replies: 26
    Last Post: 01-24-15, 11:46 AM
  3. Replies: 8
    Last Post: 01-20-15, 11:19 AM
  4. When will the Blackberry Classic be available on Sprint?
    By CrackBerry Question in forum Ask a Question
    Replies: 4
    Last Post: 01-20-15, 09:50 AM
  5. How do I remove information from my Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 01-19-15, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD