1. sejuramesh's Avatar
    Guys I am using BlackBerry z10, I purchased it on 25 April 2014, after 7 days it battery is not working as it before, when battery level come to 70 % then phone automatically swith off, when I charge then it's begin to charge from 70 %, so I went service centre, there they told me the battery has finished so it would be replaced, they replaced it and it took 26 days..
    After 26 days when I got new battery..I was happy, but placing new battery and after seven days again the same problem occurs...
    Now the battery only works for 2 hours...
    I using 10.2.0.3247 os now..
    Can any one help me what to do..?

    Posted via CB10
    07-15-14 02:13 PM
  2. sejuramesh's Avatar
    The OS is 10.2.1.3247

    Posted via CB10
    07-15-14 02:15 PM
  3. JAS0NB0URNE's Avatar
    Guys I am using BlackBerry z10, I purchased it on 25 April 2014, after 7 days it battery is not working as it before, when battery level come to 70 % then phone automatically swith off, when I charge then it's begin to charge from 70 %, so I went service centre, there they told me the battery has finished so it would be replaced, they replaced it and it took 26 days..
    After 26 days when I got new battery..I was happy, but placing new battery and after seven days again the same problem occurs...
    Now the battery only works for 2 hours...
    I using 10.2.0.3247 os now..
    Can any one help me what to do..?

    Posted via CB10
    You are saying TWO brand new batteries separately broke down on you after one week each? This is hard to believe.

    Posted with my ? Q10.
    habs_fan likes this.
    07-15-14 08:54 PM
  4. sejuramesh's Avatar
    It's true..


    Posted via CB10
    07-15-14 11:17 PM
  5. JAS0NB0URNE's Avatar
    It's true..


    Posted via CB10
    It is likely an issue with the phone itself and not the batteries in that case.

    Posted with my ? Q10.
    07-16-14 06:46 AM
  6. sejuramesh's Avatar
    So what should I do then..

    Posted via CB10
    07-16-14 02:10 PM
  7. m1kr0's Avatar
    Upgrade to the latest software (yours is pretty old), don't restore any backup settings and install BBVE (BlackBerry Virtual Expert). Run the app and see if any hardware issues show up. Check battery again and see if there is any improvement after a full charge. No change: take it back and request repair/replace.

    Z10 STL100-1, OS 10.2.1.3247
    07-16-14 02:22 PM

Similar Threads

  1. 9900 Microphone Problem! Won't Work on Calls, Works on Voice Notes
    By gr8belief in forum BlackBerry Bold 9930/9900
    Replies: 2
    Last Post: 07-21-14, 09:33 AM
  2. SD Card problems
    By lodownes09 in forum BlackBerry Z30
    Replies: 4
    Last Post: 07-18-14, 01:32 PM
  3. BlackBerry Bold 9900 earpiece speaker problem.
    By CrackBerry Question in forum Ask a Question
    Replies: 2
    Last Post: 07-15-14, 09:35 AM
  4. Camera problem.
    By Euniq Mulz in forum BlackBerry Z10
    Replies: 2
    Last Post: 07-15-14, 08:41 AM
  5. BSNL connection APN problem for Blackberry playbook
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 07-14-14, 02:13 PM
LINK TO POST COPIED TO CLIPBOARD