1. CrackBerry Question's Avatar
    whenever i try to make a i as a word itself, it makes it I. In the settings of keyboard there is substitutions. and there is this substitution from itself. i--->I I try to delete it but that substitution gets added itself again and again. auto capitalization after a period is turned off. I dont want to change languages whenever I want to make a not capitalized I with a dot on it. any ideas?
    04-15-17 01:36 AM
  2. Mirko935's Avatar
    Creating a multi-language keyboard would probably be the proper solution if your language has "i" as a word. It's in those same settings. With that you can type in three languages simultaneously without changing languages while getting spell check and suggestions for all three.

    Interestingly, I don't have that under substitution.
    04-15-17 01:52 AM
  3. guygardner73's Avatar
    The he word "I" is always a capital. I can't think of a time when you'd use a lower case letter.


    Posted via CB10
    04-15-17 02:46 AM
  4. ardakca's Avatar
    The he word "I" is always a capital. I can't think of a time when you'd use a lower case letter.


    Posted via CB10
    Well we have lower case I and i in Turkish. Usage of i is much more common but the Turkish keyboard on the priv uses ı as default.
    04-15-17 03:15 AM
  5. guygardner73's Avatar
    Well we have lower case I and i in Turkish. Usage of i is much more common but the Turkish keyboard on the priv uses ı as default.
    Oh, I see. I just sold my Priv so I can't experiment on your behalf. In the word substitution could you look at I and turn off the auto capitalization?

    Posted via CB10
    04-15-17 03:40 AM
  6. Mirko935's Avatar
    The he word "I" is always a capital. I can't think of a time when you'd use a lower case letter.


    Posted via CB10
    Only in English. For instance, in my language, Croatian, the word "i" means "and". So, it's a pretty common word, to put it mildly.
    04-15-17 04:04 AM
  7. ardakca's Avatar
    Oh, I see. I just sold my Priv so I can't experiment on your behalf. In the word substitution could you look at I and turn off the auto capitalization?

    Posted via CB10
    Nope it doesn't work. Would be cool if BlackBerry let us have ı when i is doubletapped quickly for the Turkish keyboard but I don't expect it anytime soon.
    04-15-17 04:15 AM
  8. guygardner73's Avatar
    Nope it doesn't work. Would be cool if BlackBerry let us have ı when i is doubletapped quickly for the Turkish keyboard but I don't expect it anytime soon.
    Ok, try this as a workaround, in word substitution set it up so that the letter Z or any other suitable letter produces a small I.

    Posted via CB10
    04-15-17 10:30 AM
  9. Uzi's Avatar
    Long press i then swipe up?
    04-15-17 10:37 AM
  10. ardakca's Avatar
    Ok, try this as a workaround, in word substitution set it up so that the letter Z or any other suitable letter produces a small I.

    Posted via CB10
    Would work for our Croatian friend. But since the words contain ı word substition does not work with me. No problem though I got used to it. It is OK when typing with the VKB but with the PKB I hate it since I have to press hold then swipe to i almost every word.
    04-15-17 10:38 AM
  11. Mirko935's Avatar
    What are you guys talking about? You can type regular "i" with no issues whatsoever and no workarounds required, just set your language preferences correctly.
    04-19-17 09:28 AM
  12. ardakca's Avatar
    What are you guys talking about? You can type regular "i" with no issues whatsoever and no workarounds required, just set your language preferences correctly.
    Thanks. Solved all our problems )
    04-19-17 10:24 AM
  13. Mirko935's Avatar
    Thanks. Solved all our problems )
    Oh, I just realized that Turkish has both lowercase and uppercase "i" with and without the dot... I guess then you could type it similar to how I type words with "č", "ć" etc. by typing the word with a regular "c" and when I type the whole word a suggestion appears with "c" replaced with the character that I need. e.g. for "čekam" I can type "cekam" and then a suggestion appears so I can just swipe up on the keyboard, no long-pressing keys for individual letters needed.
    04-19-17 10:55 AM
  14. ardakca's Avatar
    Oh, I just realized that Turkish has both lowercase and uppercase "i" with and without the dot... I guess then you could type it similar to how I type words with "č", "ć" etc. by typing the word with a regular "c" and when I type the whole word a suggestion appears with "c" replaced with the character that I need. e.g. for "čekam" I can type "cekam" and then a suggestion appears so I can just swipe up on the keyboard, no long-pressing keys for individual letters needed.
    You are right for messaging and such but entering a Web address is a pain since the default is lower case I and the world don't use other than English . Just a little frustrating but it is there
    04-19-17 12:24 PM
  15. erose75's Avatar
    One option: type the letter "I" and space and it will capitalize, then back space twice and space once. It will leave it lower case.
    04-19-17 12:50 PM
  16. Mirko935's Avatar
    You are right for messaging and such but entering a Web address is a pain since the default is lower case I and the world don't use other than English . Just a little frustrating but it is there
    Perhaps a multi-language keyboard with English as primary could help? Have you tried that?
    04-19-17 12:55 PM
  17. ardakca's Avatar
    Perhaps a multi-language keyboard with English as primary could help? Have you tried that?
    I am using it like that but then the lower case I is gone forever. I change the keyboard language via shift+enter and that works for me well. But I would have preferred BlackBerry make i the default not the lower case I (without the dot) when using the Turkish keyboard. Would have solved my frustration . I commented on the play store plus tweeted a couple of times but no luck.
    04-19-17 01:00 PM
  18. Mirko935's Avatar
    I am using it like that but then the lower case I is gone forever. I change the keyboard language via shift+enter and that works for me well. But I would have preferred BlackBerry make i the default not the lower case I (without the dot) when using the Turkish keyboard. Would have solved my frustration . I commented on the play store plus tweeted a couple of times but no luck.
    Just one more idea... The custom symbol layout. I use that to type all of the characters specific to Croatian in words I can't use suggestions for as they aren't in that dictionary. So I figure you could set that up. Then the letters you need would be just a swipe away, you wouldn't need to constantly change language or long press etc. It's in Keyboard Settings > Advanced > Customize layout. Though you probably already know this, but at least I tried.

    And one more thing... I just remembered, there is a guy on CB forums who is a BB employee and works in the Keyboard Development. Perhaps he could help you more than people who read Play Store comments and tweets. He was obviously quite interested in helping our German friends here:
    Alternative way for accessing german umlauts

    Sorry I can't help you more with your troubles.
    ardakca likes this.
    04-20-17 02:02 AM
  19. ardakca's Avatar
    Just one more idea... The custom symbol layout. I use that to type all of the characters specific to Croatian in words I can't use suggestions for as they aren't in that dictionary. So I figure you could set that up. Then the letters you need would be just a swipe away, you wouldn't need to constantly change language or long press etc. It's in Keyboard Settings > Advanced > Customize layout. Though you probably already know this, but at least I tried.

    And one more thing... I just remembered, there is a guy on CB forums who is a BB employee and works in the Keyboard Development. Perhaps he could help you more than people who read Play Store comments and tweets. He was obviously quite interested in helping our German friends here:
    Alternative way for accessing german umlauts

    Sorry I can't help you more with your troubles.
    Thanks for the suggestions but unfortunately the lower case I is somehow not considered as a symbol . Great effort though . I'll check the person. Thanks again for the heads-up.
    Mirko935 likes this.
    04-20-17 02:19 AM
  20. JAS0NB0URNE's Avatar
    Thanks for the suggestions but unfortunately the lower case I is somehow not considered as a symbol . Great effort though . I'll check the person. Thanks again for the heads-up.
    Is it possible for you to Copy it somewhere, and Paste it for a word substitution?

    Posted with my  Classic
    04-20-17 02:45 AM
  21. Mirko935's Avatar
    Thanks for the suggestions but unfortunately the lower case I is somehow not considered as a symbol . Great effort though . I'll check the person. Thanks again for the heads-up.
    It doesn't have to be
    Go to Custom and add Unicode 131, that's its hex Unicode code, according to Wikipedia. Fot the capital İ, 130.
    https://en.wikipedia.org/wiki/Dotted_and_dotless_I
    Then just assign it to a letter you wish.
    PRIV auto capitalizes letter i to I-screenshot_20170420-101311.jpg
    PRIV auto capitalizes letter i to I-screenshot_20170420-101315.jpg
    04-20-17 03:16 AM

Similar Threads

  1. Replies: 38
    Last Post: 04-19-17, 01:50 AM
  2. Replies: 23
    Last Post: 04-17-17, 02:56 PM
  3. Replies: 13
    Last Post: 04-16-17, 06:05 PM
  4. Guide: How to enable MMS without BIS
    By Shuswap in forum BlackBerry 7
    Replies: 2
    Last Post: 04-15-17, 08:18 AM
  5. How can I import my .bbb backup to my Priv?
    By SumanRani in forum Ask a Question
    Replies: 3
    Last Post: 04-15-17, 01:12 AM
LINK TO POST COPIED TO CLIPBOARD