1. CrackBerry Question's Avatar
    Hi everyone,

    I have scoured the internet for weeks trying to resolve this issue.

    I got a new, base-trim WRX with the 6.2" Clarion head unit. The unit is adequate for me because I'm not an audiophile and I have tweaked it to sound half-decent.

    The issue is that streaming audio from my Passport sounds terrible. It sounds very tinny, and very poor quality. I don't mean that I'm being picky, I mean it sounds like something is wrong. It's all fuzzy and full of static. The really strange part (for me) is that bluetooth calling audio is perfectly clear and has no issues. It's only audio streaming.

    Things I've done to try and resolve:

    1. Looked for update to the Clarion unit, but I seem to have the latest version
    2. wiped/autoloaded the Passport to the latest 10.3.3.2205
    3. installed the previous radio file 10.3.3.2164
    4. Re-paired the Passport to bluetooth a million times
    5.. Have since purchased a dtek60, which streams audio perfectly

    If I could get the bluetooth working I'd probably sell the dtek60. Apps and hardware specs aside, I just love the bb10 experience so much more.

    Any ideas? Recommended radio versions to try?
    03-31-17 01:30 PM
  2. coffee-turtle's Avatar
    It could be that particular Passport. Do you have another audio Bluetooth system/speaker you can use to connect and test?
    03-31-17 02:40 PM
  3. nathansw's Avatar
    I connect it to a UE Roll 2 on a regular basis to stream whatever from it and it's normal...

    I've definitely connected it to other things in the past too and it was fine.
    03-31-17 04:51 PM
  4. nathansw's Avatar
    Tried to the 10.3.3.2050 radio tonight and experienced the same issue.


    Anyone have any ideas on how to fix my Passport audio streaming to my car? Aside from getting a new head unit :\
    04-01-17 12:48 AM
  5. Rico4you's Avatar
    Sounds like a comparability issues within Passport. As it is approaching almost 3 yrs old these things can pop up! Not aware of a fix. But as you said via DTEK60 works perfectly which is great!
    04-01-17 03:13 AM
  6. nathansw's Avatar
    Any other ideas??

    Considering trying a cheap AUX bluetooth dongle as a workaround, but I'd love it to work better natively.
    04-02-17 08:17 AM
  7. coffee-turtle's Avatar
    Any other ideas??

    Considering trying a cheap AUX bluetooth dongle as a workaround, but I'd love it to work better natively.
    Did the AUX bluetooth workaround work for you? Odd that it is only this particular Clarion head unit that is giving the issue. I don't know much about it, but is it possible there is a firmware update on their side? I'm guessing there may be other devices that have a problem connectiong as well.
    04-04-17 02:50 PM
  8. nathansw's Avatar
    I haven't tried the AUX bluetooth device yet. I think I may just get a new head unit when it bothers me enough. Maybe Clarion/Subaru will come out with an update to resolve it at some point. As of right now the dealer says there's no update for me.
    04-05-17 12:40 PM

Similar Threads

  1. Classic or Passport ?
    By SathBerry in forum General BlackBerry Discussion
    Replies: 21
    Last Post: Yesterday, 07:52 AM
  2. Chen on Devices: "a multi-million unit a year situation"
    By paul360 in forum General BlackBerry Discussion
    Replies: 10
    Last Post: 04-18-17, 02:36 PM
  3. BlackBerry passport se back in stock?
    By ExQuiSiTeLy DiVinE in forum BlackBerry Passport
    Replies: 13
    Last Post: 04-02-17, 04:52 PM
  4. DTEK rating poor
    By cmassie in forum BlackBerry Priv
    Replies: 4
    Last Post: 03-31-17, 12:10 PM
  5. Transfer apps from Priv to Priv
    By Al Morgan in forum Ask a Question
    Replies: 2
    Last Post: 03-31-17, 11:48 AM
LINK TO POST COPIED TO CLIPBOARD