1. DrRobertino's Avatar
    I have an unlocked BELL Passport running up to date OS and no leaks.
    I currently live in Saudi and use an STC sim which works just fine when in Saudi.
    Before heading to Canada for the holidays I activated international roaming and purchased an international roaming data plan through STC carrier. Also confirmed that BELL and Telus are cooperative providers with STC.
    When I landed in Toronto all I get is SOS emergency service only. I've done manual search and auto but no carriers show up.
    Interestingly I drove to niagara falls and as soon as I crossed the border into USA, my phone immediately connected to ATT and I had my full data working perfectly.
    Then, as I came back into Canada it all went back to SOS emergency service!

    What gives???? Any help is greatly appreciated.

    Robertino  Passport
    12-23-15 05:34 AM
  2. DaFoxGrey's Avatar
    What is the exact model number of your Passport?
    12-23-15 08:00 AM
  3. DrRobertino's Avatar
    Sqw100-1
    OS 10.3.2.2474

    Robertino  Passport
    12-23-15 08:06 AM
  4. DaFoxGrey's Avatar
    Sqw100-1
    OS 10.3.2.2474

    Robertino  Passport
    May need raino's advice on this......

    But it sounds like the STC international data plan may have been activated for AT&T instead of Bell Mobility CA by your carrier.
    First try getting ahold of the STC customer support.
    12-23-15 10:01 AM
  5. DrRobertino's Avatar
    Did all that. It's setup for any country and they give you the select providers for each country which BELL and Telus are both included as well as ATT. I've contacted STC and they double checked the plan was active and there are no problems on the SIM from their end.

    Robertino  Passport
    12-23-15 11:10 AM
  6. DaFoxGrey's Avatar
    Did all that. It's setup for any country and they give you the select providers for each country which BELL and Telus are both included as well as ATT. I've contacted STC and they double checked the plan was active and there are no problems on the SIM from their end.

    Robertino  Passport
    OK, then I suggest sending raino a private message to see if he has any ideas:
    http://forums.crackberry.com/members/raino-3089745/

    He is extremely good at figuring out odd carrier/coverage issues like what you are having.
    12-23-15 02:21 PM
  7. raino's Avatar
    This is very weird. On one hand, OP has a SQW100-1, which not only good for Bell/Telus, it's the same model of phone they sell.

    Only thing I can think of right now would be to make sure the phone's Network Mode allows for a 3G/HSPA+ option (and isn't set to 2G only.) Settings>Networks and Connections>Mobile Network>Network Mode should show an option that includes 3G (like 3G and 2G,) because Bell and Telus don't have GSM 2G networks. So if the phone is forced to look for only 2G, it will show the SOS coverage indicator.

    In the same vein, exclude 4G as well, to eliminate any weird hand-off issues between 4G (a non call handling network) and 3G/HSPA+ (the network on which calls would be made.) So try setting the phone to an option where HSPA+ is the fastest network you can connect to--an option like 3G and 2G for example.
    DaFoxGrey likes this.
    12-23-15 11:06 PM
  8. DrRobertino's Avatar
    Holy F*#@&'n ****. You've done it!!!!!!
    So, I had my network on 4g, 3g and 2g and got nothing in Canada but worked in the USA. Now back in Canada I switched to just 3g and 2g mode and BOOM voice and data are both working!!!!
    One strange thing is that the network shows not as BELL or Telus but as STC and no roaming symbol either. Any ideas on that??

    This is awesome, it's been driving me nuts for days!!!!
    Thank you so much for your help and as well to the person who referred you, I knew I'd be able to get an answer here!!!

    Robertino  Passport
    DaFoxGrey likes this.
    12-24-15 04:53 AM
  9. DrRobertino's Avatar
    So I tried switching back to 4g,3g and 2g mode just out of interest and once again I lost all connectivity. I switched back to 3g and 2g and manually selected an STC network option that did NOT say GSM as a possible mode and I regained all connectivity again. Thanks to Raino's suggestion that Bell and Telus don't have GSM 2g Any longer.

    Robertino  Passport
    Last edited by DrRobertino; 12-24-15 at 05:20 AM.
    12-24-15 04:58 AM

Similar Threads

  1. In need of an E-Mail Geek
    By Rowe6 in forum BlackBerry Priv
    Replies: 6
    Last Post: 12-24-15, 10:03 AM
  2. Amazon Problem
    By Hussain Afridi in forum BlackBerry Z30
    Replies: 1
    Last Post: 12-23-15, 04:32 PM
  3. Please I forgot my BlackBerry account password and want to know if it will be possible to retrieve it?
    By CrackBerry Question in forum BlackBerry Storm 9530/9500 Themes
    Replies: 2
    Last Post: 12-23-15, 05:06 AM
  4. WiFi help?
    By Tanya Frost in forum BlackBerry Priv
    Replies: 1
    Last Post: 12-22-15, 06:10 PM
  5. Cal/Dav help needed
    By scrannel in forum BlackBerry Z10
    Replies: 4
    Last Post: 12-22-15, 06:05 PM
LINK TO POST COPIED TO CLIPBOARD