1. Neanderthal's Avatar
    Hi I am a new BlackBerry user and just got my Z30 today. I like this device a lot but can't access the BlackBerry World any more. It says a protocol error occurred (504). I just can't use BlackBerry World because of this. Does anyone have any idea? Please help.

    Posted via CB10
    12-15-14 02:41 PM
  2. treaker's Avatar
    I had that error with my Z10, and it disappeared after a day. Not sure what the problem was.

    Posted via CB10
    12-15-14 02:50 PM
  3. Yassbittar's Avatar
    If you got it today, then you can do a security wipe from the settings without worrying too much about backing up months of app data and media.

    You could try either that, or reset it to factory settings using BlackBerry Link.
    12-15-14 09:16 PM
  4. Neanderthal's Avatar
    Okay now I can seems like the problem went away on its own. I don't understand what happened there but I'm happy to open and download the app again
    Thanks a ton guys.

    Posted via CB10
    12-15-14 10:48 PM
  5. Neanderthal's Avatar
    Oh yeah and I am loving this device!!!!

    Posted via CB10
    12-15-14 10:49 PM
  6. nelsonningombam's Avatar
    I believe you have upgraded your os or BlackBerry World and interrupted. Restarting or reseting will help

    Posted via CB10
    12-15-14 11:07 PM

Similar Threads

  1. Privacy Screen for Z30
    By xposeurphoto in forum BlackBerry Z30
    Replies: 7
    Last Post: 06-27-15, 11:11 PM
  2. PlayOn not working on Z30
    By Robertino BB-Z10 in forum BlackBerry Z30
    Replies: 1
    Last Post: 02-09-15, 05:07 PM
  3. Z30 camera flash light lit up by itself!
    By pbfan in forum BlackBerry Z30
    Replies: 4
    Last Post: 12-16-14, 11:24 AM
  4. What model Z30 for ATT
    By trophyspot in forum Ask a Question
    Replies: 4
    Last Post: 12-15-14, 03:24 PM
  5. BlackBerry Z30 takes home 2014 Good Design award
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 1
    Last Post: 12-15-14, 03:21 PM
LINK TO POST COPIED TO CLIPBOARD